Subject: Re: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-method-08.txt

From: Magnus Westerlund <[email-masked]>
Date: Thu, 1 Apr 2021 12:27:20 +0000

Hi,

See below. 

On Wed, 2021-03-31 at 23:37 +0000, MORTON, ALFRED C (AL) wrote:
> 
> In Version 08, we have this statement in the Scope/Applicability section
> regarding the 
> algorithm:
> 
>    The load rate adjustment algorithm's goal is to determine the Maximum
>    IP-Layer Capacity in the context of an infrequent, diagnostic, short
>    term measurement.  It is RECOMMENDED to discontinue non-measurement
>    traffic that shares a subscriber's dedicated resources while testing.
> 
> We can express the limitations more clearly in the first sentence, 
> and augment the second sentence as follows:
> 
> The load rate adjustment algorithm's scope is limited to helping determine the
> Maximum IP-Layer Capacity in the context of an infrequent, diagnostic, short
> term measurement. It is RECOMMENDED to discontinue non-measurement traffic
> that shares a subscriber's dedicated resources while testing: measurements may
> not be accurate and throughput of competing elastic traffic may be greatly
> reduced.
> 

Yes, I think that is a good sentence. 

/Magnus

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 1 Apr 2021 12:53:11 +0000

bottom post:

> -----Original Message-----
> From: ippm <[email-masked]> On Behalf Of Magnus Westerlund
> Sent: Thursday, April 1, 2021 8:27 AM
> To: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]
> Cc: [email-masked]
> Subject: Re: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-method-08.txt
> 
> Hi,
> 
> See below.
> 
> > In Version 08, we have this statement in the Scope/Applicability
> > section regarding the
> > algorithm:
> >
> > We can express the limitations more clearly in the first sentence, and
> > augment the second sentence as follows:
> >
> > The load rate adjustment algorithm's scope is limited to helping
> > determine the Maximum IP-Layer Capacity in the context of an
> > infrequent, diagnostic, short term measurement. It is RECOMMENDED to
> > discontinue non-measurement traffic that shares a subscriber's
> > dedicated resources while testing: measurements may not be accurate
> > and throughput of competing elastic traffic may be greatly reduced.
> >
> 
[acm] 
Thanks. Did you also see the reply at the end of my message, regarding your question on competing traffic?

Al

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 1 Apr 2021 14:58:52 +0000

Hi,

I had actually missed that text at the bottom. But thanks for the answer. Yes, I
can understand that complete starvation was not achieved in that short timescale
for flow that are high rate. I think that is in the realm of what I expected. 

Cheers

Magnus

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 1 Apr 2021 15:03:22 +0000

Great. As I often said, we have completed lots of testing to reach this point.

So, with the text changes offered to resolve your comments on version 8 this week, are we now good-to-go?

-=-=-  Al -=-=-

> From: Magnus Westerlund <[email-masked]>
> Sent: Thursday, April 1, 2021 10:59 AM

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 1 Apr 2021 15:25:10 +0000

> week, are we now good-to-go?

Yes, I am satsified.

/Magnus

> > I had actually missed that text at the bottom. But thanks for the answer.
> > Yes,
> > I
> > > Thanks. Did you also see the reply at the end of my message, regarding
> > > your
> > > question on competing traffic?
> > > 
> > > Al
> > > 
> > > 
> > > > 
> > > 
> > >

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 1 Apr 2021 15:31:46 +0000

> Sent: Thursday, April 1, 2021 11:25 AM
[acm] 
Thanks! I will submit version 09 when my development laptop returns from service today..

> > > > > Subject: Re: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-
> method-
> > > > > 08.txt
> > > > >
> > > > > Hi,
> > > > >
> > > > > See below.
> > > > >

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 1 Apr 2021 22:12:41 +0000

Version 09 is submitted and available [0]. 

Thanks again for all discussions.

for the co-authors,
Al

[0] https://datatracker.ietf.org/doc/html/draft-ietf-ippm-capacity-metric-method

> From: ippm <[email-masked]> On Behalf Of MORTON, ALFRED C (AL)
> Sent: Thursday, April 1, 2021 11:32 AM
> To: Magnus Westerlund <[email-masked]>;
> [email-masked]
> Cc: [email-masked]
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
> 
> > Subject: Re: [ippm] I-D Action:
> > draft-ietf-ippm-capacity-metric-method-08.txt
> >
> > > Great. As I often said, we have completed lots of testing to reach
> > > this
> > point.
> > >
> > > So, with the text changes offered to resolve your comments on
> > > version 8 this week, are we now good-to-go?
> > >
> >
> > Yes, I am satsified.
> >
> > /Magnus
> [acm]
> > > > Subject: Re: [ippm] I-D Action:
> > > > draft-ietf-ippm-capacity-metric-method-
> > > > 08.txt
> > > >
> > > > Hi,
> > > >
> > > > can understand that complete starvation was not achieved in that
> > > > short timescale for flow that are high rate. I think that is in
> > > > the realm of what I expected.
> > > >
> > > > Cheers
> > > >
> > > > Magnus
> > > >
> > > >
> > > >
> > > > > > > In Version 08, we have this statement in the
> > > > > > > Scope/Applicability section regarding the
> > > > > > > algorithm:
> > > > > > >
> > > > > > > The load rate adjustment algorithm's scope is limited to
> > > > > > > helping determine the Maximum IP-Layer Capacity in the
> > > > > > > context of an infrequent, diagnostic, short term
> > > > > > > measurement. It is RECOMMENDED to discontinue
> > > > > > > non-measurement traffic that shares a subscriber's dedicated
> > > > > > > resources while testing: measurements may not be accurate and
> throughput of competing elastic traffic may be greatly reduced.
> > > > > > >
> > > > > >
> > > > > Thanks. Did you also see the reply at the end of my message,
> > > > > regarding your question on competing traffic?
> > > > >
> > > > > Al
> > > > >
> > > > >
> > > > > >
> > > > >
> > > > >
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ippm__;!!Bhd
> T!1J4omYdLjXoLVewCsKZf_1_IYNbMsymT4DAZoYTjNrJZSNO8FPgno4INX5YY$

---

From: "MORTON JR., AL" <[email-masked]>
Date: Tue, 27 Apr 2021 17:47:00 +0000

Hi Magnus,

I still see your DISCUSS on the ballot page for this draft.
Are you still able to clear your DISCUSS, or does someone else
need to do it now? (the draft is on the agenda this week).

Al

---

From: Martin Duke <[email-masked]>
Date: Tue, 27 Apr 2021 10:57:50 -0700

He doesn't have to clear the DISCUSS. It doesn't matter anymore.

On Tue, Apr 27, 2021 at 10:47 AM MORTON JR., AL <[email-masked]> wrote:

> > > So, with the text changes offered to resolve your comments on version
> 8 this
> > > week, are we now good-to-go?
> > >
> >
> > Yes, I am satsified.
> >
> > /Magnus
> >
> > > -=-=-  Al -=-=-
> > >
>
>

---

From: "MORTON JR., AL" <[email-masked]>
Date: Tue, 27 Apr 2021 18:00:51 +0000

Thanks for the clarification, Martin.
When I checked the ballot page and saw the big red box, I began to wonder...

From: Martin Duke <[email-masked]>
Sent: Tuesday, April 27, 2021 1:58 PM
To: MORTON JR., AL <[email-masked]>
Cc: Magnus Westerlund <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-method-08.txt

On Tue, Apr 27, 2021 at 10:47 AM MORTON JR., AL <[email-masked]<mailto:[email-masked]>> wrote:
Hi Magnus,

Al

> From: Magnus Westerlund <[email-masked]<mailto:[email-masked]>>
> To: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>