Subject: Re: [ippm] Erik Kline's No Objection on draft-ietf-ippm-ioam-data-12: (with COMMENT)

From: Tal Mizrahi <[email-masked]>
Date: Sun, 23 May 2021 09:33:47 +0300

Hi Erik,

Thanks for the comments.
We are currently working on an  updated version of the draft.
We propose the following changes based on your comments - please see inline.
Please let us know if there are further comments.

On Wed, Mar 24, 2021 at 3:27 AM Erik Kline via Datatracker
<[email-masked]> wrote:
>
> Erik Kline has entered the following ballot position for
> draft-ietf-ippm-ioam-data-12: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-ippm-ioam-data/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> [ section 5.4 ]
>
> * "deployed in a particular IOAM," -> "deployed in a particular IOAM-Domain,"
>   perhaps
>

Suggested text update:
OLD:
Given that the operator knows which equipment is deployed in
a particular IOAM
NEW:
Given that the operator knows which equipment is deployed in
a particular IOAM domain

> * I think perhaps it should be made clear, especially for the Incremental
>   Trace Option, that dynamic insertion of data might need to be moderated
>   "subject to any protocol constraints of the encapsulating layer", as it
>   were.
>
>
>

Suggested text update:
OLD:
IOAM transit nodes push their node
data to the node data list, decrease the remaining length
available to subsequent nodes and adjust the lengths and possibly
checksums in outer headers.
NEW:
IOAM transit nodes push their node
data to the node data list subject to any protocol constraints of the
encapsulating layer.
They then decrease the remaining length
available to subsequent nodes and adjust the lengths and possibly
checksums in outer headers.

Cheers,
Tal.

---

From: Erik Kline <[email-masked]>
Date: Sun, 23 May 2021 13:39:47 -0700

Thanks!

On Sat, May 22, 2021 at 11:34 PM Tal Mizrahi <[email-masked]>
wrote:

> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html