Subject: Re: [ippm] RFC 8321 and 8889

From: Cociglio Mauro <[email-masked]>
Date: Tue, 24 Aug 2021 12:54:48 +0000

Hi Martin and All.
The 2 bits described in RFC8321 are both implemented so I would rather simply elevate it to PS.
Regards.
Mauro

-------- Messaggio originale --------
Da: Martin Duke <[email-masked]>
Data: 23/08/21 21:35 (GMT+01:00)
A: "MORTON JR., AL" <[email-masked]>
Cc: "Ran Pang(联通集团中国联通研究院-本部)" <[email-masked]>, IETF IPPM WG <[email-masked]>
Oggetto: Re: [ippm] RFC 8321 and 8889

Hi Al, this is my impression as well. In a perfect world I would ask the WG to do a bis draft to inventory what is mature and to deprecate the bits that haven't seen real deployment. If it turns out that it's all deployed, then we could do a simpler document action.

Is this work that anyone is interested in taking on?

On Fri, Aug 20, 2021 at 9:41 AM MORTON JR., AL <[email-masked]<mailto:[email-masked]>> wrote:
Hi Martin,

While I don’t have a serious concern, I’d prefer to elevate the parts of 8321 that *were implemented* to PS.  I think I read that some parts were not implemented and I look to those who reported on their implementations to say what they did.

This thinning-out of non-implemented capabilities was a feature of Standards Track Advancement processes in the past, so it makes sense to apply it here as well.  I realize this means a new draft, but the processing could be accelerated to match the need.

If the entire RFC 8321 was implemented, then this point is a non-issue.

hope this helps,
Al

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Martin Duke
Sent: Friday, August 20, 2021 12:31 PM
To: Ran Pang(联通集团中国联通研究院-本部) <[email-masked]<mailto:[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] RFC 8321 and 8889

Thanks all,

I'm hearing strong consensus that 8321 should be a PS and somewhat weaker support for 8889, but no dissents.

If anyone has serious concerns, this would be a good time to say so.

On Fri, Aug 20, 2021 at 3:02 AM Ran Pang(联通集团中国联通研究院-本部) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Martin and WG,

The alt-mk described in RFC8321/8889 has been deployed in some of our networks.
It works well.
So I would like the WG consider elevate them to proposed standard.

Best regards,
Pang Ran.

From: Martin Duke<mailto:[email-masked]>
Date: 2021-08-13 02:26
To: IETF IPPM WG<mailto:[email-masked]>
Subject: [ippm] RFC 8321 and 8889
Hello IPPM,

(with AD hat on)

The IESG is currently considering
https://datatracker.ietf.org/doc/html/draft-ietf-6man-ipv6-alt-mark-08<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-6man-ipv6-alt-mark-08__;!!BhdT!04s1Z7EtCnJrifRI3dUP1d0hps2MsV_B1gLCAqMQ1jJwmHnx-jiXCBYQM6IB$>
which is the implementation of RFC 8321<https://urldefense.com/v3/__https:/www.rfc-editor.org/rfc/rfc8321.html__;!!BhdT!04s1Z7EtCnJrifRI3dUP1d0hps2MsV_B1gLCAqMQ1jJwmHnx-jiXCEt7L0EO$> and 8889<https://urldefense.com/v3/__https:/www.rfc-editor.org/rfc/rfc8889.html__;!!BhdT!04s1Z7EtCnJrifRI3dUP1d0hps2MsV_B1gLCAqMQ1jJwmHnx-jiXCD5jrkAO$> techniques in an IPv6 framework. IIUC, this is very much how things are "supposed to work" -- measurement definitions and methodology are done by IPPM, and the protocol-specific instantiations are in the respective working groups.

However, there are complications in that 8321 and 8889 are Experimental RFCs, and the ipv6-alt-mark draft is a Proposed Standard. This has resulted in text from 8321/8889 going into ipv6-alt-mark so that it can be elevated to PS. I'm told that, if the status quo holds, other drafts will reference ipv6-alt-mark to avoid a downref. This seems suboptimal.

I would prefer that we take one of the two following actions:
1) If the WG has consensus that we are comfortable that there is enough experience with 8321 and/or 8889 to elevate them to PS, I can initiate a document action to change their status.

2) If there is no such consensus, ipv6-alt-mark should be Experimental.

In either case, the draft can probably lose some of the duplicate text.

Logically, there is a third option -- that the bits of the RFCs copied in the draft are mature enough to be a standard, but that the others aren't. Though I'm not an expert, I doubt this is the case. But if people believe it to be true, we'll have to come up with new options.

I would be grateful for the working group's thoughts about these documents and the ideas therein. Is it reasonable for people to read and reflect on this by 26 August (2 weeks from today?)

Thanks,
Martin
如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]<mailto:[email-masked]>，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked]<mailto:[email-masked]> ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Mach Chen <[email-masked]>
Date: Wed, 25 Aug 2021 01:00:41 +0000

Hi all,

As I know, the two alternatives defined in RFC 8321 are both implemented, I also agree with idea to elevate RFC 8321 to PS.

Best regards,
Mach

From: ippm [mailto:[email-masked]] On Behalf Of Cociglio Mauro
Sent: Tuesday, August 24, 2021 8:55 PM
To: Martin Duke <[email-masked]>; MORTON JR., AL <[email-masked]>
Cc: Ran Pang(联通集团中国联通研究院-本部) <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] RFC 8321 and 8889

Hi Martin and All.

-------- Messaggio originale --------
Da: Martin Duke <[email-masked]<mailto:[email-masked]>>
Data: 23/08/21 21:35 (GMT+01:00)
A: "MORTON JR., AL" <[email-masked]<mailto:[email-masked]>>
Cc: "Ran Pang(联通集团中国联通研究院-本部)" <[email-masked]<mailto:[email-masked]>>, IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Oggetto: Re: [ippm] RFC 8321 and 8889

hope this helps,
Al

Thanks all,

Best regards,
Pang Ran.

(with AD hat on)

Thanks,
Martin

________________________________
[https://cdn.tim.ticdn.it/content/dam/flytoco-areapubblica-aemfe/tim_it/dem-assets/email_footer/banner_mail_1agosto.jpg]<https://on.tim.it/banner-mail-dip>