Subject: RE: Onerous requirement [Re: IPR for Standards Track only???]

From: Powers Chuck-rxcp20 <[email-masked]>
Date: Wed, 11 Jun 2003 14:22:55 -0700

Scott,

I support the proposals fron Brian and Scott, as well as Hung's suggested rewording.

On your point about redefining contribution being a change to running code, is this in fact the case in practice? I agree that the current Note Well statement does encompass more than just I-D submissions, but have any IPR disclosures been made to the IETF based on a verbal or email proposal before it showed up in an I-D? I personally haven't seen any, but that doesn't mean they haven't been made in the past.

I am just curious as to how in line folks are today with the current wording of the Note Well statement. 

regards,

Chuck

> -----Original Message-----
> From: Scott Bradner [mailto:[email-masked]]
> Sent: Wednesday, June 11, 2003 3:40 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: Onerous requirement [Re: IPR for Standards Track only???]
> 
> 
> the definition of contribution is taken directly from teh 
> note well note
> a change would be a change to current runing code
> 
> ---
> From [email-masked]  Wed Jun 11 16:35:07 2003
> From: "Ling, Hung C (Hung)" <[email-masked]>
> To: Scott W Brim <[email-masked]>, [email-masked]
> Subject: RE: Onerous requirement [Re: IPR for Standards Track only???]
> Date: Wed, 11 Jun 2003 16:31:01 -0400
> MIME-Version: 1.0
> X-Mailer: Internet Mail Service (5.5.2656.59)
> Content-Type: text/plain
> Sender: [email-masked]
> Errors-To: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.12
> Precedence: bulk
> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/ipr-wg>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Id: IPR-WG <ipr-wg.ietf.org>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/ipr-wg>,
> 	<mailto:[email-masked]?subject=subscribe>
> 
> I want to comment on two points:
> 
> A) I support the discussion from Scott Brim and Brian 
> Carpenter .  An alternative (perhaps simplier) choice of words:
> 
> 	6.2.1  Timing of disclosure under section 6.1.1
> 	The IPR disclosure required pursant to section 6.1.1 
> must be made 
> 	as soon as reasonably possible after the Contribution 
> is incorporated 
> 	into a submission to be published as an Internet Draft 
> or RFC, unless 
> 	the required disclosure is already on file.  For 
> example,..........   
> 
> 
> Compared to Scott Brim:
>      The Contributor or his or her employer or sponsor (if 
> any) or other
>      organization holding the rights to IPR, must submit an IPR
>      disclosure as soon as reasonably possible after the 
> Contribution is
>      incorporated into a submission to be published as an 
> Internet Draft
>      or RFC, unless there is already an IETF IPR disclosure by such
>      person(s) on file that relates to the Contribution.  
> 
> B) There has also been some discussion on what kind of 
> statements made during oral or electronic communications 
> constitutes "contribution".  I propose tightening up the 
> definition of "IETF contribution" in section 1 (c):
> 
> From:  
> 	"IETF Contribution": any submission to the IETF intended by the
>       Contributor for publication as an Internet-Draft or RFC (except
>       for RFC Editor Contributions described below) and any statement
>       made within the context of an IETF Standards Process. Such
>       statements include oral statements in IETF sessions, as well as
>       written and electronic communications....................
> 
> To:
> 	"IETF Contribution": any submission to the IETF intended by the
>       Contributor for publication as an Internet-Draft or RFC (except
>       for RFC Editor Contributions described below) and any statement
>       made within the context of an IETF Standards Process 
> that comments
> 	directly upon the substantive content of such a submission. Such
>       statements include oral statements in IETF sessions, as well as
>       written and electronic communications....................
> 
> 
> Thanks, Hung Ling
> 
> 
> -----Original Message-----
> From: Scott W Brim [mailto:[email-masked]]
> Sent: Tuesday, June 10, 2003 9:27 PM
> To: [email-masked]
> Subject: Re: Onerous requirement [Re: IPR for Standards Track only???]
> 
> 
> On Tue, Jun 10, 2003 03:50:57PM +0200, Brian E Carpenter allegedly
> wrote:
> > In section 6.1.1 we have
> > 
> > >    This requirement specifically includes Contributions that are
> > >    made by any means including electronic or spoken comments.  
> > 
> > How about changing this to:
> > 
> >    This requirement specifically includes Contributions 
> that are made
> >    by any means including electronic or spoken comments, unless the
> >    latter are rejected from consideration before a disclosure could
> >    reasonably be submitted.
> > 
> > and I think the same sentence is needed in 6.1.2. This 
> seems objective
> > to me (i.e. if an idea gets thrown out in less time than it takes to
> > prepare a disclosure, the disclosure isn't required.)
> > 
> >    Brian
> 
> We want to 
> 
>   - avoid unnecessary burdens on both participants and IPR 
> holders.  The
>     goal is lean, mean, efficient production of good technology.
> 
>   - ensure that if anyone is influencing the standardization process
>     while (personally and reasonably) knowing of related IPR, that it
>     gets disclosed.
> 
> It's true that one can influence the standardization process a lot
> through non-document "contributions".  On the other hand, several
> vendors have said that they feel daunted by having to keep track of
> disclosures possibly needed for every oral statement that 
> someone might
> make.  Stepping back for a minute, that requirement isn't really what
> we're after -- we only have it, reluctantly, because it's the only way
> we know to meet the above requirements.
> 
> I suggest that disclosing IPR related to such non-document
> "contributions" can be allowed to wait until the draft is 
> submitted.  If
> a "contribution" never bears fruit in a document, then it 
> doesn't matter
> who has the IPR on it.  However, we don't want anyone to be 
> able to send
> a lot of mail on a subject until a draft comes out, and then 
> go mum, and
> not have to disclose.  So, at the time the draft comes out, people who
> would have to disclose under the current proposed policy would still
> have to do so -- the chickens would come home to roost.  But the
> document would be the trigger.  
> 
> Functionally it's exactly the same as if the discloser had submitted a
> draft up front.  It's early enough in the process -- at the time of
> submission -- that the WG isn't completely derailed by late 
> disclosure.
> Also, I suspect this is how a lot of disclosures are handled anyway.
> People float ideas and see if they get taken up, and they 
> don't disclose
> unless and until that happens.
> 
> So whether Brian's amendment gets incorporated or not, I suggest an
> amendment to 6.2.1 (Timing of Disclosure Under 6.1.1).  It's pretty
> simple, just change "made":
> 
>   Old:
> 
>      The Contributor or his or her employer or sponsor (if 
> any) or other
>      organization holding the rights to IPR, must submit an IPR
>      disclosure as soon as reasonably possible after the 
> Contribution is
>      made unless there is already an IETF IPR disclosure by such
>      person(s) on file that relates to the Contribution.  
> 
>   New:
> 
>      The Contributor or his or her employer or sponsor (if 
> any) or other
>      organization holding the rights to IPR, must submit an IPR
>      disclosure as soon as reasonably possible after the 
> Contribution is
>      incorporated into a submission to be published as an 
> Internet Draft
>      or RFC, unless there is already an IETF IPR disclosure by such
>      person(s) on file that relates to the Contribution.  
> 
> 
> Finally, right now all the rewards and punishments go to the 
> IPR holder,
> not the participant who is responsible for the disclosure.  Right now
> there is no consistency in what happens to an individual who does not
> disclose IPR.  In the few cases I know of (this doesn't happen, or
> doesn't get detected, very often in the IETF), some have even 
> gone on to
> be considered respected leaders.  It would be nice if there were some
> kind of feedback for people who don't disclose.  I'm told that some
> people are hesitant to disclose IPR because it makes them feel ashamed
> in the working group.  It's hard to provide a carrot for disclosure.
> Can we provide some kind of stick?  Is there an allowed way 
> to say, for
> example, that if someone doesn't disclose they are not 
> allowed to submit
> any more WG drafts for some period of time, something like that?
> 
> Thanks ... Scott (Brim)
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg
> 
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Scott Bradner <[email-masked]>
Date: Wed, 11 Jun 2003 17:29:04 -0400 (EDT)

I'll be submitting a revision of the -technology tonight
I do not think that Hung's suggestion is needed based on the 
suggestion that Brian and swb made - so please look at teh revision
and see what you think

> but have any IPR disclosures been
> made to the IETF based on a verbal or email proposal before it showed up in an
> I-D?

there have been quite a few verbal disclosures of verbal contributions
and electrinic ones on mailing lists for mailing list contributions
but I do not recall any case wher someone submitted a formal disclosure
based on a verbal or mailing list comment

Scott