Subject: Re: Proposal for slight edit to section 6.2.1 of draft-ietf-ipr-t echn ology-rights-09.txt

From: Keith Moore <[email-masked]>
Date: Mon, 16 Jun 2003 00:19:43 -0400

> Keith, I think that is the holy grail we are seeking - how to define a
> trigger point which balances the (justifiable, IMO) desire by the working
> group to have IP information as early as reasonably possible, while not
> forcing patent holders to make guesses regarding what needs to be disclosed,
> and then be faced with the burden of constantly reviewing and refining those
> disclosures when those guesses prove inaccurate, or are undermined by later
> working group efforts.

It seems to me that our working groups ought to be considering multiple
solutions to many of our design problems, and if several of those solutions
involved IPR, working groups should have that information available to them
when making their decisions.  This would mean that IPR would quite often be
disclosed without being used, but that's as it should be.  In some cases,
writing the first internet-draft based on WG discussions is such a substantial
investment that the IPR really should have been disclosed before then.  

It may be that what we need is a formal way for WGs to state that they're
considering using some technology or set of technologies, in advance of
writing any detailed specifications, and where a WG can mention multiple
technologies as candidates.   Then we could require disclosure within NN
days of such an announcement.   We don't have anything like that in our process
now, but there's at least some interest in having working groups use more
actual engineering processes, so if those were introduced it might provide
useful milestones for IPR disclosure.

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Powers Chuck-rxcp20 <[email-masked]>
Date: Sun, 15 Jun 2003 20:29:09 -0700

Keith, I think that is the holy grail we are seeking - how to define a trigger point which balances the (justifiable, IMO) desire by the working group to have IP information as early as reasonably possible, while not forcing patent holders to make guesses regarding what needs to be disclosed, and then be faced with the burden of constantly reviewing and refining those disclosures when those guesses prove inaccurate, or are undermined by later working group efforts.

   My original suggestion was simply an attempt at wording which provided a more clearly defined point for this to occur. IMO, triggering the disclosure obligation once a Contributor becomes aware that his/her suggestions have become part of a document under discussion by some subset of a working group (even if it has not yet been submitted to the I-D editor) would balance these needs the best.

   What would be even better would be for the policy to just say: "use common sense, and when it looks like your contribution is getting serious consideration, disclose any IP you are aware of".  Unfortunately, I think the world's lawyer population is too high for this to be practical [sorry, Larry :)]

Chuck

> -----Original Message-----
> From: Keith Moore [mailto:[email-masked]]
> Sent: Sunday, June 15, 2003 12:27 PM
> To: Powers Chuck-rxcp20
> Cc: [email-masked]; Chuck Powers; [email-masked]; 
> [email-masked];
> [email-masked]
> Subject: Re: Proposal for slight edit to section 6.2.1 of
> draft-ietf-ipr-t echn ology-rights-09.txt
> 
> 
> > If we disclose some IP, and in the future the spec changes 
> substantially, it
> > doesn't mean that the disclosure was _wrong_, but it could 
> mean that it is
> > no longer relevant. Based on what THIS DOCUMENT says, we 
> are encouraged to
> > modify our disclosures if that happens. Doing that on a 
> regular basis costs
> > time and money, and argues for not disclosing until the 
> specification is
> > stable.
> 
> perhaps, but IETF's interests are in having the IPR disclosed 
> before it makes
> a substantial investment in it.  by the time the 
> specification is stable,
> that's way too late - unless of course the IPR is licensed 
> under very liberal terms.

---

From: "todd glassey" <[email-masked]>
Date: Mon, 16 Jun 2003 06:57:56 -0700

Multiple solutions to the IP dilemma will complicate and confuse the issue
further. IP Law and the contract that is created between the submitter of
materials and the IETF is a serious issue since many part of it are clearly
unenforceable in my opinion. What needs to happen is that less loopholes
need to be designed into the scenario. Not more issues open to
interpretation being added to further muddy the waters.

Todd Glassey
IP Owner

----- Original Message ----- 
From: "Keith Moore" <[email-masked]>
To: "Powers Chuck-rxcp20" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Sunday, June 15, 2003 9:19 PM
Subject: Re: Proposal for slight edit to section 6.2.1 of draft-ietf-ipr-t
echn ology-rights-09.txt

---

From: John C Klensin <[email-masked]>
Date: Mon, 16 Jun 2003 11:32:09 -0400

--On Monday, June 16, 2003 00:19 -0400 Keith Moore
<[email-masked]> wrote:

> 
> It may be that what we need is a formal way for WGs to state
> that they're considering using some technology or set of
> technologies, in advance of writing any detailed
> specifications, and where a WG can mention multiple
> technologies as candidates.   Then we could require disclosure
> within NN days of such an announcement.   We don't have
> anything like that in our process now, but there's at least
> some interest in having working groups use more actual
> engineering processes, so if those were introduced it might
> provide useful milestones for IPR disclosure.

FWIW, there is historical precedent in some standards bodies
(the ones I can remember at the moment are are in
non-Information Technology areas) for issuing a _public_ call
for comments, notices of IPR rights, etc., on a technology being
considered for standardization.  Of course, that call can't be
made binding on non-participants, and can work, at best, no
better than the communication mechanism used for the call.
Perhaps as a result, I haven't seen it used very often, and
didn't see it accomplish much.

But it is hard to think about where we would draw the line
between "technology being considered for standardization" and
"some bunch of ideas that people are passing around as part of
problem and solution definition".

        john

---

From: "todd glassey" <[email-masked]>
Date: Tue, 17 Jun 2003 07:30:22 -0700

John, it really doesn't matter as far as any court would be considered, both
instances cited below constitute clearly identifiable sessions (or
instances) where there is some genesis of Intellectual Property, and so both
need to be addressed.

I have always thought that there should be some release process involved
with registering for a mailing list and that to assure that they are all
current that this should be a yearly thing. That is getting a release from
every participant. Its really no big deal and could be easily accomplished
with a simple web or email based process (yech - unauthenticated as it
is)...

Todd
----- Original Message ----- 
From: "John C Klensin" <[email-masked]>
To: "Keith Moore" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, June 16, 2003 8:32 AM
Subject: Re: Proposal for slight edit to section 6.2.1 of draft-ietf-ipr-t
echn ology-rights-09.txt