Subject: Re: recourse if our rules are violated?

From: Todd Glassey <[email-masked]>
Date: Mon, 9 Apr 2007 16:12:08 -0700 (GMT-07:00)

-----Original Message-----
>From: "Joel M. Halpern" <[email-masked]>
>Sent: Apr 9, 2007 4:04 PM
>To: [email-masked]
>Subject: Re: recourse if our rules are violated?
>
>It seems to me that the timing is actually more important than the cases below.
>if a patent that appears to be relevant becomes known before approval 
>as an RFC, then clearly the WG should go back and decide, as the 
>rules indicate.

The claims of the patent are the key issue, and they will change with any Office Actions done by the PTO and will not be solid until the patent is issued.

>If the patent becomes known after approval, but before publication, I 
>would treat it the same as above, and get teh WG to decide if they 
>think it matters.

Since the claims of the patent will not be 'solid' until the patent is issued this may not work either.

>If the patent becomes known after publication as an RFC, then we can 
>not unpublish the RFC.  

Why not? this is one of the key failings in the IP managment framework of the IETF. Because the IETF cannot unpublish things (i.e. terminate any external rights-to-use which are granted) then it is liable for any damages that occur therein. This is really simple liability analysis.

> We publish the IPR disclosure.  The question 
>is whether, assuming the RFC is standards track, we need to do 
>anything.  

I agree - and the first thing an IPR filing should do is to trigger a flag to be raised on that effort and also to tell the IETF that there is an IPR response needed before any formal advancement on that effort is done. This is especially critical since the IETF's publication model is a 1-way trip into print.

> It seems to me that this can not be dealt with by a rule, 
>or even an ION.  The correct response is going to depend upon a lot 
>of circumsttances, and the WG may not even exist anymore to be asked.
>
>Note for those who don't live this: determining whether a patent 
>applies to the practice described in an RFC is best described as an 
>art.  And probably as an indefinite art.  I have seen patents 
>applied, many years after granting, in ways I would never have 
>thought possible.
>
>John raised the question of a known bad faith participant.  That 
>seems a dangerous place to go.  Without an actual court ruling, I can 
>not see how we could reasonably take action on a supposition of bad 
>faith.  (That does not mean that folks can not be made aware of what 
>happened, and that such may not influence reactions to other 
>proposals from that source.  But no official sanction seems practical.)
>
>Yours,
>Joel M. Halpern
>
>At 12:49 PM 4/9/2007, Steven M. Bellovin wrote:
>>The IETF chair, Russ Housley, would like the opinion of the IPR WG on
>>what to do when an IPR disclosure occurs belatedly.  There are three
>>cases I can see:
>>
>>         (a) Intentional non-disclosure
>>
>>         (b) Unintentional non-disclosure (which appears to be the case
>>         in the situation currently under discussion on the IETF mailing
>>         list)
>>
>>         (c) Third-party patents that were not known to the WG or the
>>         IETF when the document was adopted.
>>
>>Our focus thus far has been on (a), and our attitude has been "let the
>>government(s) take action" (see, for example, the Rambus case
>>( http://www.law.com/jsp/article.jsp?id=1161606920964 ) and the Dell
>>case ( http://www.ftc.gov/opa/1995/11/dell.htm ).  We've traditionally
>>assumed there was nothing we could do about (c), since such patents
>>could appear at any time
>>
>>The questions, then, are these:
>>
>>         Should the IETF have a formal policy?  Alternatively, should we
>>         leave it to the IESG's judgment?
>>
>>         If we do have a formal policy, what should it be?
>>
>>         Should it be expressed in an RFC or an ION?
>>
>>
>>                 --Steve Bellovin, http://www.cs.columbia.edu/~smb
>>
>>_______________________________________________
>>Ipr-wg mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/ipr-wg
>
>
>_______________________________________________
>Ipr-wg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Todd Glassey <[email-masked]>
Date: Mon, 9 Apr 2007 20:45:14 -0700 (GMT-07:00)

If you are going to do this then this also needs to be captured in the BCP's.

Todd

-----Original Message-----
>not unpublish the RFC.  We publish the IPR disclosure.  The question 
>anything.  It seems to me that this can not be dealt with by a rule,

---

From: Todd Glassey <[email-masked]>
Date: Tue, 10 Apr 2007 17:28:11 -0700 (GMT-07:00)

The problem Harald is that those are two types of comments that someone who owns and has authoritative knowledge of those rights would have to submit. The other issue you havent dealt with is when someone else files a 'I think there are outstanding IPR issues here' notice. And that should require those people submitting the Work Product to react and either confirm through a license which documents those claims, or a release which clearly states that they are not asserting any claims therin.

Todd

-----Original Message-----
>From: Harald Tveit Alvestrand <[email-masked]>
>Sent: Apr 10, 2007 2:44 PM
>To: Frank Ellermann <[email-masked]>, [email-masked]
>--On 10. april 2007 20:06 +0200 Frank Ellermann <[email-masked]> 
>wrote:
>
>> John C Klensin wrote:
>>
>>>> I'm not sure what that leads to in terms of IETF procedures.
>>>> We're still left with two choices: ignore the IPR claim or
>>>> ignore the technology.
>>
>>> I would have chosen a different verb than "ignore", but, yes,
>>> that is the problem and, at least, the reason we need to make
>>> careful case-by-case decisions.
>>
>> How about a default rule "remove RFC from standards track" that
>> can be overruled by an IETF consensus ?
>
>Remember that two of the possible kinds of IPR disclosures are:
>
>- "oops, we forgot to tell you about this patent, here's the license that 
>clearly and unambiguously gives you permission to use it in any way you 
>want to"
>
>- "oops, we forgot to tell you about this patent, here's a pile of legal 
>mutterings that tell you absolutely nothing and will leave you wondering 
>about the ability to use the technology for the next 20 years"
>
>and every shade in between.
>I don't like "default" rules.
>
>                    Harald
>
>
>

---

From: [email-masked] (Scott O. Bradner)
Date: Fri, 13 Apr 2007 16:44:34 -0400 (EDT)

> I am puzzled. For some years now, our RFC have been carrying the boiler plate
> "   The IETF invites any interested party to bring to its attention any
>    copyrights, patents or patent applications, or other proprietary
>    rights that may cover technology that may be required to implement
>    this standard.  Please address the information to the IETF at
>    [email-masked]."
> so this situation was contemplated at least three years ago (I first saw it in
> RFC3710:-).
> 
> So what did whoever introduced that text intend to happen?

that a notice would be published in the IETF claimed IPR list

Scott