Subject: [iPRP] Parallel Redundancy Protocol for IP Networks - iPRP

From: Popovic Miroslav <[email-masked]>
Date: Thu, 22 Oct 2015 16:33:00 +0000

Assume you have the problem of ensuring reliable packet delivery of UDP streams with hard-real-time constraints. Such a requirement is common for critical industrial processes, smart grids, high-frequency trading and online gaming.

A common solution is to duplicate packets over fail-independent paths in order to ensure 0-ms packet repair. Prior to our work the only generic method to perform this was at the MAC layer (PRP).

With iPRP, we propose a generic solution that works with all IP networks. It was developed for the EPFL smart grid project (smartgrid.epfl.ch). It runs on different flavours of Linux and on different devices (PCs, National Instruments CompactRIO).

More information: https://tools.ietf.org/html/draft-popovic-iprp-00

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 22 Oct 2015 17:43:58 +0000

Regarding this work have you looked at what the recently chartered DetNet WG is up to? Sounds like there is some level of interest overlap.

- Jouni

From: iPRP [mailto:[email-masked]] On Behalf Of Popovic Miroslav
Sent: Thursday, October 22, 2015 9:33 AM
To: [email-masked]
Subject: [iPRP] Parallel Redundancy Protocol for IP Networks - iPRP