Subject: [IPsec] One answer to sec 2.5 question about payloads in order

From: Dan McDonald <[email-masked]>
Date: Tue, 9 Sep 2008 22:00:00 -0400

In section 2.5, there is this:

   NOTE TO IMPLEMENTERS: Does anyone require that the payloads be in the
   order shown in the figures in Section 2?  Can we eliminate the
   requirement in the following paragraph?  If not, we will probably
   have to add a new appendix with the order, but there is no reason to
   do that if no one actually cares. {{ Remove this paragraph before the
   document is finalized, of course. }}

I don't think having the payloads in a specific order is going to present a
problem.  Just as long as we have a clear direction on what to do in the
presence of malformed payloads (e.g. Two instances of an IDi payload in one
packet is an error, right?), and what payloads MUST/SHOULD/MAY be there, I
think we're in okay shape.

I didn't see any previous e-mails on this, but I may have missed someone else
chiming in.

Dan
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 9 Sep 2008 19:35:15 -0700

>I didn't see any previous e-mails on this, but I may have missed someone else

You did not. Other chiming is appreciated.

--Paul Hoffman, Director
--VPN Consortium

---

From: Yoav Nir <[email-masked]>
Date: Wed, 10 Sep 2008 09:52:15 +0300

> You did not. Other chiming is appreciated.

I thought I did, and no, I don't care about the order of the payloads.
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: <[email-masked]>
Date: Wed, 10 Sep 2008 11:33:07 +0200

During implementation
it was not a help with a fixed order.  It has been a
help to work out (a) the count on the number of 
occurrences (the cardinality) of a payload in a packet 
and (b) any relations between payloads (for example if 
KE payload present, then also SA payload must be present),
and (c) any other constraints (for example CP(CFG_REQUEST) 
may appear only in an IKE request message).

(quote from IPsec-maillist-mail on Jun 22, 2007)

Christian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Paul Hoffman
> Sent: 10. september 2008 04:35
> To: Dan McDonald; [email-masked]
> Subject: Re: [IPsec] One answer to sec 2.5 question about 
> payloads in order
> 
> >I don't think having the payloads in a specific order is going to 
> >present a problem.  Just as long as we have a clear 
> direction on what 
> >to do in the presence of malformed payloads (e.g. Two 
> instances of an 
> >IDi payload in one packet is an error, right?), and what payloads 
> >MUST/SHOULD/MAY be there, I think we're in okay shape.
> >
> >I didn't see any previous e-mails on this, but I may have missed 
> >someone else chiming in.
>

---

From: Tero Kivinen <[email-masked]>
Date: Wed, 10 Sep 2008 15:30:37 +0300

Yoav Nir writes:
> >> present a

I also commented this in my long email earlier:
----------------------------------------------------------------------
Our implemnentation do not care about the order of the payloads except
in some specific places (CERT payloads and so on). 
----------------------------------------------------------------------

In general when sending packets it is sometimes easier if the payloads
can be in any order, as it allows reusing more of the code. When
parsing the incoming payloads, we do parse all of them first and then
we already has pointers to all specific payloads, so it does not
matter what was the order of the payloads in the packet (we do know
and preserve the order of same type of payloads, i.e. CERT payloads
and so on). 
-- 
[email-masked]
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec