Subject: [IPsec] Proposed changes to draft-ietf-ipsecme-iptfs-07

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 15 Mar 2021 18:53:38 +0300

Hi,

as suggested by Tero at IETF110 I've prepared concrete proposal for the text changes in draft-ietf-ipsecme-iptfs-07.
I tried to make minimal changes - mostly they consist of more accurate (as it looks to me) naming
of things and more accurate separation of AGGFRAG and IP-TFS. No bits on the wire are affected.
Document structure and section numbers are not changed. However, the name of the draft
is changed as well as its abstract.

The only technical change is in Section 2.2.3, where I suggest to change:

   When using the AGGFRAG_PAYLOAD in conjunction with replay detection,
   the window size for both MAY be reduced to share the smaller of the
   two window sizes.

to 

   When using the AGGFRAG_PAYLOAD in conjunction with replay detection,
   the window size for both SHOULD be reduced to share the smaller of the
   two window sizes.

I suggested it before but it seemed to be lost in a long list of suggestions.
The rational for this change: if reassembly window size is greater than
replay protection window size, then not yet reassembled packets will never be reassembled,
because needed fragments will never be received. So, having reassembly window longer
than replay protection window is a waste of resources, thus SHOULD instead of MAY.

Instead of long list of small suggested changes in the body of this message I've
edited the .txt version of the draft and fed current and my versions to rfcdiff.
The result is in attachment. Note that I didn't touch ToC.

Regards,
Valery.

---

From: Christian Hopps <[email-masked]>
Date: Fri, 19 Mar 2021 05:23:04 -0400

If there are no objections from the WG I will incorporate these changes with some edits (e.g., we refer to congestion control and non-congestion control as modes already so I'll need to change the way those are referred to, to avoid confusion with the new term "AGGFRAG mode").

Thanks,
Chris.

> On Mar 15, 2021, at 11:53 AM, Valery Smyslov <[email-masked]> wrote:
> 
> Hi,
> 
> <Diff_ draft-ietf-ipsecme-iptfs-07.txt - draft-ietf-ipsecme-iptfs-07-svan.txt.html>_______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec