Subject: RE: Requirements for IKEv2 implementations

From: Paul Hoffman / VPNC <[email-masked]>
Date: Thu, 1 May 2003 14:05:37 -0700

At 4:20 PM -0700 4/29/03, Gregory Lebovitz wrote:
>MY WG and Security Area member perspective:
>Certificates are good security and we should try as much as we can to help
>implementations adopt them.

That's what SHOULD is for. The current text says MUST.

>  Any worthwhile IKEv1 implementation today can
>handle certs.

Sorry, but that is just plain wrong. There are many "worthwhile" 
implementations that don't do certs. There are plenty of "worthwhile" 
implementations that do certs wrong, such as doing things with certs 
that the IKEv1 specs say they SHOULD NOT do.

>Market observer perspective:
>PKI has been a royal pain for many interested in IPsec VPNs. Just ask the
>PKI vendors. They have abandoned the application as a focus for their
>development, marketing and sales. At an absolute minimum, PSS is a MUST.

Exactly right. But there is no reason for two MUSTs for authentication.

--Paul Hoffman, Director
--VPN Consortium

---

From: Lauri Tarkkala <[email-masked]>
Date: Mon, 5 May 2003 18:51:35 +0300

On Wed, Apr 30, 2003 at 04:17:47PM -0400, Russ Housley wrote:
> Greg:
> 
> I question the PSS as the mandatory to implement.  While I am for an 
> advocate for this algorithm, I do not think that it is widely deployed 
> today.  I think that RSA PKCS#1 v1.5 is a more appropriate signature 
> algorithm for MUST.  RSA PSS is the up and coming signature algorithm, and 
> as such I think that SHOULD is the way to go.

I agree.

Technically PSS is superior to PKSC#1, but I have seen very
little support for it in practice. Considering that it would
be an advantage to preserve the ability to generate these
signatures on misc.  devices (smart-cards, USB tokens, and
other things I seldom see people using ;-) I would be in favor
of the above proposal.

Lauri

-- 
Lauri Tarkkala
SSH Communications Security Corp