Subject: 2401bis Issue # 77 -- Should AH be mandatory?

From: Karen Seo <[email-masked]>
Date: Thu, 25 Sep 2003 17:17:44 -0400

Folks,

Here's a description and proposed approach for:

IPsec Issue #:	77

Title:		Should AH be mandatory?

Description:
============
There has been discussion of simplifying IPsec by not requiring AH 
and supporting just ESP. However, there are clearly communities, 
e.g., Mobile IP, that are using AH.

Proposed approach:
==================
2401 bis will make AH support a MAY for IPv4 but a MUST for IPv6.

Thank you,
Karen

---

From: Michael Richardson <[email-masked]>
Date: Thu, 25 Sep 2003 18:30:09 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Karen" == Karen Seo <[email-masked]> writes:
    Karen> IPsec by not requiring AH and supporting just ESP. However, there
    Karen> are clearly communities, e.g., Mobile IP, that are using AH.

  I believe that it is being abandoned by these groups because we won't
adjust the specification to make it work properly for them.

] Train travel features AC outlets with no take-off restrictions|  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian/notebook using, kernel hacking, security guy");  [

---

From: Francis Dupont <[email-masked]>
Date: Tue, 30 Sep 2003 11:53:46 +0200

=> for Mobile IPv6 AH was possible (in fact many, including me, believe
it is better) but for simplicity it was removed from specs, first as
the default mechanism, then everywhere...

Regards

[email-masked]