Subject: Certicom IP Statement Regarding IKE

From: Russ Housley <[email-masked]>
Date: Wed, 04 Feb 2004 13:36:05 -0500

Dear IPsec WG:

The attached note was just sent to [email-masked], and it should 
appear on the IPR web page shortly.

Russ

= = = = = = = = = =

Dear Sir or Madam:

We wish to advise the IETF that Certicom believes it has rights
under patents and pending applications that relate to RFC 3526
"More Modular Exponential (MODP) Diffie-Hellman Groups for
Internet Key Exchange (IKE)", RFC 2409 "Internet Key Exchange",
Internet Draft (draft-ietf-ipsec-ikev2-12.txt) "Internet Key
Exchange (IKEv2) Protocol" and other IETF specifications using
MODP Groups (individually and collectively the "IKE
Specifications").  The applicable patents and applications
include, but are not limited to, US Patents #5,933,504,
#6,563,928, #6,078,667, #6,178,507, #6,195,433, US Patent
Application Publications #2001/0014153, #2002/0090085,
#2001/0021256, and any corresponding foreign applications.

Certicom will, upon written request, provide a nonexclusive,
royalty-free patent license, with reasonable terms and
conditions, under those patents issued to Certicom that contain
claims essential to the IKE Specifications and for which
Certicom is able to provide patent licenses, within the limited
field of use of MODP public key cryptography implemented using
the well known Groups 1 and 2 as defined in RFC 2409. This
patent license is available to all entities willing to grant
Certicom a reciprocal license.

Any party wishing to request a patent license should write to:

Tony Rosati
VP of Intellectual Property & Licensing
Certicom Corp.
5520 Explorer Drive, 4th Floor
Mississauga, ON L4W 5L1
Tel:(613) 254-9265

email: [email-masked]

---

From: chris stillson <[email-masked]>
Date: Thu, 5 Feb 2004 16:03:17 -0800

This doesn't currently apply to us, just to future use of elliptic
curve crypto in our IKE....

-- 

chris stillson
IPSEC crypto monkey
x82477

Note: Preceding comments written by an engineer. There is nothing
to read into them. He really has no hidden motives or agendas.

1.Right Understanding 2.Right Thoughts 3.Right Speech 4.Right Action 
5.Right Livelihood 6.Right Effort 7.Right Mindfulness 8.Right Concentration 
--Please inform author if he has forgotten about any of these

---

From: chris stillson <[email-masked]>
Date: Thu, 5 Feb 2004 16:58:58 -0800

> curve crypto in our IKE....

Sorry about that. just forwarding a bit of mail and missed a to....

chris stillson
IPSEC crypto monkey
x82477

---

From: chris stillson <[email-masked]>
Date: Fri, 6 Feb 2004 09:29:53 -0800

Russ Housley writes:
 > Chris:
 > 
 > I read the IPR statement differently.  I am not going to take any position 
 > about the patents. However, the second paragraph offers royalty-free use of 
 > the 768-bit and the 1024-bit MODP groups in RFC 2409.  These groups are 
 > used with Diffie-Hellman.
 > 
 > The IPS statement does not say anything about the other MODP groups, which 
 > implies that the situation will be different.

I didn't notice that. Yes they do make claim against 2409. Isn't it a
bit late for them to do that? I can understand them having claims on
ECC, but the modp stuff? How? The RFC is 6 1/2 years old.....

chris stillson
IPSEC crypto monkey
x82477

---

From: Russ Housley <[email-masked]>
Date: Fri, 06 Feb 2004 14:05:39 -0500

Yes, I believe that Certicom is claiming rights to all of the groups in RFC 
2409.  At leas that is how I interpret the statement, and that is the 
reason I thought it appropriate to post the IPR Statement to the WG mail 
list....

Each implementor needs to figure out their own way forward.

Russ

At 12:35 PM 2/6/2004 -0600, JianHua Feng wrote:
>Does that mean include group1, 2 in RFC 2409 ? They are all well-known and 
>have been used for years.

---

From: JianHua Feng <[email-masked]>
Date: Fri, 6 Feb 2004 12:35:07 -0600

Does that mean include group1, 2 in RFC 2409 ? They are all well-known and have been used for years.

Jianhua