Subject: RE: GLP, number portability and wireless subscribers

From: "Lu, Henry" <[email-masked]>
Date: Thu, 11 Mar 1999 18:16:05 -0600

Dear David,

I think what we can not afford is place a call to wrong number.
Whether we will reveal the true number or not is not
very important from my perspective. You have to know 
that SS7 network is not like IP network, there is no
network topology database information in SCP like
OSPF or BGP in IP world. This create problem for reconstructing
call routing from IP world. SS7 is per call base and do 
a SCP query if there is 800 or ported number. No matter
SIP or H.323, will be per call based through gateway query. 
We are still lock the protocol in old ways per call based. We can
not update IP world PSTN topology like what we are doing
in OSPF or BGP for the whole network in one database sync.
I hope it will help. Thanks.

Henry W. Lu

-----Original Message-----
From: David R. Oran [mailto:[email-masked]]
Sent: Tuesday, March 09, 1999 1:12 PM
To: Jonathan Rosenberg; [email-masked]
Cc: iptel
Subject: RE: GLP, number portability and wireless subscribers

I'm reluctant to bring this up, because some would view it as a corner
case or just a "feeeeture" of the PSTN, but when the PSTN does number
translation (or call forwarding in the network as well), the resulting
number is not revealed to the calling party. The pure directory scheme
would reveal the translated number since that's what would be put in the
end-to-end signaling (e.g. SIP, H.323). Do we care about this?

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, March 09, 1999 1:43 PM
> To: [email-masked]
> Cc: John Schnizlein; Greg Zhang; David R. Oran; Matt Squire; Scott
> Petrack; Alok Mittal; iptel
> Subject: Re: GLP, number portability and wireless subscribers
>
>
> Hussein F. Salama wrote:
> >
> > Jonathan Rosenberg wrote:
> >
> > >
> > > This begs the question, then: does the translation of the
> 800 number get
> > > done before the gateway selection process, or after? By
> doing it before,
> > > a gateway can be chosen which is, in fact, close to the
> real number
> > > being dialed. With 800 numbers, all gateways will be able
> to reach it.
> > > It seems that this opens the possibility of very
> non-optimal routing. A
> > > caller in NY that dials an 800 number, goes to a gateway
> in CA. The
> > > phone network there determines that the 800 number translates to a
> > > number in NY, and routes the call through the PSTN back
> to NY. However,
> > > if the translation occurs before gateway selection, the caller can
> > > choose a local NY gateway and do much better.
> >
> > Because of the above example, I think all types of translation (800
> > numbers or LNP) and mapping should occur prior to call
> routing. This is
> > particularly important for 800 numbers, because they have a regional
> > scope in many cases. The same 800 number may owned by
> company X in CA
> > and company Y in NY. In the above example, the call will be
> incorrectly
> > routed to company X instead of going to the originally intended
> > destination, company Y.
>
> This is another good example of why translation before
> gateway selection
> is a good idea. However, I'm not sure there is much we can do from a
> protocol perspective to prevent it. There may be valid reasons why a
> company would like to advertise an 800 number (only they own it, for
> example), and I'd rather not exclude this possibility. It seems like a
> sensible approach is to allow non-routing numbers in GLP, but mention
> that there are issues with them, and translation before routing is a
> good idea. Does this sound sensible?
>
> Scott P., of course, is right, that the translation service itself is
> outside the scope of iptel.
>
> -Jonathan R.
> --
> Jonathan D. Rosenberg                       Lucent Technologies
> Member of Technical Staff                   101 Crawfords Corner Rd.
> High Speed Networks Research                Holmdel, NJ 07733
> FAX:   (732) 834-5379                       Rm. 4C-526
> EMAIL: [email-masked]
> URL: http://www.cs.columbia.edu/~jdrosen
>

---------
This message came from the IETF IPTEL Working Group Mailing List.

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 12 Mar 1999 12:02:11 -0500

> From: Lu, Henry [mailto:[email-masked]]
> Sent: Thursday, March 11, 1999 7:16 PM
> To: 'David R. Oran'; Jonathan Rosenberg; [email-masked]
> Cc: iptel
Define "wrong number", please. If I have an 800 number and call to say
that I want it to ring 555-4545 instead of 555-7676 and then hang up, is
it "placing a call to a wrong number" if 555-7676 rings for the next 30
seconds while the tables are getting updated? This is no different from
the convergence properties of IP routing.

> very important from my perspective.
Really? This is not what I hear from my service provider friends, but as
I said I'd rather not worry about this so let's drop it for now.
Jonathan rightly points out that as long as you limit translation result
visibility to parts of the network the owner of the translation trusts,
things will be OK. The porblem arises if you simultaneously want to have
optimal routing AND information hiding.

> You have to know
> OSPF or BGP in IP world.
Yes, I know this.

> This create problem for reconstructing
Ok, I'll bite. Why not? Remember, we're not doing destination selection
in GLP, we're only doing route selection once the final routing-number
is already known.

---------