Subject: Re: Reg. Real time Transport Protocol

From: Rick Cobb <[email-masked]>
Date: Wed, 02 Jun 1999 14:55:25 -0700

Sure.  As I recall, that's the case for all the video formats,
particularly H.261, since an encoded macro block can be variable
length and a packet must start and end on macro-block boundaries.

-- ReC

Stanley Feng wrote:
> 
> I have a question:
> For each payload type in RTP, there is a static mapping to a payload
> format, is it possible the payload size is variable for some payload
> format?
> 
> Thank you in advance.
> 
> Stanley Feng
> 
> ---------
> This message came from the IETF IPTEL Working Group Mailing List.

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: Colin Perkins <[email-masked]>
Date: Wed, 02 Jun 1999 23:15:35 +0100

>length and a packet must start and end on macro-block boundaries.

And for some audio formats too, such as VDVI and all the sample based
codecs.

>> format, is it possible the payload size is variable for some payload

Remember also that the mapping is not always static, with control protocols
such as SIP signalling dynamic mappings.

Colin

---------

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 02 Jun 1999 18:25:53 -0400

> such as SIP signalling dynamic mappings.

Plus, for frame-based codecs, the number of frames per packet may vary
from call to call and within a call, unless it is declared via ptime in
SDP,

This discussion, however, belongs on the rem-conf list, not here.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---------

---

From: Stanley Feng <[email-masked]>
Date: Wed, 2 Jun 1999 17:18:04 -0400

I have a question:

Thank you in advance.

Stanley Feng

---------