Subject: RE: how to if a frame is RTP

From: "Khayami, Mohsen" <[email-masked]>
Date: Thu, 10 Jun 1999 15:10:28 -0500

--> Stanley Feng writes:
>Colin Perkins wrote:
>> --> Venkata Narasimha Murthy Nanduri writes:
>> >1) How can we know whether an RTP packet is encapsulated in the UDP data
>> >field?
>>
>> The RTP spec contains code to validate a packet, to ensure that it is RTP
>> data.
>
>So if I want to do some special operation on all the RTP packets, do I have
>to check the payload of every UDP packet? i.e., even if only 1% of the UDP
>packets contain RTP packets, I will have to do the checking for all the UDP
>packets?

Yes, unless you have used a signalling protocol to decide which ports are
used for RTP traffic. 

>> >2) If it is based on the UDP port numbers, then are there any standard
>> >UDP port numbers that will be used for RTP?
>>
>> The ports used for RTP traffic are signalled out of band using your
>> favourite control protocol (SIP, SAP, RTSP, H.whatever, etc...). There
>> are no standard UDP ports for RTP traffic.
>
>Since we can use control protocol to agree on some port for RTP traffic, I
>guess we are ok.

Right; this is how things normally work.

Colin

---------
This message came from the IETF IPTEL Working Group Mailing List.

Regards
Mohsen Khayami
Email: [email-masked]
Phone: 781-895-9110

> -----Original Message-----
> From: Chris James [mailto:[email-masked]]
> Sent: Thursday, June 10, 1999 3:56 PM
> To: [email-masked]
> Subject: how to if a frame is RTP
> 
> 
> First, appologies for the newbee question.
> 
> Given a hex dump of a UDP frame, how is it
> possible to know if the next layer is RTP?
> There is no assigned port to it.  Is there
> something in the frame data that distinguishes
> it?
> 
> Any help/pointers are appreciated.
> _________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.com address at http://mail.yahoo.com
> 
> 
> ---------
> This message came from the IETF IPTEL Working Group Mailing List.
> 

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: "Stephen Sprunk" <[email-masked]>
Date: Fri, 11 Jun 1999 10:53:40 -0500

It is common practice to start with 5004/5005 and work upwards from there
(eg. second stream on 5006/5007, third on 5008/5009, etc.)  However, not all
applications follow this practice; the VoIP implementation on Cisco IOS
starts at 16384 for example.

The only way you're going to reliably find RTP streams is examine your
signalling protocol.  H.323's signalling is painful to decode, but SIP/SDP
is relatively simple.

S

     |          |         Stephen Sprunk, K5SSS, CCIE #3723
    :|:        :|:        NSA, Network Consulting Engineer
   :|||:      :|||:       14875 Landmark Blvd #400; Dallas, TX
.:|||||||:..:|||||||:.    Pager: 800-365-4578 / 800-901-6078
C I S C O S Y S T E M S   Email: [email-masked]

    -----Original Message-----
    From: Stanley Pinjiang Feng <[email-masked]>
    To: Jonathan Rosenberg <[email-masked]>
    Cc: Chris James <[email-masked]>; [email-masked]
<[email-masked]>
    Date: Friday, June 11, 1999 10:30
    Subject: Re: how to if a frame is RTP

    This may be of interest. The following is from the newest version of
RFC1890: RTP Profile for Audio and Vedio Conferences with Minimal Control
section 8:
        Port numbers 5004 and 5005 have been registered for use with this
profile for those applications that choose to use them as the default pair.
Applications that operate multiple profiles may use this port pair as an
indication to select this profile if they are not subject to the constraint
of the previous paragraph.
    I would very much prefer to have these default UDP ports for RTP.
Again, we can use this default pair to agree on some other pair of ports so
that mutiple RTP sessions can be carried simultaneously between two IP
addresses.
    Thank you

    Stanley Feng

---------