Subject: Re: H.225 Alerting Frames

From: Beatles Fan <[email-masked]>
Date: Wed, 30 Jun 1999 13:49:05 -0700 (PDT)

Anybody have a name or URL?

--- Jonathan Rosenberg <[email-masked]> wrote:
> This question is probably best addressed by the h.323
> implementors list
> (if someone can please provide it).
> 
> -Jonathan R.
> 
> Beatles Fan wrote:
> > 
> > Hi,
> > 
> > I am looking at the raw data in VoIP frames.  In
> > particular H.225 frames.  One particular frame
> > has Message Type set to Alerting.  After the User
> > Info in the frame there are still 256 bytes that
> > have relevance.  This is evident from the contents
> > of some of this raw data.  It looks as if it is
> > setting something up on an Intel video phone.
> > 
> > I have enclosed a decode of the frame below and
> > have marked off where my decoding of the H.225
> > starts and ends.  I am interested in the bytes
> > after the 02 00 (beginning with 03 00 01 00 08 02 etc.)
> > The ITUT H.225 spec says that Alerting frames
> > are defined as follows:
> > 
> > Alerting-UUIE ::= SEQUENCE
> > {
> > protocolIdentifier      ProtocolIdentifier,
> > destinationInfo         EndpointType,
> > h245Address             TransportAddress OPTIONAL,
> > ...,
> > callIdentifier          CallIdentifier,
> > h245SecurityMode        H245Security OPTIONAL,
> > tokens                  SEQUENCE OF ClearToken OPTIONAL,
> > cryptoTokens            SEQUENCE OF CryptoH323Token OPTIONAL,
> > fastStart               SEQUENCE OF OCTET STRING OPTIONAL,
> > }
> > 
> > Here is where I lose it (thanks for bearing with me, it's
> > almost over).  Taking the protocolIdentifier, the H.225
> > spec defines it as follows:
> > 
> > [skip some H.225]
> > ProtocolIdentifier              ::=     OBJECT IDENTIFIER
> >                                                                
>                 -- shall be set to
> >                                                                
>                 -- {itu-t (0) recommendation (0) h (8) 2250      
>                                                                  
>             --
> > version (0) 2}
> > 
> > So does this mean that there should be a 00 00 08 02
> > following?  I don't see a pattern like this anywhere
> > (although I see something close with 03 00 01 00 08 02).
> > 
> > Am I missing something?  Does PER come into play?
> > 
> > ANY help is gratefully appreciated.  Thank you -
> > 
> > Chris
> > 
> > Here's the frame data with the start of H.225 marked out
> > 
> > 4B 95 FB C4 08 00 45 00   K.....E.
> > 01 3C 08 95 40 00 74 06   .<..@.t.
> > BE DC 86 86 F6 10 C0 A8   ........
> > 01 0B 06 B8 04 13 00 63   .......c
> > 4C E6 00 02 50 B1 50 18   L...P.P.
> > 21 43 DD 50 00 00 08 02   !C.P....   <-  H.225 starts w/ 08 02
> > E8 C2 01 7E 00 0C 05 03   ...~....
> > 00 06 00 08 91 4A 00 01   .....J..
> > 02 00 03 00 01 00 08 02   ........   <- H.225 ends with 02 00
> > E8 C2 07 04 04 88 18 80   ........
> > A5 28 12 54 65 73 74 20   .(.Test
> > 43 61 6C 6C 20 49 6E 74   Call Int
> > 65 72 6E 65 74 7E 00 DA   ernet~..
> > 05 12 40 06 00 08 91 4A   ..@....J
> > 00 01 00 86 86 F6 10 08   ........
> > 08 22 C0 B5 00 80 80 11   ."......
> > 49 6E 74 65 6C 20 56 69   Intel Vi
> > 64 65 6F 20 50 68 6F 6E   deo Phon
> > 65 00 0E 32 2E 31 31 2E   e..2.11.
> > 31 2E 37 2E 36 2E 31 2E   1.7.6.1.
> > 31 00 00 21 56 D8 B1 13   1..!V...
> > 12 D3 11 A3 B2 00 A0 C9   ........
> > 27 5D 69 40 B5 00 80 80   ']i@....
> > 80 88 76 69 64 62 6F 78   ..vidbox
> > 31 40 69 6E 74 65 6C 2E   1@intel.
> > 63 6F 6D 00 00 00 00 00   com.....
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 6C 64 61 70 2E 64   ..ldap.d
> > 69 72 65 63 74 2E 63 6F   irect.co
> > 6E 6E 65 63 74 65 64 70   nnectedp
> > 63 2E 63 6F 6D 00 00 00   c.com...
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 00 00 00 00 00 00   ........
> > 00 00 43 41 4C 4C 00 00   ..CALL..
> > 00 00                     ..
> > 
> > TCP (Transmission Control Protocol)
> >  Source Port      = H225 (1720)
> >  Dest Port        = 1043
> >  Sequence Number  = 6507750
> >  Acknowledgement  = 151729
> >  Data Offset      = 20 Octets
> >  Control Flags    = PSH,ACK
> >  Window Size      = 8515
> >  Checksum         = DD50H
> >  Urgent Pointer   = 0
> >  No TCP Options
> > 
> > H.225 Call Signalling
> >  Discriminator    = 8
> >  Call Ref Length  = 2
> >  Message Sent     = To Originator
> >  Call Ref Value   = 26818
> >  Message Type     = Alerting
> >  Info Element     = User-User
> >  User-User Length = 12
> >  Protocol Discrim = X.208 and X.209
> >  User Info        = 0x0300060008914A00010200
> > 
> >  Data Length      = 256 Bytes
> > 
> > _________________________________________________________
> > Do You Yahoo!?
> > Get your free @yahoo.com address at http://mail.yahoo.com
> > 
> > ---------
> > This message came from the IETF IPTEL Working Group Mailing
> List.
> 
> -- 
> Jonathan D. Rosenberg                       Lucent Technologies
> Member of Technical Staff                   101 Crawfords Corner
> Rd.
> High Speed Networks Research                Holmdel, NJ 07733
> FAX:   (732) 834-5379                       Rm. 4C-526
> EMAIL: [email-masked]
> URL: http://www.cs.columbia.edu/~jdrosen
> 

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: "Nancy-M Greene" <[email-masked]>
Date: Wed, 30 Jun 1999 17:04:54 -0400

The url for the archives is

http://www.imtc.org/mail/h323implementors/1999/

and for list subscription instructions,
send email to [email-masked] with text "info"

Nancy
--------------------------------------------------------------------------
Nancy M. Greene 
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From: 	Beatles Fan[SMTP:[email-masked]]
> Sent: 	Wednesday, June 30, 1999 4:49 PM
> To: 	[email-masked]
> Cc: 	[email-masked]
> Subject: 	Re: H.225 Alerting Frames
> 

---------

---

From: "El-Gebaly, Hani" <[email-masked]>
Date: Wed, 30 Jun 1999 18:32:06 -0700

Chris,

Here is the info needed to join the implementers group: 
for list subscription instructions,
send email to [email-masked] with text "info"

To answer your question, you are using a version 1 H.323 stack and hence the
protocol identifier is 0, 0, 8, 2250, 0, 1. 
Here is a description of the alerting raw PDU and how it is decoded. I am
not an ASN1 expert to explain why the fields are mapped that way but hope
that helps. 

LAYER:     Q931
RAW_PDU:  -   -   -   -   -   -   -   -   RAW PDU  -   -   -   -   -   -   -
-
	20 octets (hex output):
		08 02 f6 59 01 7e 00 0c 05 03 00 06 00 08 91 4a 
		00 01 02 00 
DECODED_PDU: -   -   -   -   -   -   -  DECODED PDU   -   -   -   -   -   -
-
PDU_TYPE: Alerting
	Protocol Discriminator: 8
	Call Reference:
		length (in octets): 2
		value (in hex): 76 59 , flag: 1 - destination side
	User-user:
		length: 12
		protocol discriminator: 5
		h323_uu_pdu: alerting:
			protocolIdentifier: 0, 0, 8, 2250, 0, 1
			destinationInfo:
				terminalInfo:

cheers,

Hani 

> -----Original Message-----
> From:	Beatles Fan 
> Sent:	Wednesday, June 30, 1999 1:49 PM

---------