Subject: Re: [Fwd: [IPTEL] TRIP Sequence Numbers]

From: "Bob Penfield" <[email-masked]>
Date: Mon, 2 Apr 2001 15:48:08 -0400

----- Original Message -----
From: "Matt Squire" <[email-masked]>
To: <[email-masked]>; "Bob Penfield" <[email-masked]>
Sent: Monday, April 02, 2001 10:52 AM
Subject: Re: [Fwd: [IPTEL] TRIP Sequence Numbers]

>
> >
> > In section 10.1.4 of draft-ietf-iptel-trip-04.txt it states:
> >
> >     When an LS first originates a route into its ITAD, it MUST originate
> >     it with a Sequence Number of MinSequenceNum.
> >
> > Is the LS required to do this:
> >     a) when it restarts/reboots, or
> >     b) when the route is added to its Local-Route database
> >
>
> The intention is that new routes start off with a sequence number of
> one.  Assuming that when an LS restarts, its local routing database is
> empty, then (b) covers (a).
>
For case (b), I mean when an administrator entered the route into some
persistant database. The sequence number would be 1 when the route was
created and incremented each time the administrator updated the route. Since
the route is stored in a persitent database, the routes sequence number
could survive reboots and restarts. When the LS reboots/restarts, its local
routes' seq#s are not reset to 1, they have what ever seq# is recorded in
the database.

>
> > If (b) is allowed, the situation described in 10.1.6 (where an LS
receives a
> > self-originated route with a seq# larger than what it currently has
recorded
> > for the route) could be avoided. If either (a) or (b) is permitted, I
think
> > section 10.1.4 should say something like "An LS MAY maintain Sequence
> > Numbers that are persistent across restarts/reboots".
> >
>
> I'm not sure how allowing (b) gets rid of the situation where an LS
> receives an old self originated route.
>
With (b), the route (and its sequence number) lives in a persistent database
that survives restarts/reboots and the LS would never advertive a route with
a seq# higher than what it previously had. If the LS receives a
self-originated route with a seq# higher than what it has recorded in the
persistent database, then there is something very wrong (either the database
has been changed, or someone else is orginating routes with the LS's TRIP
ID.

>
>
> I have no problem with allowing LSs to maintain sequence numbers across
> reboots.  My personal gut feeling is that it would not be worth the
> trouble, but there's certainly no reason to disallow the behavior.
> Hussein, it would be great if you could add this sentence to the
> Sequence Numbers considerations section (10.1.4).
>
> > Bob
> > d:-)
> >
> > Robert F. Penfield
> > Chief Software Architect
> > Acme Packet, Inc.
> > 130 New Boston Street
> > Woburn, MA 01801
> > [email-masked]
> >
> > _______________________________________________
> > IPTEL mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/iptel

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Bob Penfield" <[email-masked]>
Date: Mon, 2 Apr 2001 17:33:00 -0400

----- Original Message -----
From: "Matt Squire" <[email-masked]>
To: "Bob Penfield" <[email-masked]>
Cc: <[email-masked]>; "IPTEL List" <[email-masked]>
Sent: Monday, April 02, 2001 4:19 PM
Subject: Re: [Fwd: [IPTEL] TRIP Sequence Numbers]

> Bob Penfield wrote:
> Got it.  But just to be clear, *allowing* (b) where an LS stores info in
> a persistant database does not eliminate the possibility that a
> self-originated route is received with an out-of-whack sequence number.
> This possiblity would only be eliminated if (b) were the required
> behavior.
>
Agreed. An LS that does uses (b) is not relieved of the requirements of
section 10.1.6.  The language in 10.1.6 (which says "This should be a
relatively rare occurrence and indicates that a route still exists within
the ITAD since the LSs last restart/reboot") implies (a). I just want to
make sure persistent sequence numbers (b) are allowed.

>  That said, I think your suggestions are good things and
> should be incorporated into the doc.
>
> - Matt

---

From: Matt Squire <[email-masked]>
Date: Mon, 02 Apr 2001 16:19:28 -0400

behavior.  That said, I think your suggestions are good things and

- Matt

---

From: "Hussein F. Salama" <[email-masked]>
Date: Thu, 05 Apr 2001 17:23:14 -0700

Apologize for the late response.

Requiring the sequence numbers to be persistent works for routes that are
statically configured on the LS. But what about routes that the LS learns from
an external peer then originates into the ITAD. To make these persistent, then
when an LS goes down then comes back up, we must make sure that these external
routes were not withdrawn while the LS was down.

Similarly, what if in the future the LS redistributes routes from another source
(e.g. some intra-domain call routing protocol or from H.323 Annex G) into TRIP.
Can't assume that these routes will be persistent until LS crashes then comes
back up.

Why isn't the TripDisableTime timer sufficient to address the issues? Whenever
the TRIP process goes down (for whatever) reason, it shouldn't be started until
at least TripDisableTime have elapsed which is a long enough to ensure that
routed advertised by this TRIP LS into the ITAD have been withdrawn. If the TRIP
LS itself can't enforce this timeout, it is sufficient that its internal peers
refuse to re-establish the peering until the TripDisableTime has elapsed.

Thanks.

Hussein

--
Hussein F. Salama
Cisco Systems
Mail Stop SJC-21/3, 170 W. Tasman Drive, San Jose, CA 95134
Voice: +1 (408) 527-7147, Fax: +1 (408) 527-7147

---

From: "Bob Penfield" <[email-masked]>
Date: Fri, 6 Apr 2001 15:26:27 -0400

Hussein,

Thank you for your response. I had not thought of external routes that a LS
injects as "self-originated". In any event, I don't want TRIP to REQUIRE
persistent sequence number, I just want TRIP to ALLOW persistent sequence
numbers for Local Routes directly entered into a LS.

Thanks,

Bob
d:-)

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "Hussein F. Salama" <[email-masked]>
To: "Bob Penfield" <[email-masked]>
Cc: "Matt Squire" <[email-masked]>; "IPTEL List"
<[email-masked]>
Sent: Thursday, April 05, 2001 8:23 PM
Subject: Re: [Fwd: [IPTEL] TRIP Sequence Numbers]

> > > > created and incremented each time the administrator updated the
route.
> > Since
> > > > could survive reboots and restarts. When the LS reboots/restarts,
its
> > local
> > > > routes' seq#s are not reset to 1, they have what ever seq# is
recorded
> > in
> > > > > > for the route) could be avoided. If either (a) or (b) is
permitted,
> > I
> > > > that survives restarts/reboots and the LS would never advertive a
route
> > with
> > > > self-originated route with a seq# higher than what it has recorded
in
> > the