Subject: [IPTEL] not present/otherwise nodes

From: David Bertrand <[email-masked]>
Date: Mon, 09 Apr 2001 15:22:07 +0200

Hi all,

Let's suppose a CPL script contains a switch (for example based on
subject) without the output <not-present> but with the output
<otherwise>. If the variable the switch is to match (in this case,
subject of call) is not present in the call setup request, should the
script execute the otherwise node or the default behaviour ?

--
David Bertrand
Software Engineer
Indigo Software
50 Rue Wiertz
Brussels, 1050 - Belgium
Phone : +32 2 235 09 44
Fax: +32 2 280 26 76
[email-masked]
http://www.indigosw.com

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: James Undery <[email-masked]>
Date: Mon, 09 Apr 2001 14:29:05 +0100

> script execute the otherwise node or the default behaviour ?

It should execute the otherwise node, the default behaviour is only used
when there is no match  to an output node and no otherwise node exists.

James Undery