Subject: [IPTEL] CPL: address matching without subfield

From: David Bertrand <[email-masked]>
Date: Wed, 04 Apr 2001 14:39:19 +0200

Hi,

In section 5.1.1 of the last draft on CPL concerning usage of
address-switch with SIP, it states:

"If no subfield is specified for addresses in SIP messages, the string
matched is the URI part of the address. For "sip" URLs, all parameters
are stripped;"

My question is : Is the port number a parameter ?
and whatever the response, does an absent port match the default port
number (like in the paragraph concerning port number matching)?

For example: - if the port number is a parameter:
    If the address given in the script is "sip:[email-masked]:5060"
   and if the URI in the SIP message (without parameters) is
   "sip:[email-masked]", should they match ?

                    - if the port number is not a parameter:
    If the address given in the script is "sip:[email-masked]" and
    if the URI in the SIP message (without parameters)
    is "sip:[email-masked]:5060",  should they match ?

Thanks in advance,
David

--
David Bertrand
Software Engineer
Indigo Software
50 Rue Wiertz
Brussels, 1050 - Belgium
Phone : +32 2 235 09 44
Fax: +32 2 280 26 76
[email-masked]
http://www.indigosw.com

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: James Undery <[email-masked]>
Date: Wed, 4 Apr 2001 13:50:52 +0000 (GMT)

> number (like in the paragraph concerning port number matching)?

I'd say no the port isn't a parameter, and yes an absent port matches the
default port.

>     is "sip:[email-masked]:5060",  should they match ?

Yes, although "sip:[email-masked]" and "sip:[email-masked]:6000" won't
match.

James Undery

---

From: Jonathan Lennox <[email-masked]>
Date: Wed, 4 Apr 2001 15:23:19 -0400 (EDT)

>     is "sip:[email-masked]:5060",  should they match ?

I think that default ports should be omitted from the URI when doing URI
matching.  However, I don't think this is what the spec says.  Given that
there's going to have to be one more revision for the time-switch stuff,
would we have to do a second IESG cycle if I changed this?

-- 
Jonathan