Subject: [IPTEL] Multiple nodes in CPL

From: Bogdan - Andrei IANCU <[email-masked]>
Date: Mon, 25 Jun 2001 21:33:16 +0200

Is it allowed for a node (excepting the switches, proxy and lookup) to
have more than one child nodes?
For example, in a sub-action tag can you put a mail and reject (in this
order) node on the same row?
.
.
<subaction name=reject>
  <mail url=[email-masked]?subject="call rejected" />
  <reject />
</subaction>

I raise this problem because in the CPL draft, for some nodes it is not
specified anything about the output or the following node. For other
nodes, like reject, mail, log there is said that they have no output,
but other nodes can follow. From this I can conclude that is possible to
have more than one node in a row, but the question remains: for which
nodes is it allowed (there are in the draft nodes without any comment
about)?

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 25 Jun 2001 23:30:26 -0400

> -----Original Message-----
> From: Bogdan - Andrei IANCU [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 3:33 PM
> To: [email-masked]
> Subject: [IPTEL] Multiple nodes in CPL
> 
> 

No.

>   <mail url=[email-masked]?subject="call rejected" />

No. It would be like:

<subaction name=reject>
  <mail url="[email-masked]?subject=call%20rejected">
    <reject/>
  </mail>
</subaction>

> nodes is it allowed (there are in the draft nodes without any comment

No; "follow" here means a subtag relationship.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com