Subject: [IPTEL] TRIP byte/bit ordering

From: "William Parton" <[email-masked]>
Date: Tue, 25 Sep 2001 10:36:32 +0100

I have studied the TRIP RFC and those that it references (as well the iptel
mailing list) for a definitive statement on the bit/byte ordering to be used
within TRIP messages (i.e. big/little endian) but have been unable to find
any such statement. Is this aspect of the protocol defined in the RFC(s) or
is there a general RFC covering this low level aspect of protocol
implementation? If so could someone please point me in its direction.

regards
Will

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 27 Sep 2001 07:51:01 -0400

In general, everything over IP is big endian. See Appendix B of RFC 791.

(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "William Parton" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, September 25, 2001 5:36 AM
Subject: [IPTEL] TRIP byte/bit ordering

> implementation? If so could someone please point me in its direction.

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel