Subject: [IPTEL] TRIP byte/bit ordering

From: "William Hern" <[email-masked]>
Date: Wed, 26 Sep 2001 10:32:24 +0100

[Apologies to anyone who has received this message twice.]

I have studied the TRIP RFC and those that it references (as well the iptel
mailing list) for a definitive statement on the bit/byte ordering to be used
within TRIP messages (i.e. big/little endian) but have been unable to find
any such statement. Looking at Version 09 of the draft TRIP spec, the bit
ordering in the diagrams would suggest little-endian but the attribute flag
section (S4.3.2) implies big-endian.

Is this aspect of the protocol defined in the RFC(s) or is there a general
RFC covering this low level aspect of protocol implementation? If so could
someone please point me in its direction.

Many thanks in advance.

Will

William Hern, Dept. CV06-M, Translations and Service Development
Nortel Networks UK Ltd, Concorde Road, Maidenhead, UK.
Email: [email-masked]
ESN Tel: 590 4780 External Tel: +(44) 1628 434780 Fax: +(44) 1628 431105
Corporate Intranet Web page: http://47.96.0.203/home/whern
Registered office: Maidenhead Office Park, Westacott Way, Maidenhead,
Berkshire, SL6 3QH.
Company number 3937799

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 26 Sep 2001 07:33:51 -0400

TRIP, like all IP related protocols uses big endian. See Appendix B of RFC
791.

(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "William Hern" <[email-masked]>
To: <[email-masked]>
Cc: "William Parton" <[email-masked]>; "Robert Ruth"
<[email-masked]>; "Chris Bingham" <[email-masked]>;
"Patrick Bradd" <[email-masked]>
Sent: Wednesday, September 26, 2001 5:32 AM
Subject: [IPTEL] TRIP byte/bit ordering

> Registered office: Maidenhead Office Park, Westacott Way, Maidenhead,

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel