Subject: [IPTEL] few questions on TRIP

From: Anirudh Sahoo <[email-masked]>
Date: Sat, 03 Nov 2001 18:39:39 -0800

Hi all,
    I have a couple of questions on TRIP draft:

1. The minimum length of OPEN message should be
    17 (3 octets TRIP header + 14 octets of
    OPEN msg header), instead of 14? I think the draft
    does not take TRIP header into account while
    counting the minimum length.

2. In Section 5.4.2, should not the draft also mention
    that the originating LS should (or MUST?) set the type of the
    AdvertisementPath to AP_SEQUENCE?

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Manjunath Bangalore <[email-masked]>
Date: Sun, 04 Nov 2001 01:38:47 -0800

Anirudh,

>     counting the minimum length.

You are right, including the header, the minimum length should be 17
octets
Looks like sec 4.2 was apparently supposed to read
"(not including message header)"

>     AdvertisementPath to AP_SEQUENCE?

When a path segment in either path attribute (AdvertisementPath or
RoutedPath) contains only one ITAD member (in the case that you mention,
the Originating ITAD), AP_SEQUENCE is equivalent to AP_SET. The property
of being an "ordered" or "unordered" set defined through the 'path
segment type' comes into picture only when there are at least 2 ITAD
members in the path segment.

regards,
-Manjax