Subject: AW: [Iptel] Summary of +1-800 for tel URI discussion

From: "Stastny Richard" <[email-masked]>
Date: Mon, 2 Dec 2002 16:31:21 +0100

All, 
I have problems to follow this discussion:
An 800 number is a service number and the routing is done within IN.
 
So in the PSTN the 800 number is routed first to the service provider hosting
the IN service (with a cic derived from NP translation - see yu drafts on np) and
the service provider is then finding out the PSTN number where the call should terminate.
 
Since this is an IN-service, it could be intelligent, so the PSTN number could be a bunch
of numbers really, one for each hour of the day or one for each area or office code, and 
exactly this is the point where the context is coming into play.
 
I need the originating context, e.g transmitted in the SIP message with the 800 number
and match it with the context of the terminating number.
 
Be aware, that the terminating number itself gives you NOT the context, because the
call center may sit in Ireland or move around the globe with the sun ;-). So a PSTN
number in Ireland may have the context +49 (germany) and a number in scotland the
context +43 (Austria). And this example is not a joke, it is real, if you dial e.g an
+43800 or +800 Number in Vienna, I sometimes end up in Holland, Ireland or Scotland (just
chat a bit with the ladies).
 
So what we need, is a clear definition what context means, and since there may be ambiguities,
I strobly recommend to define at least e.g. orig-context and term-context.
 
regards
Richard

	-----Ursprüngliche Nachricht----- 
	Von: Michael Hammer [mailto:[email-masked]] 
	Gesendet: Mo 02.12.2002 15:41 
	An: Henning Schulzrinne 
	Cc: Scott Bradner; [email-masked]; [email-masked] 
	Betreff: Re: [Iptel] Summary of +1-800 for tel URI discussion

	All,
	
	I suspect that the routing of the call to multiple destinations, even
	though the same 1-800 number is used, has nothing to do with the 1-800
	number and everything to do with other information contained in the
	signaling, and thus very much orthogonal.  If sticking this other
	information into the tel: URL is the way independent information is bound
	to a phone number, so be it; but, then there are many pieces of information
	that could be bound in such fashion.
	
	Mike

	At 03:09 PM 11/30/2002 -0500, Henning Schulzrinne wrote:
	>Scott,
	>
	>trying to guess at the source of confusion here. I suspect that part of
	>the problem might be two meanings of the word 'context':
	>
	>- Context = 'resolve this identifier under this context'
	>(;context=+1-212-939-7000 = Pizza Hut as if dialed from 212-939-7000)
	>
	>- Context = 'this number is only valid if dialed from this context; it's
	>an error otherwise' (the number may still reach something or other, but
	>it's not the intended destination)
	>
	>I think most of us are thinking of the second use, not the first. Your
	>paragraph seems to hint at the first. Thus, for PizzaHut, there would be
	>no need for context (the number is valid, albeit routed differently
	>everywhere in the +1 context.) The problem I have with the first
	>interpretation is that the context is unknown, since the routing can
	>depend on any prefix and can never be known by the writer of a web page, say.
	>
	>I suspect that the PizzaHut routing problem is basically unsolvable as
	>soon as you have gateways; you'll always reach the PizzaHut closest to the
	>gateway, not the IP-based caller. The routing algorithm is presumably
	>based on more than just digits in the ANI phone number. The problem is
	>essentially the same as the 911 routing problem; maybe Intrado can start a
	>new line of business :-)
	>
	>However, I'm still not sure I understand your concern.
	>
	>Now, do I get a PizzaHut coupon?
	>
	>Scott Bradner wrote:
	>
	>> >I really do not want extra language in the spec to handle what I suspect
	>> >is a non-issue, because if folks don't know any better they will litter
	>> >all freephone numbers with context which in most cases is not only
	>> >extraneous, but also in some cases harmful to proper routing.
	>>
	>>
	>>I guess I must be confused about this issue - I would have thought that
	>>one needed locational context to resolve 1-800-hot-pizza (or
	>>whatever dominos country-wide number is) in order to direct a call
	>>to the right place (one on N-thousand local shops)
	>>
	>>it would seem to be a database loading issue if that number gets paid for
	>>by one or more organizations and not an issue of what information you
	>>need to get to the right place
	>>
	>>Scott
	>
	>
	>_______________________________________________
	>Iptel mailing list
	>[email-masked]
	>https://www.ietf.org/mailman/listinfo/iptel
	
	_______________________________________________
	Iptel mailing list
	[email-masked]
	https://www.ietf.org/mailman/listinfo/iptel

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 02 Dec 2002 10:40:00 -0500

The conclusion I reached from this whole discussion is a bit different. 
To summarize:

- context is no more necessary for +1-800 than for "regular" E.164 
numbers (after all, nothing keeps somebody from forwarding 900 or other 
regular numbers to different parts of the world)

- context is to ensure semantic uniqueness, not to select among 
semantically equivalent locations operated by the owner of that 
identifier (after all, we don't add context to http URIs, even though 
they often end up in different locations; just try Google while you're 
visiting another country - you'll end up seeing a local-language version 
of their home page).

- any routing preferences or indications should be provided in, say, 
caller preferences, not as part of the tel (or sip) URI.

Thus, I don't intend to add additional context parameters to 2806bis.

Henning