Subject: RE: [Iptel] comments on rfc2806bis

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 4 Dec 2002 10:09:43 -0500

We are not communicating, sorry.

You need two separators in a row to do "(724) 742-6826"
They aren't the SAME separator, but they are two consecutive
separators in a row.  There is a space between the ")" and the "7".

Your response leads me to think the only thing you
disallow is the same separator repeated without an intervening
meaningful character.  Thus you would allow
+ 1 ().-7 2 4 ().-7 4 2 ().-6 8 2 6
but not
+1  7247426826

I'd like to see the ABNF that described that rule :)

I'll agree that there is no need to repeat the same separator,
but there is a need to have two different separators adjacent.

Interestingly, I think it really is two max, although I'm not an
expert on how every country displays local numbers.  There are
many examples of spaces around parens, but I don't think there
are any others.  You might even get away with a rule that
permitted a space around a paren as the only multiple separator
rule, something like

lparen = [" "] "(" [" "]
rparen = [" "] ")" [" "]
sep = " " | "-" | "." | lparen | rparen
...

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 8:49 AM
> To: Rosen, Brian
> Cc: 'Jonathan Rosenberg'; [email-masked]
> Subject: Re: [Iptel] comments on rfc2806bis
> 
> 
> We meant "two separators in a row", as in +1--724..6826. Except for 
> typos, two consecutive visual seps don't seem to serve a role. The 
> advantage of limiting the number of separators per digit is that it 
> limits the maximum legal length of the number.
> 
> Yes, clearly, a tel URI can, in total, contain more than one 
> separator.
> 
> Rosen, Brian wrote:
> > Maybe I've missed something, but we usually write (724) 
> 742-6826, and not
> > (724)742-6826.  My business card actually has +1 (724) 
> 742-6826.  That means
> > two
> > separators.
> > 
> > I do think we should permit visual separators, stripping 
> them for comparison
> > purposes as you suggest.
> > 
> 

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 04 Dec 2002 10:30:53 -0500

So much fuss about the minor members of the alphabet :-)

I don't see why

(724)742-6826

wouldn't work for you. After all, this is how the numbers are commonly 
written. (We agreed, I believe, that spaces should not be legal visual 
separators, so the only real combination of interest are things like 
")-" and "-(". I've never seen those in real life.)

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 04 Dec 2002 10:45:02 -0500

> So much fuss about the minor members of the alphabet :-)

As you have probably observed, nothing brings out opinions more than 
discussions on syntax ;)

> I don't see why

Right - I was about to point out that spaces are not allowed in URI. If 
we did want them, we would be doing something like this:

tel:+1%20(724)%20742-6826

which, I think, reduces the readability rather than increasing it.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com