Subject: RE: [Iptel] comments on rfc2806bis

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 4 Dec 2002 11:02:33 -0500

Confusion reins.

I don't care a whit what is "on the wire" in terms of readability.
You don't look at the actual sip message.  You look at the presentation
of it.  What you want to do is to send the spaces escaped.  You can
escape all of the seps if you want to.  What matters is if I send
+44 11 22 33 4567 then it displays that way on the other side.

It's very hard (we've tried) to build a "pretty printer" that takes
an arbitrary number and displays it pleasantly on callerId.  
It's pretty easy to preserve what was sent.  I want to do that. 

Confusing things even more, the business card in front of me displays
a number like:
+49 (0) 90 32 / 69 12 64

Slash is on you sep list, right?

Then, what do we do about that pesky (0)?
It's one of those context thingies, right?
This guy is in my contact database that way.
If I dial the number, I know how to deal with the zero.  
However, we don't want to build into the UA the mechanism to translate
depending on where you are.  That means a proxy does it, or
probably the terminating gateway.  So, I probably send the zero, but do
I need to send context info.  I suspect not, but we should think
about it.  

Brian 

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 10:45 AM
> To: Henning Schulzrinne
> Cc: Rosen, Brian; [email-masked]
> Subject: Re: [Iptel] comments on rfc2806bis
> 
> 
> 
> 
> Henning Schulzrinne wrote:
> > So much fuss about the minor members of the alphabet :-)
> 
> As you have probably observed, nothing brings out opinions more than 
> discussions on syntax ;)
> 
> > 
> > I don't see why
> > 
> > (724)742-6826
> > 
> > wouldn't work for you. After all, this is how the numbers 
> are commonly 
> > written. (We agreed, I believe, that spaces should not be 
> legal visual 
> > separators, so the only real combination of interest are 
> things like 
> > ")-" and "-(". I've never seen those in real life.)
> 
> Right - I was about to point out that spaces are not allowed 
> in URI. If 
> we did want them, we would be doing something like this:
> 
> tel:+1%20(724)%20742-6826
> 
> which, I think, reduces the readability rather than increasing it.
> 
> -Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 04 Dec 2002 11:24:05 -0500

Since there's no agreed-upon semantic distinction between space, ., () 
and -, I don't think we need to support spaces. +44-11-22-33-4567 will 
work just as well. I suspect you'll also see +44.11.22.33.4567 and 
humans will easily deal with either. The (0) issue, indicating 
optionality, does not arise in E.164 numbers.

> It's pretty easy to preserve what was sent.  I want to do that. 

We're in agreement on that. The separators, any of them, are enough to 
render numbers in a way that people can more easily read and transcribe 
them, compared to a longish string of digits.

> Confusing things even more, the business card in front of me displays

You don't worry about it - it's not part of the E.164 number and we long 
ago agreed that we would not deal with whatever dial prefixes are needed 
to dial, say, long-distance numbers. It would simply be

+49-9032-691264

or

+49(9032)691264

> It's one of those context thingies, right?

No. Please, please, let's not go there again. We've had a month of that 
discussion and I'd rather not rehash it.

> probably the terminating gateway.  So, I probably send the zero, but do

Whoever actually dials needs to know how E.164 numbers become dial 
strings. That's not terribly hard, since that entity only needs to 
detect how local the number is (same country? same area code?) and know 
its local dialing rules (11-digit dialing? 10-digit dialing? 7-digit 
dialing? Add 0 or 1 or 011?)

The draft talks about this at some length.

I gather some systems (ISDN?) even allow E.164 numbers directly or at 
least allow uniform national dialing without worrying about whether an 
area code is needed or not.