Subject: RE: [Iptel] comments on rfc2806bis

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 4 Dec 2002 08:44:34 -0500

Maybe I've missed something, but we usually write (724) 742-6826, and not
(724)742-6826.  My business card actually has +1 (724) 742-6826.  That means
two
separators.

I do think we should permit visual separators, stripping them for comparison
purposes as you suggest.

Brian

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, December 03, 2002 5:42 PM
> To: Henning Schulzrinne
> Cc: [email-masked]
> Subject: Re: [Iptel] comments on rfc2806bis
> 
> 
> 
> 
> Henning Schulzrinne wrote:
> 
> >> > Implementations MUST NOT assume that telephone numbers have a
> >> >    maximum, minimum or fixed length, or that they always 
> begin with a
> >> >    certain number.
> >>
> >>
> >> For global numbers, I certainly can assume a maximum 
> length of 15, as
> >> that is the constraint in the BNF. I think you should say "local
> >> numbers" instead of telephone numbers.
> > 
> > 
> > 
> > I've removed the constraint from the BNF. As was pointed out, it 
> > couldn't deal with the visual separators. Given visual 
> separators, the 
> > length becomes unbounded. Something like
> > 
> > tel:+1-----------201.........(((((555)))))))1234
> > 
> > is odd, but legal according to the current BNF. (I've now 
> rewritten the 
> > BNF so that each digit can be followed by at most one 
> visual separator. 
> > Is there any reason to have more than that? This would 
> limit the length 
> > to 30.)
> 
> I've been pondering the role of visual separators in the URI, 
> and did a 
> bit of thinking and research on the topic. Here are my thoughts.
> 
> On one hand, since URI are ultimately for computer consumtpion, the 
> separators play no role. They also complicate the comparison process 
> since they should probably be removed before comparison. Simplicity 
> would argue for their elimination entirely.
> 
> However, one can argue that they play a reasonable role in supporting 
> the general transcribability requirement of a URI. From RFC 2396:
> 
> > A URI often needs to be remembered by people, and it is easier
> >          for people to remember a URI when it consists of meaningful
> >          components.
> 
> This would argue in favor of the separators, since people very 
> frequently use them to help correct write the number. As an 
> example, its 
> much easier to get the correct number of ones when writing:
> 
> tel:+1(111)111-1111
> 
> as opposed to tel:+11111111111.
> 
> Interestingly, there is precedent for the usage of such 
> separators in a 
> URN. The ISBN URN (rfc3187), uses dashes in the same way we use them. 
> The specifications for that URN scheme do require that the dashes are 
> removed before comparing for equivalence.
> 
> So, in the interests of transcribability and in keeping with 
> the trend 
> in the ISBN URN, I would argue that we retain the separators 
> and remove 
> them for comparison purposes.
> 
> So, the issue remains of whether or not to allow multiple 
> separators. I 
> think what you have done is reasonable - allowing a single 
> separator. I 
> can think of no reason why we would need more.
> 
> 
> >>
> >> >  Even though ITU-T E.123 [8] recommends the use of space 
> characters as
> >> >    visual separators in printed telephone numbers, tel 
> URIs MUST NOT 
> >> use
> >> >    spaces.
> >>
> >>
> >> The BNF clearly disallows spaces as part of the phone 
> number itself, so
> >> having a MUST NOT here seems redundant. Does this mean I can't have
> >> escaped spaces as part of a parameter value? That is 
> allowed by the BNF.
> > 
> > 
> > I suppose we can allow %20 spaces as visual separators. Is 
> there value 
> > in that?
> > 
> 
> Probably not. This isn't like an HTTP URI, where we are trying to 
> describe files whose names are frequently unconstrained in 
> their natural 
> form.
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Iptel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iptel
> 
_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 04 Dec 2002 08:48:31 -0500

We meant "two separators in a row", as in +1--724..6826. Except for 
typos, two consecutive visual seps don't seem to serve a role. The 
advantage of limiting the number of separators per digit is that it 
limits the maximum legal length of the number.

Yes, clearly, a tel URI can, in total, contain more than one separator.

---

From: "Cullen Jennings" <[email-masked]>
Date: Wed, 4 Dec 2002 06:51:01 -0800

Not sure what Brian meant but when I read his email, I interpreted it as
(724) 742-6826 did have two visual separators in a row. The ) and the space
after the ) and before the 732.

Cullen

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Henning Schulzrinne
> Sent: Wednesday, December 04, 2002 5:49 AM
> To: Rosen, Brian
> Cc: 'Jonathan Rosenberg'; [email-masked]