Subject: RE: [Iptel] comments on rfc2806bis

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 9 Dec 2002 13:04:10 -0500

Sorry to be obstinate, but I don't get it.  The "technical problem"
is that the set of visual separators proposed does match what real people
use.
Either you fix that, or I think we should get rid of all the separators.
Why is a subset interesting?  If you can't reproduce what the users
actually use, what are you providing?  If I typed "(724) 742-6826" and
it got mangled to 724.742-6826 in the URI is that helpful? I think not.

At this point, I think we should eliminate separators.

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Friday, December 06, 2002 12:48 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Iptel] comments on rfc2806bis
> 
> 
> There has been no real, technical problem identified with keeping the 
> visual separators, beyond "taste" problem. Can we please 
> close this issue?
> 
> People can indeed populate tel URIs according to the 
> guidelines of E.123 
> (minus the spaces, which are generally a pain in URIs). Just 
> like nobody 
> can force people to use the correct ISBN hyphenation, we just have to 
> make sure that nothing breaks if a poor user hasn't read 
> E.123 lately. 
> Obviously, functionality is unaffected by such user 
> punctuation mistakes.
> 
> The argument about human readability are not with the tel 
> URI, but with 
> RFC 2396. I suggest you take your complaints to the relevant 
> URI working 
> group.
> 
> [email-masked] wrote:
> > In a message dated 12/4/2002 11:11:00 AM Eastern Standard Time, 
> > [email-masked] writes:
> > 
> > 
> >> Confusion reins.
> > 
> > 
> > [MAP] I'll second that.
> > 
> > Here's another. (I'll stick my neck out first - go ahead, 
> chop it off - 
> > but E.123 (Feb 2001) is the international standard for the 
> > representation of telephone numbers in (printed) human 
> readable format. 
> > It defines the format Brian finds on his business card, 
> including the / 
> > and spaces. Yes, I think ITU-T went a little out of their 
> scope when 
> > they added web addresses and e-mail address formats to 
> E.123, but that's 
> > another issue.)
> > 
> > Now the next step of confusion: A footnote in E.123 
> indicates that the 
> > hypen is used in some countries as a separator, but that in the 
> > Netherlands it is used to indicate the point at which the 
> dialer should 
> > wait for another dial tone.
> > 
> > Another confusion for the tel:uri: E.123 says that "the ( ) 
> should not 
> > be used in an international number".
> > 
> > In fact, in E.123, the "spacing" symbols are: spaces, dots, 
> and hypens. 
> > It says "only spaces should be used in an international 
> number" and a 
> > footnote implies that dots and hypens are allowed but 
> should be phased 
> > out. E.123 defines "procedural" symbols as: +, parentheses, slash.
> > 
> > I believe some time ago I made the point that there are two 
> separate 
> > things:
> > 
> > 1. human representation of a number (entry on or display by 
> a terminal)
> > 2. representation in the protocol ( or "on-the wire")
> > 
> > Attempts to make these the same are leading to extreme 
> difficulty, bad 
> > compromises, endless discussions, etc. I understand the reason for 
> > wanting to make the actual protocol human readable, but 
> other things are 
> > being added that would cause a lot more trouble for a human 
> than the 
> > lack of separators.
> > 
> > E.123 covers the human interface representation (item 1). 
> This should 
> > not be the issue in the tel:uri. IPTEL needs to concentrate 
> on item 2. 
> > If one wanted to design a human interface according to the 
> principles in 
> > E.123, there might be, for example, a case in which one could enter 
> > multiple telephone numbers separated by a slash (as on 
> Brian's busines 
> > card). The functionality might translate this into multiple 
> tel:uri's. 
> > (I don't see a single tel:url having multiple telephone numbers.)
> > 
> > 
> > Mike Pierce
> > Artel
> > 
> 
_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 09 Dec 2002 13:08:16 -0500

Correction: you can certainly type see tel:+1(724)742-6826. () are legal 
separators.