Subject: RE: [Iptel] Re: I-D ACTION:draft-rosen-iptel-dialstring-03.txt

From: "Francois Audet" <[email-masked]>
Date: Wed, 22 Mar 2006 14:28:01 -0600

You can use:

sip:DIALDIGITS;phone-context=[email-masked];user=
phone

There is absolutely no difference between user=phone and user=dialdigits
if
since they both need a phone-context that makes the user part globally
unique.

When we went through this a wile ago, the rationale that was given for
the
"dial digits" was the pauses.

Adding a new way to do exactly the same thing just means more interop
problems.
This is further complicated by the fact we tabled this for 2 years.

I'd favor instead that we describe (in that draft) how to use user=phone
with a 
phone-context that essentially means "the network dialling plan in
location x" 
or whatever, without defining a new URI parameter. And drop the
"pauses".

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]] 
> Sent: Tuesday, March 21, 2006 15:51
> To: Paul Kyzivat; [email-masked]
> Cc: [email-masked]; Audet, Francois [SC100:3055:EXCH]
> Subject: Re: [Iptel] Re: I-D 
> ACTION:draft-rosen-iptel-dialstring-03.txt
> 
> 
> >While there are many ways to deal with this if you have good 
> dial plan 
> >processing in the phone, it still seems that there is often 
> a desire to 
> >leave both of these things encoded in the URI. This requires 
> a way to 
> >represent dial strings.
> 
> I doubt that there will be ever a good dial plan processing 
> in a phone and it is also not necessary, if you have a 
> defined destinction if a 
> string of numbers is a phone number or a dialstring
> 
> So I fully agree that there is required a way to reresent 
> dial-strings and also a way to distingush if a sip:nnn@domain 
> is a phone numer i.e an imbedded tel:URI or a dialstring.
> 
> sip:nnn@domain;user=phone
> sip:nnn@domain;user=dialstring
> 
> Richard
> 
> 
> ________________________________
> 
> Von: Paul Kyzivat [mailto:[email-masked]]
> Gesendet: Di 21.03.2006 23:53
> An: [email-masked]
> Cc: [email-masked]; 'Francois Audet'
> Betreff: Re: [Iptel] Re: I-D 
> ACTION:draft-rosen-iptel-dialstring-03.txt
> 
> 
> 
> 
> 
> Brian Rosen wrote:
> > It deals with reality.  Phones don't (always) do dial plan 
> > interpretation. We have no way to know if it's been done.  
> The problem 
> > isn't a tel uri, the problem is sip:nnn@domain;user=phone.  
> It's NOT a 
> > phone number, it's a dial string.
> 
> I think Brian and I agree on the issues here, but I want to 
> pick on the description. In the case of both a tel uri or 
> sip:nnn@domain;user=phone, it is *supposed* to be a phone 
> number. Neither of these is supposed to contain a dial 
> string. The problem is that both of these are known to be 
> used, improperly, to contain dial strings.
> 
> > The only way to implement real tel uri's is to force all 
> phones to do 
> > all dial plan interpretation.  That just isn't going to 
> happen in my 
> > lifetime I think.
> 
> Well, its hard for me to guess on your health issues, but I 
> think there is a pretty good chance that all voip phones will 
> do this in *my* lifetime. I do agree that they don't all do 
> it today, and we probably need to accomodate that.
> 
> In my experience a more severe problem is cases when the 
> dialstring contains both the target address *and* some 
> special function (e.g. star
> code) that needs to be taken into account along with the 
> target address. While there are many ways to deal with this 
> if you have good dial plan processing in the phone, it still 
> seems that there is often a desire to leave both of these 
> things encoded in the URI. This requires a way to represent 
> dial strings.
> 
>         Paul
> 
> > I don't care about the pauses; I could lose them.  They are also 
> > reality, however.  It's what the phone has in a speed dial 
> to get to, 
> > for example, an existing voicemail system.  You can say forklift 
> > upgrade to a SIP based VM, but that's not reality.
> >
> > Brian
> >
> > -----Original Message-----
> > From: Francois Audet [mailto:[email-masked]]
> > Sent: Tuesday, March 21, 2006 4:07 PM
> > To: [email-masked]
> > Subject: RE: [Iptel] Re: I-D 
> > ACTION:draft-rosen-iptel-dialstring-03.txt
> >
> > I guess I'll be the dissenter here...
> >
> > I really do not see why we need this draft. I think it will do much 
> > more harm than good.
> >
> > It will dissuade people from implementing "real" tel uris.
> >
> > I have not seen any convincing evidence that using "pauses" in 
> > dialling is something SIP should do.
> >
> > _______________________________________________
> > Iptel mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/iptel
> >
> >
> > _______________________________________________
> > Iptel mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/iptel
> >
> 
> _______________________________________________
> Iptel mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/iptel
> 
> 
> 
> 

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 22 Mar 2006 16:04:42 -0500

> "dial digits" was the pauses.

I was one of the people that didn't see the need for user=dialstring. I 
lost that battle. I think another rationale was that the same context 
can then be used for local numbers and dialstrings. (If you think that 
is important.)

It doesn't matter much, which is why I didn't lose much sleep over this. 
In the end, either way provides a mechanism for conveying a dial string 
in a URI and being able to distinguish it from a phone number.

> or whatever, without defining a new URI parameter. And drop the

I thought it was decided, not tabled. While I started out on the other 
side, and would have been happy to have it end up that way, at this 
point it just want to move on rather than reopen the debate.

	Paul