Subject: [Iptel] draft-mahy-iptel-cpc

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 27 Mar 2008 03:56:22 -0400

Hi,

This draft (draft-mahy-iptel-cpc-06.txt) is expired. Will this draft
become WG item? If not, is there any other standard way to carry CPC or
OLI parameter in SIP? 

Thanks,
Yiu

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: "DOLLY, MARTIN C, ATTLABS" <[email-masked]>
Date: Thu, 27 Mar 2008 07:04:08 -0500

Yiu,
 
There is not a standard way to pass CPC or OLI in SIP? Also,
draft-mahy-iptel-cpc-06.txt would not meet Nroth American deployment
needs because it blends CPC and OLI.
 
Martin

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Lee, Yiu
Sent: Thursday, March 27, 2008 3:56 AM
To: [email-masked]; [email-masked]
Subject: [Iptel] draft-mahy-iptel-cpc

Hi, 

Thanks, 
Yiu

---

From: "Sumit Garg" <[email-masked]>
Date: Thu, 27 Mar 2008 09:46:37 -0400

Over a period of time I have seen various efforts in that direction
which eventually get dropped...to list a few:

draft-schubert-sipping-saml-cpc-02.txt (Expired: jan 2007)

draft-mahy-iptel-cpc-06.txt (Expired:Sep 2007)

draft-ietf-sip-privacy-04.txt , Appendix A (Expired: 2002)

draft-rocky-sipping-calling-party-category-01.txt (Expired : 2006)

I've also seen implementation using parameters  like isup-oli for which
I could not even find a draft.

Based on this I believe conveying CPC/OLI in SIP is a real requirement.

Maybe for pure SIP scenario it could be done with caller-preferences,
but not in interworking scenarios.

From what I understand:

1. CPC in ISUP could be desired by the terminating exchange, however,
the scope of the OLI is only 1 call-leg and could be different from CPC
as it is more closely tied to the billing number.

3. CPC is ISUP only, OLI could be over MF also.

I don't really care what the tag-name in use is (oli/cpc)but, from where
I am looking I would say:

1.       cpc-param in P-Asserted-Id corresponds to cpc in ISUP (Better
than in From header as it is a tel-uri parameter).

2.       cpc-param in
History-Info/Diversion/P-DCS-Billing-Info/Referred-By etc. etc. could
correspond to OLI.

Is there some way of reaching consensus and moving on...rather than have
more aborted attempts in the future?

-Sumit

"The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all progress
depends on the unreasonable man."
-- George Bernard Shaw

From: [email-masked] [mailto:[email-masked]] On Behalf
Of DOLLY, MARTIN C, ATTLABS
Sent: Thursday, March 27, 2008 8:04 AM
To: Lee, Yiu; [email-masked]; [email-masked]
Subject: Re: [Iptel] draft-mahy-iptel-cpc

Yiu,

Martin

Hi, 

Thanks, 
Yiu

---

From: "Sumit Garg" <[email-masked]>
Date: Fri, 28 Mar 2008 09:12:43 -0400

I was surprised by the lack of responses.

This is a real need as I believe intermediate exchanges could need
special processing for calls from Prison etc.

The reason I proposed using P-A-I as opposed to From header in the draft
was:

In case of anonymous calls, the From header is generally of the form
anonymous@.......

A derived tel-Uri with cpc would look like anonymous;cpc=payphone

This violates the tel-URI syntax. P-Asserted-Id covers this scenario as
well.

If there is a defined standard mechanism for this requirement, could
somebody please point me to the same?

-Sumit

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Sumit Garg
Sent: Thursday, March 27, 2008 9:47 AM
To: [email-masked]; [email-masked]
Subject: Re: [Iptel] draft-mahy-iptel-cpc

From what I understand:

2.       cpc-param in

-Sumit

Yiu,

Martin

Hi, 

Thanks, 
Yiu

---

From: "DOLLY, MARTIN C, sbcuid" <[email-masked]>
Date: Fri, 28 Mar 2008 08:50:02 -0500

Sumit,
 
What is really needed is OLI & CPC for North American deployments.
Prisons is an OLI value, not a CPC value. That is the issue with the cpc
draft it mixes up two different parameters. OLI is what type of line,
where CPC is call type ( for the most part).
 
Martin

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sumit Garg
Sent: Friday, March 28, 2008 9:13 AM
To: [email-masked]; [email-masked]
Subject: Re: [Sipping] draft-mahy-iptel-cpc

-Sumit

From what I understand:

2.       cpc-param in

-Sumit

Yiu,

Martin

Hi, 

Thanks, 
Yiu

---

From: "Sumit Garg" <[email-masked]>
Date: Fri, 28 Mar 2008 11:23:51 -0400

If people agree on the need, and mixed usage is the only road-block what is preventing us from having 2 parameters.....maybe in the next version of the draft?

-Sumit

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man."
-- George Bernard Shaw

From: Jesske, R [mailto:[email-masked]] 
Sent: Friday, March 28, 2008 9:58 AM
To: [email-masked]; Sumit Garg; [email-masked]; [email-masked]
Subject: AW: [Sipping] draft-mahy-iptel-cpc

Hi,

nevertheless what is the status now of cpc? Because cpc is needed in some cases like ieps of payphone.

And we could add the OLI.

Thanks and Best Regards

Roland

	Von: [email-masked] [mailto:[email-masked]] Im Auftrag von DOLLY, MARTIN C, sbcuid
	Gesendet: Freitag, 28. März 2008 14:50
	An: Sumit Garg; [email-masked]; [email-masked]
	Betreff: Re: [Sipping] draft-mahy-iptel-cpc

	Sumit,

	What is really needed is OLI & CPC for North American deployments. Prisons is an OLI value, not a CPC value. That is the issue with the cpc draft it mixes up two different parameters. OLI is what type of line, where CPC is call type ( for the most part).

	Martin

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Sumit Garg
	Sent: Friday, March 28, 2008 9:13 AM
	To: [email-masked]; [email-masked]
	Subject: Re: [Sipping] draft-mahy-iptel-cpc

	This is a real need as I believe intermediate exchanges could need special processing for calls from Prison etc.

	The reason I proposed using P-A-I as opposed to From header in the draft was:

	In case of anonymous calls, the From header is generally of the form anonymous@.......

	This violates the tel-URI syntax. P-Asserted-Id covers this scenario as well.

	If there is a defined standard mechanism for this requirement, could somebody please point me to the same?

	-Sumit

	"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man."
	-- George Bernard Shaw

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Sumit Garg
	Sent: Thursday, March 27, 2008 9:47 AM
	To: [email-masked]; [email-masked]
	Subject: Re: [Iptel] draft-mahy-iptel-cpc

	Over a period of time I have seen various efforts in that direction which eventually get dropped...to list a few:

	I've also seen implementation using parameters  like isup-oli for which I could not even find a draft.

	Maybe for pure SIP scenario it could be done with caller-preferences, but not in interworking scenarios.

	From what I understand:

	1. CPC in ISUP could be desired by the terminating exchange, however, the scope of the OLI is only 1 call-leg and could be different from CPC as it is more closely tied to the billing number.

	I don't really care what the tag-name in use is (oli/cpc)but, from where I am looking I would say:

	1.       cpc-param in P-Asserted-Id corresponds to cpc in ISUP (Better than in From header as it is a tel-uri parameter).

	2.       cpc-param in History-Info/Diversion/P-DCS-Billing-Info/Referred-By etc. etc. could correspond to OLI.

	Is there some way of reaching consensus and moving on...rather than have more aborted attempts in the future?

	-Sumit

	"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man."
	-- George Bernard Shaw

	From: [email-masked] [mailto:[email-masked]] On Behalf Of DOLLY, MARTIN C, ATTLABS
	Sent: Thursday, March 27, 2008 8:04 AM
	To: Lee, Yiu; [email-masked]; [email-masked]
	Subject: Re: [Iptel] draft-mahy-iptel-cpc

	Yiu,

	There is not a standard way to pass CPC or OLI in SIP? Also, draft-mahy-iptel-cpc-06.txt would not meet Nroth American deployment needs because it blends CPC and OLI.

	Martin

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Lee, Yiu
	Sent: Thursday, March 27, 2008 3:56 AM
	To: [email-masked]; [email-masked]
	Subject: [Iptel] draft-mahy-iptel-cpc

	Hi, 

	This draft (draft-mahy-iptel-cpc-06.txt) is expired. Will this draft become WG item? If not, is there any other standard way to carry CPC or OLI parameter in SIP? 

	Thanks, 
	Yiu