Subject: [ipv6-dir] RE: Updated document

From: [email-masked]
Date: Thu, 5 Jan 2006 16:50:44 +0200

Pekka,

Wouldn't be correct to say that the IETF is working on the
identifier/locator split. I'm not
sure we need to say that it is a approach, but this is an area that the
IETF is working on.
I doubt we want the ITU-T making there own locator-split solutions!

Also, there are various MIPv4/MIPv6 dual stack approaches in the works
as well.   Various people
have talked about SCTP as a IPv4/IPv6 transition mechansims, and then
some people want to 'port'
SHIM6 to IPv4 as well ... 

I still like to think that IETF makes protocols and works on the
end-to-end architecture, and
other SDOs use the stuff we make, as they need them.

John

>-----Original Message-----
>From: ext Pekka Nikander [mailto:[email-masked]] 
>Sent: 05 January, 2006 16:02
>To: Kurt Erik Lindqvist
>Cc: [email-masked]; Margaret Wasserman; IAB IAB; Loughney 
>John (Nokia-NRC/Helsinki); Brim Scott W; Bradner Scott; Leslie Daigle
>Subject: Re: Updated document
>
>> Please send comments!
>> <q.9-sg13-liasion-20060105.doc>
>>
>
>If we want to include speculative and forward looking text, I 
>propose the following for the "IPv4/IPv6 transition" bullet:
>
>---
>
>A potential future approach to IPv6/IPv4 interaction is to 
>implement the so called identifier/locator split in some way.  
>Among the various potential approaches being considered, the 
>approach used in the HIP working group 
>(draft-ietf-hip-arch-03.txt, in RFC Editor
>Queue) is among the more developed.  The parallel HIP research group  
>is studying the problems related to real life deployability of HIP.   
>If later decided to be adopted, HIP or some other 
>identifier/locator split approach may make the difference of 
>IPv4 and IPv6 irrelevant, allowing nodes to be mobile and 
>multi-homed between the two versions of IP, without any 
>IP-version related visibility to the applications.  [Technical 
>remark:  While the architectural approach taken by 
>identifier/locator split is different from the current 
>tunnelling and encapsulation approaches, at the actual 
>data-transport protocol level there is little if any 
>difference.  The differences lie in IP-layer state set up 
>between peer nodes and at the APIs available to the upper 
>layer protocols and applications.]
>
>---
>
>However, that text may be too speculative and/or something 
>that cannot be considered as a part of the IETF consensus.  I 
>am definitely biased here, and leave it for others to make the 
>evaluation.
>
>--Pekka
>
>

_______________________________________________
ipv6-dir mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipv6-dir

---

From: "Loughney John (Nokia-NRC/Helsinki)" <[email-masked]>
Date: Fri, 6 Jan 2006 14:01:38 +0200 (EET)

Scott, 
As NSIS chair, I welcome input & participation wrt to NGN.
John

---------------
Sent from my Nokia phone.

> From: ext Scott W Brim
> Received: Fri Jan 06 13:57:04 EET 2006
> To: Brian E Carpenter
> Cc: Kurt Erik Lindqvist, Leslie Daigle, <[email-masked]> (Nokia-NRC/Helsinki) John, IAB IAB, Margaret Wasserman, Bradner Scott, [email-masked]
> Subject: Re: [ipv6-dir] Re: Updated document
> 
> On 01/06/2006 06:28 AM, Brian E Carpenter allegedly wrote:
> > I've lost track of the original request
> 
> To refresh everyone, the whole paragraph at the end of their liaison was:
> 
>     It would be very much appreciated if the IETF could provide input
>     to study the impact of IPv6 to an NGN. Furthermore, it would be
>     very helpful and useful for our further collaboration if the IETF
>     could inform us of their standards plan regarding IPv6. We will
>     also inform the IETF of our ideas in the near future and then
>     commence creating Internet drafts to define our requirements.
> 
> 
>