Subject: RE: RFC 2461- issue list

From: Soliman Hesham <[email-masked]>
Date: Thu, 23 Oct 2003 10:18:12 -0400

A few important points there. I'm not sure I have 
the answers for all, but here is my understanding:

 > I have a high-level question first; is the intent to do these updates
 > and recycle the document as a draft standard?
 > Or to try to move it to full standard?

=> My understanding was that the new RFC would still
be in DS, but I could be wrong. It'd be good if the 
chairs shed some light on this.

 > 
 > If recycle at draft is the goal, are there documents (such as MIPv6)
 > which contain extensions to the packet formats which should be folded
 > into the base ND spec at this point in time?
 > 
 > In addition to the MIP issues in your list there is (at least) the
 > definition of the R bit in the prefix option, and the advertisement
 > interval option.

=> Right. So I'm not sure if the goal is to include all
the ND extensions in other specs, again it would be good
to get some feedback on this point. I assumed that extensions
would be done anyway in other specs as deemed necessary.
So, if this assumption is agreeable then the work should be 
limited to clarifying points in the spec or solving problems
that were discovered by people while working with this 
version of ND. Do you think we should include these 
extensions? 

There is also the process issue on what can be added to
a DS, given the requirements on moving from PS to DS
(having every option interop tested and some level of 
deployment), which might stand in the way of adding 
new extensions from a PS/draft.  

Hesham

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Fri, 24 Oct 2003 09:24:28 +0900

>>>>> On Thu, 23 Oct 2003 10:18:12 -0400, 
>>>>> Soliman Hesham <[email-masked]> said:

> version of ND.

FWIW, my understanding is the same on both points.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

---

From: Erik Nordmark <[email-masked]>
Date: Sat, 25 Oct 2003 11:59:39 +0200 (CEST)

> new extensions from a PS/draft.  

You are allowed to add things that have been at PS for 6 months with
interoperability test results i.e. things that could move to DS in
their own right. 

   Erik