Subject: RE: Issue 3: on link assumption considered harmful

From: Soliman Hesham <[email-masked]>
Date: Tue, 28 Oct 2003 23:56:47 -0500

> 
 > 	the "scenario" is not significantly attractive to me.  

=> Completely agree with you.

 > on the other
 > 	hand, the issue with the current conceptual sending 
 > algorithm (fallback
 > 	to IPv4 gets deleyed severely) is severe, so i'm all 
 > for the suggested
 > 	change.

=> Agreed.

Hesham

 > itojun

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Soliman Hesham <[email-masked]>
Date: Thu, 30 Oct 2003 07:09:51 -0500

> AFAIK, nothing else would break (fortunately).
 > 
 > I've already got an scenario, which is what you are
 > trying to break. Isn't that enough ?
 > 
 > Of course I can configure _manually_ the hosts , 
 > as well as configuring the IP address and the default route
 > (oops...why do people use DHCP ?)

=> I'm afraid you missed the point by a fair distance. 
If you use DHCP (when there is no default router) 
you could get the same prefix for the whole
link and everything will work fine with normal
next hop determination as is and after removing this
assumption. 

The only issue is when you don't use the same prefix
in all hosts on the link. This will NOT happen if:

- you manually configure the same prefix on all hosts
- you dynamically configure the same prefix on all hosts

Given the above, I don't understand what you're objecting 
to...

Hesham