Subject: Re: Issue 13: Omission of prefix options - resolution

From: Tim Hartrick <[email-masked]>
Date: Tue, 4 Nov 2003 11:18:52 -0800 (PST)

All,

> 
> >Suggested resolution:
> >
> >- Introduce a new code (1) in the router solicitation
> >and advertisement. When a host sends an RS with code = 1
> >it requests that the RA include all prefixses valid on
> >that link. Similarly, when a router sends an RA with code=1
> >it means that the RA includes all prefixes valid on that
> >link. This way, a MN can confirm its mobility.
> 
> 	we cannot always correlate RS and RA (router can listen to RS, then
> 	issue RA on the next periodic advertisement).  also RS does not solicit
> 	unicast RA.  the above solution does not work.
> 

The code or bit don't work all by themselves.  Clearly, new protocol machinery
will need to be specified so that hosts which understand the new code or bit
can live happily on subnets that don't have routers that speak using
the new code or bit.  The other combinations of old and new behavior will need
to be considered as well.  Pekka's suggestion of making router advertisements
all or nothing with respect to the inclusion of prefix options would achieve
the same ends.

We need a way for routers to communicate that there is more information
available and we need to work out the backward compatibility details for the
cases where either the host or the router don't understand or speak the new
dialect.  It doesn't sound impossible but it also sounds like more than just
a minor bug fix to the specification.  It would have been nice to fix this
when the problem was first noted several years ago.  That would have eliminated
the need to worry about backward compatibility.

Tim Hartrick
Mentat Inc.

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Greg Daley <[email-masked]>
Date: Wed, 05 Nov 2003 13:08:23 +1100

Hi Tim,

> the need to worry about backward compatibility.
Backward compatability shouldn't really be a problem.
Hosts which are doing RFC2461 Router Discovery
will understand RAs with options or bits in them
indicating solicitation or completeness, but just not
be able to access the improved function.

Implementations which support the new function
understand what the current problems are (you're
right, this may have to be codified somewhere), but
may be assisted by the presence of single bit or option,
just in the case where RA supports this.

I don't think it's that hard, but whether it goes into
RFC2461bis is another matter.

Greg