Subject: RE: Issue 29: AD REVIEW: IPv6 Node Requirements

From: [email-masked]
Date: Wed, 19 Nov 2003 18:18:53 +0200

Jari,

> > 4.6 Multicast Listener Discovery (MLD) for IPv6 - RFC2710
> > 
> >    If an application is going to join any-source multicast group
> >    addresses, it SHOULD implement MLDv1. When MLD is used, the rules in
> >    "Source Address Selection for the Multicast Listener Discovery (MLD)
> >    Protocol" [RFC-3590] MUST be followed.
> > 
> > 
> >>>If I understand correctly, these nodes could support either
> >>>MLDv1 or MLDv2.
> 
> The document already allows either MLDv1 or MLDv2 to
> be used. And yes, MLDv2 is backwards compatible to
> MLDv1 as John pointed out.
> 
> Perhaps the only question that I have left is... whether
> IPv6 nodes should support MLDv2 instead of MLDv1. The
> node requirements document and the MLDv2 draft intro
> gives the impression that the only difference is
> source-specific filtering. Then the current node
> reqs rules make sense. But Appendix B of the MLDv2
> draft seems to list a number of other modifications,
> including some enhancements to robustness. Are these
> important? I'm not an expert enough to determine that.

Appendicies are non-normative, so I think that we don't need to
worry about it in the Node Requirements document, though 
I am by no means an MLD expert.

John

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Jari Arkko <[email-masked]>
Date: Wed, 19 Nov 2003 18:34:38 +0200

> I am by no means an MLD expert.

Appendix B of the MLDv2 draft is simply a list of changes
from MLDv1. While this list is non-normative, I think the
changes are in the body... so my question is whether there's
really a bit more to MLDv2 than source-specific multicast.
But lets stop the discussion between MLD non-experts and
ask someone who knows: Brian, are there other improvements
in MLDv2 than source-specific multicast? If yes, are those
significant enough that nodes should migrate to MLDv2
even if they don't use the source-specific multicast feature?

--Jari

---

From: Brian Haberman <[email-masked]>
Date: Wed, 19 Nov 2003 12:45:09 -0500

Jari Arkko wrote:

>> worry about it in the Node Requirements document, though I am by no 
>> means an MLD expert.
> 
> 

So, I think I answered this already in an earlier message, but let
me clarify something here.  The IP stack layer really does not know
what kinds of multicast applications are going to be run on it.
A user could arbitrarily install an SSM application just as easily
as an ASM application, if the stack supports multicast at all.

With that in mind, if a stack developer knows for sure that his stack
couldn't be used for a certain flavor of multicast application (SSM
or ASM), then he can use the current guidelines in the node reqs to
determine whether MLDv1 or MLDv2 should be supported.

In all other cases, I would prefer MLDv2 for flexibility reasons.

So, if I back off my answer in the last post a little, perhaps the
wording for any-source should be something like "SHOULD support MLDv2
but MAY support MLDv1".

Brian

---

From: Jean-Jacques Pansiot <[email-masked]>
Date: Wed, 19 Nov 2003 19:02:19 +0100

> wording for any-source should be something like "SHOULD support MLDv2
Hi,

I think that running MLDv1 on a host has consequences on other hosts
on the same link  : if a host send a MLDv1 report for a group G,
then the router (Querier) must run in MLDv1 compatibility mode.
In effect, this prevents other hosts on the same link  to use MLDv2
and source selection for this group

Jean-Jacques

---

From: Brian Haberman <[email-masked]>
Date: Wed, 19 Nov 2003 14:42:55 -0500

Jean-Jacques Pansiot wrote:

> and source selection for this group.

The limitation is per group.  That is, the querying router will operate
in MLDv1 compatability mode for G when it sees an MLDv1 Report for G.
All other groups will remain in MLDv2 mode.

Brian

---

From: Jari Arkko <[email-masked]>
Date: Wed, 19 Nov 2003 21:40:01 +0200

> wording for any-source should be something like "SHOULD support MLDv2

With your explanation of the stack - app issues, I think this
would make sense. If others agree, and suitable text can be
crafted, of course. Anyway, this is not a crucial issue for
me but I just wanted to understand the implications.

--Jari

---

From: Jean-Jacques Pansiot <[email-masked]>
Date: Wed, 19 Nov 2003 19:02:19 +0100

Hi,

Jean-Jacques