Subject: RE: getnameinfo and various protocol types

From: "Bound, Jim" <[email-masked]>
Date: Thu, 11 Dec 2003 13:21:02 -0500

We should do this as addendum to 3493 for sure.
/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Thursday, December 11, 2003 3:44 AM
> To: [email-masked]
> Subject: getnameinfo and various protocol types
> 
> 
> 	getnameinfo(3) specification assumes that there are 
> only two transport
> 	protocols - tcp and udp.  when performing service name lookup
> 	it would use "tcp" if NI_DGRAM is not specified, and "udp" when
> 	NI_DGRAM is specified.
> 
> 	now we have couple of new transport protocols coming, 
> such as SCTP and
> 	DCCP.  how can we support service name lookup for those?  i.e.
> 	how can we tell getnameinfo(3) to use "sctp" or "dccp" 
> for the 2nd
> 	argument of getservbyport(3)?
> 
> 	my proposal:
> 	define NI_UDP as replacement of NI_DGRAM.  deprecate 
> NI_DGRAM (keep
> 	it as an alias to NI_UDP is okay).  define NI_SCTP, 
> NI_DCCP and such.
> 	these three are mutually exclusive, and if more than 
> one is specified
> 	it would cause EAI_FAIL.
> 
> itojun
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 20 Dec 2003 12:12:14 -0500

SCTP API should be done in that spec and be congruent to 3493 and new
addendum APIs which we need for getnameinfo. I believe Jack McCann is
contacting Itojun to work on addendum API spec for getnameinfo.  
/jim

> Behalf Of Jun-ichiro itojun Hagino
> Sent: Monday, December 15, 2003 4:28 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: getnameinfo and various protocol types
> 
> 
> > > Actualy, RFC2960 explictily states that "All current TCP 
> ports shall be
> > > automatically reserved in the SCTP port address space." 
> in the IANA
> > > considerations section.
> > 
> > That was what I remebered. If this indeed means that there will not
> > be any conflicting usage in the future (which the above text doesn't
> > explicitly say) then I think we at least don't have the problem
> > of getservbyport() returning different results for SCTP and TCP.
> > 
> > Don't know how significant the problem is that a given port 
> (e.g., 80)
> > might not be defined for SCTP, even though the port number is
> > reserved, so that getservbyport() for SCTP should
> > fail and getservbyport() for TCP would return a service string.
> 
> 	(it may not be a IPv6 question, but unix API question)
> 
> 	based on the RFC2960 statement, what should we do about 
> getservbyport
> 	2nd argument for SCTP connection, and/or /etc/services entries?
> 
> 	my guess is that (1) we need to put "foo/sctp" explicitly into 
> 	/etc/services and (2) 2nd argument must be "sctp".  
> this is based on
> 	observation from tcp/udp case (even if there's the same 
> service - such
> 	as http - on the same port, we put separate entries 
> into /etc/services)
> 
> itojun
>