Subject: RE: Optimistic DAD _again!_

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 20 Feb 2004 08:26:20 -0000

Hi Nick:

If more voices can help, you have my full support as well :)

Pascal
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Nick 'Sharkey' Moore
> Sent: jeudi 19 février 2004 09:52
> To: [email-masked]
> Subject: Optimistic DAD _again!_
> 
> Hi IPv6ers,
> 
> 	You might recall some time ago I stirred up some interest
> in my Optimistic DAD draft, which seeks to eliminate DAD delay
> without significantly increasing the risk involved in address
> collision.  In the meantime it's picked up a couple of independant
> implementations[1] and a couple of conference publications[2].
> 
> 	It was debated fairly thoroughly in MobileIP WG,
> (I presented the idea to the WG in San Francisco[3]) but
> has since been judged to be outside the scope of that group,
> as it is applies to any situation needing fast address
> configuration, not just MobileIP.
> 
> 	IPv6 WG seems the proper place for it to be developed
> further, and I'd like to open it up for debate here with the
> aim of moving it towards standardization.
> 
> The latest version is:
> 	<draft-moore-ipv6-optimistic-dad-04.txt>
> ... and it's _still_ only 13 pages long.
> 
> Please let me know what you think ... and if there's enough
> interest maybe we can discuss it further at Seoul.
> 
> -----Nick 'sharkey' Moore.
> 
> 
> [1] One by our team at Monash, one by Ed Remmel of Elmic Systems
> [2] See <http://bluesky.zoic.org/sharkey/> for refs ...
> [3] ... and for slides from these presentations.
> --
> Nick Moore, Resarch Fellow        | <[email-masked]>
> Monash University CTIE	          | <http://www.ctie.monash.edu.au/ipv6/>
> Australian Telecommunications CRC | <http://www.telecommunications.crc.org.au/>
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Mon, 23 Feb 2004 18:52:15 +0900

>>>>> On Thu, 19 Feb 2004 19:52:28 +1100, 
>>>>> "Nick 'Sharkey' Moore" <[email-masked]> said:

> implementations[1] and a couple of conference publications[2].

(snip)

> interest maybe we can discuss it further at Seoul.

I'd like to know if there has been a consensus to pursue any sort of
DAD optimization in the first place.  There have surely been lots of
discussions related to this issue, and, as far as I can recall, the
idea of optimization has never been adopted.

One fundamental question that I remember is whether optimizing DAD
really makes much sense while there are other kinds of delays such as
random delay (up to 1 second) for the first RS and random delay at
routers before responding to an RS.  Without addressing the
fundamental question(s), we'd simply restart similar divergent
discussions, waisting lots of energy and time without seeing progress.

p.s. I've read the latest draft and have some (mainly editorial)
comments.  I'll post the comments in a separate message.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]