Subject: Deletion of auto configured link local address

From: "Suvendu M" <[email-masked]>
Date: Fri, 19 Mar 2004 11:19:18 +0530

Hi,

I have a doubt regarding deletion of auto configured link local address. We
know that whenever a IPv6 node comes it comes up
with a link local address (addr1). Now say I manually configure another link
local address (addr2) on that interface (its possible if I am not  wrong).
Now can I delete the auto configured  link local address (addr1) ??

Regards
Suvendu.

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 19 Mar 2004 11:05:26 -0500 (EST)

Hi Suvendu,
	See comments inline.

Regards
Suresh

>local address (addr2) on that interface (its possible if I am not  wrong).

It is certainly possible but it is not required to be possible. The 
standards require an interface to have AT LEAST one link local address 
and having just one satisfies that requirement. There are some platforms 
such as IOS which will allow you to have only one link local. 

>Now can I delete the auto configured  link local address (addr1) ??

Yes. How you do it depends on your platform. Let's say you were using 
linux you could use the following commands

#ifconfig <interface_name> add <addr2>
#ifconfig <interface_name> del <addr1>

to accomplish what you wanted.

>Suvendu.

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.