Subject: Re: [pmtud] Re: [dccp] PMTU issues

From: Michael Welzl <[email-masked]>
Date: 18 Nov 2003 08:38:03 +0100

... I agree 100% with Eddie on these two (1. "we should
get rid of ICMP feedback in the long run", 2. "combine PMTUD
with ECN") issues.

Cheers,
Michael

On Tue, 2003-11-18 at 02:39, Eddie Kohler wrote:
> Hi Fred,
> 
> * PLPMTUD is useful.
> * Designing PMTUD so that it works in the absence of ICMP feedback seems
>   necessary.
> 
> BUT
> 
> * Suitable ICMP feedback hints might significantly improve the performance
>   of a transport protocol.
> * We can program our transports to react to ICMP as a hint -- i.e., not
>   trust it, but use it to optimize performance.
> * So ICMP should not be "needed", but it might, and probably would, be quite
>   helpful in some cases.
> * For instance, not all packetization layers have as easy a time as TCP
>   with packet size changes.  The smooth ramp-up suggested in PLPMTUD may
>   require intervention from the application for example.  For good
>   performance, these applications may apply PMTUD in unexpected ways --
>   they might start large, for example.  ICMP feedback would really help
>   them.
> * ICMP is not a significant cause of Internet congestion and need not ever
>   become one (mark it less-than-best-effort).
> 
> I still think your overloading of ECN capable as "PLPMTUD capable, don't
> send ICMP" is not necessary, a bad idea, and will not fly.
> 
> Eddie
> 
> _______________________________________________
> pmtud mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pmtud
-- 
Michael Welzl <[email-masked]>
University of Innsbruck

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Eddie Kohler <[email-masked]>
Date: Mon, 17 Nov 2003 17:39:19 -0800

Hi Fred,

* PLPMTUD is useful.

BUT

Eddie