Subject: RFC 2461 : Neighbor Discovery

From: "Subramonia Pillai - CTD, Chennai" <[email-masked]>
Date: Wed, 14 Apr 2004 11:01:37 +0530

Hi,

I am running IPV6CP for PPP links. I will come to know the link local
address from IPV6CP itself. I can also derive (global eui-64 based) global
unicast address based on IPV6CP identifier.

My doubt is "Should I run ND on PPP links in addition?"  Can any one please
tell me with the reason?

Thanks
Subu

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Soliman Hesham" <[email-masked]>
Date: Wed, 14 Apr 2004 06:17:18 -0400

> From router point of view, global address can be get from 
 > Configuration. So
 > I am still thinking, for router case do we need ND?

=> Do you think hosts connected to your router 
will need the information I mentioned in the last 
email? If yes, they will send RSs. 

I don't know what you're using the router for but
I don't know of any case where I can categorically
say don't implement RFC 2461. I think that it's 
basically always needed. If for nothing else, a host
might want to use NUD for reachability confirmation.

Hesham

 > 
 > Thanks in advance
 > Subu
 > 
 > -----Original Message-----
 > From: Soliman Hesham [mailto:[email-masked]]
 > Sent: Wednesday, April 14, 2004 11:57 AM
 > To: Subramonia Pillai - CTD, Chennai; [email-masked]
 > Subject: RE: RFC 2461 : Neighbor Discovery
 > 
 > 
 > 
 > => Do you want to configure a global address?
 > If you do then you need RFC 2461. Also you might 
 > need the NUD features in RFC2461 to detect reachability
 > of the default router. 
 > 
 > Hesham
 > 
 >  > 
 >  > Thanks
 >  > Subu
 >  > 
 >  > 
 >  > Administrative Requests: 
https://www1.ietf.org/mailman/listinfo/ipv6

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Thu, 15 Apr 2004 15:56:29 +0900

>>>>> On Wed, 14 Apr 2004 06:17:18 -0400, 
>>>>> "Soliman Hesham" <[email-masked]> said:

I think the original question is rather vague:

>>>>> On Wed, 14 Apr 2004 11:01:37 +0530, 
>>>>> "Subramonia Pillai - CTD, Chennai" <[email-masked]> said:

> My doubt is "Should I run ND on PPP links in addition?"  Can any one please

about which part of ND the question is asking (RFC2461 or RFC2462,
which part of each spec, etc).

Additionally, from the latter part of this thread, there seems to be
another confusion on whether we are only concentrating on routers,
only on hosts, or on both.

For further constructive discussion, these points should be clarified
in the first place, IMO.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]