Subject: RE: IPv6 WG Last Call:draft-ietf-ipv6-optimistic-dad-02.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 23 Sep 2004 14:46:22 -0400

> One major comment:
 >                                                              
 >                                                            
 > 5. Security Considerations
 > 
 >    Further work will be required to integrate Optimistic DAD 
 > with Secure
 >    Neighbor Discovery [SEND].
 > 
 > ==> sorry for not saying this earlier, but this seems unacceptable to
 > me.  SEND specs are already in the RFC-ed queue, and the WG has been
 > closed.  This IMHO needs to be analyzed here.  I.e., analyze 
 > and state
 > how oDAD interacts (or not) with SEND.  AFAICS, there 
 > shouldn't be any
 > showstoppers here..

=> Actually, just another comment on the same line in the draft, 
what kind of work is needed to allow for SEND and optDAD to coexist?
SEND should make life easier for this proposal, what needs
to be done?

Hesham

 > 
 > .....
 > 
 > A couple of editorial nits/typos:
 > 
 >    There will be no response to its NS (sent from ::), and this NS 
 > will
 >  
 > ==> s/::/the unspecified address/ (clearer when used in braces)
 > 
 >    This version of Optimistic DAD is dependant on the details of the
 >  
 > ==> s/dependant/dependent/
 > 
 >    [MIPV6] D. Johnson, C. Perkins, J. Arkko. Mobility 
 > Support in IPv6,
 >         revision 24 (draft-ietf-mobileip-ipv6-24).  June 2003 ...
 >         Expired December 2003.
 > 
 > ==> now RFC.
 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 > 
 > --------------------------------------------------------------------
 > IETF IPv6 working group mailing list
 > [email-masked]
 > Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
 > --------------------------------------------------------------------
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Fri, 24 Sep 2004 07:31:35 +1000

On 2004-09-23, Jari Arkko wrote:
>
> I agree with Pekka that it should be covered. But I also
> thought that at least an earlier version of the document
> already had SEND support...

Yeah, I don't think there's anything that needs to be changed, 
but I don't feel that I'm sufficiently expert in SEND to make
that call.  

cheers,

-----Nick