Subject: Link MTU restriction in 2461

From: "Soliman, Hesham" <[email-masked]>
Date: Mon, 25 Oct 2004 01:35:21 -0400

Hi, 

The following comment was received from Elwyn Davies:

	S6.3.4: (next to last para on p49):  The restriction in setting the LinkMTU to be not 	greater than the default value specified in the link type specific document is odd and 	actually inconsistent with the statements in RFC2590 for example (which allows LinkMTUs 	both larger and smaller than the default). 

I'm not sure about the history of this so I wanted to get some 
feedback from the authors or other members if possible. It is 
true that RFC 2590 allows for MTUs to be larger or smaller
than the default, provided that they're above 1280. 

Thoughts?

Hesham

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Erik Nordmark <[email-masked]>
Date: Sun, 24 Oct 2004 23:14:38 -0700

> than the default, provided that they're above 1280. 

I think this is an error in RFC 2461. To correct it there is perhaps a 
need to make the destinction between the default MTU and the upper 
limit. In the case of Ethernet (ignoring jumboframes) both values are 
the same which is why the wording is off.

So if the IP-over-foo specification has a hard upper limit, then MTU 
options larger than this should be ignored. But is it ok for the MTU 
option to be larger than the default MTU.

    Erik