Subject: RE: comments on draft-ietf-ipv6-privacy-addrs-v2-00.txt

From: Grubmair Peter <[email-masked]>
Date: Fri, 15 Oct 2004 20:52:51 +0200

Hi,
I am referring to page 14, chapter D.
It suggests to remember creation time of temporary addresses
and allows RAs to extend lifetimes of temporary addresses.

In original RFC3041 lifetime of temporary addresses could
only be lowered by RAs. No need to remember creation time.
(RFC3041, p. 10, 3.3 -> 1) .. When adjusting the lifetime of
 an existing temporary address, only lower the lifetime.)
Best regards
  Peter

-----Original Message-----
From: Suresh Krishnan [mailto:[email-masked]]
Sent: Freitag, 15. Oktober 2004 14:33
To: Grubmair Peter
Cc: 'Pekka Savola'; IPV6 IETF (E-mail)
Subject: RE: comments on draft-ietf-ipv6-privacy-addrs-v2-00.txt

Hi,
  I am not exactly sure what part of the draft you are referring about, 
but without the 2 hour lifetime rule stateless address autoconf is 
susceptible to a denial of service attack using fake RAs with low 
lifetimes. Can you give me the specifics regarding the text in the draft 
which you are worried about (section number, paragraph etc.)?

Regards
Suresh

On Thu, 14 Oct 2004, 
Grubmair Peter wrote:

>I want to state that I personally do not like the new
>idea from the draft to consider total lifetimes of a
>temporary address in case of some RAs renew prefixes.
>(Previously lifetimes of temporary addresses could only be
>lowered by RAs).
>This adds additional complexity for the rather rare
>event of a sites address renumbering.
>Best regards
>   Peter
>
>
>--------------------------------------------------------------------
>IETF IPv6 working group mailing list
>[email-masked]
>Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
>--------------------------------------------------------------------
>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 17 Oct 2004 00:21:18 -0400 (EDT)

Hi Peter,
   Remembering the creation time is not mandatory. It is just one way of 
satisfying the constraints. The node can use any other means if it so 
desires. 
  If you are worried about renumbering issues you can set a 
lower value for TEMP_VALID_LIFETIME and TEMP_PREFERRED_LIFETIME. An RA 
extending the lifetimes of a temporary address can NEVER extend it past 
the values you set in these variables. i.e. These values serve as a ceiling 
for the lifetimes of a temporary address. Would that address your 
renumbering issues?

Thanks
Suresh

On Fri, 15 Oct 2004, Grubmair Peter wrote:

>From: Suresh Krishnan [ mailto:[email-masked]
><mailto:[email-masked]> ] 
><https://www1.ietf.org/mailman/listinfo/ipv6>