Subject: Re: IPv6CP - rfc 2472 --- why only IID, why not prefix too

From: "Rajan Srivastava" <[email-masked]>
Date: Thu, 25 Nov 2004 20:15:24 +0530

Hi Bhaskar,

Yes, you are right if we talk about a PPPv6 client inside a LAN.

But if I have a PPPv6 client running at my home PC, I can't do ND.
I will have to resort to a DHCPv6 client [implemented at my PC itself]!
Or is there any alternative?

thanks & regards
Rajan

>From: Bhaskar S <[email-masked]>
>To: Rajan Srivastava <[email-masked]>
>Subject: Re: IPv6CP - rfc 2472 --- why only IID, why not prefix too
>Date: Thu, 25 Nov 2004 12:38:00 +0530
>
>Hi Rajan,
>
>When the PPP client received the IID, it can create its own Link-Local 
>address.
>
>Then if it needs a global address it can acquire a prefix from ND, using 
>this Link-local
>address. (Note: DHCP not required).
>
>So if your client doesn't need a global your implementation won't need to 
>do ND/DHCP.
>
>Rajan Srivastava wrote:
> >
> > Hi Greg,
> >
> > Thanks for the kind & prompt response.
> > What you mentioned is correct; but this kind of provision in IPv6 
>framework
> > has resulted in more complex implementations.
> >
> > Eg., if PPP server would have allocated
> > one prefix to PPP client (in IPv6CP) then the client would become a 
>globally
> > routable
> > host; and the PPP client might use this prefix as per his requirements;
> > and multiple prefix allotment could also take place in the same way as
> > defined in IPv6 RFCs!
> >
> > But since things are not defined in this way, PPP client and
> > server both have to have DHCPv6 client/server implemented
> > on them; making both the systems (PPP client & server)
> > more complex!
> >
> > Thanks & regards
> > Rajan
> >
> > >From: Greg Daley <[email-masked]>
> > >Reply-To: [email-masked]
> > >To: Rajan Srivastava <[email-masked]>
> > >CC: [email-masked]
> > >Subject: Re: IPv6CP - rfc 2472 --- why only IID, why not prefix too
> > >Date: Thu, 25 Nov 2004 13:09:05 +1100
> > >
> > >Hi Rajan,
> > >
> > >Rajan Srivastava wrote:
> > >>Hi,
> > >>
> > >>In rfc 2472, it is provisioned that PPP server will negotiate
> > >>interface identifier with PPP client, server will not pass on network
> > >>prefix;
> > >>and prefix delegation is left for DHCPv6 etc.
> > >>
> > >>What is rationale behind this strategy?
> > >
> > >IP(v4)CP believes that the peer PPP device can only have one address.
> > >
> > >In IPv6, there's a lot more flexibility regarding prefix utilization
> > >on a host or network.
> > >
> > >IPv6 Link-Local addresses have a fixed 64 bit upper portion, and so
> > >the 64 bit token used for IP6CP may be usable to generate a valid
> > >Link-Local address.
> > >
> > >Such an address can then be used in DHCP, or Neighbour Discovery.
> > >
> > >Since Router Discovery (part of Neighbour Discovery) can provide
> > >multiple prefixes to a host, any one or more of these prefixes
> > >may be used to autoconfigure an address.
> > >
> > >As you mentioned, prefix delegation caters to another set of devices:
> > >those requiring networks/prefixes of addresses.
> > >
> > >Each fills its own requirement, and it doesn't necessarily make sense
> > >to define another way to do this in IP6CP, since the assumptions
> > >are different to IPv4.
> > >
> > >
> > >Yours Sincerely,
> > >
> > >Greg Daley
> > >
> >
> > _________________________________________________________________
> > Protect your PC! Call in the experts! http://www.msn.co.in/security/ 
>Click
> > here now!
> >
> > --------------------------------------------------------------------
> > IETF IPv6 working group mailing list
> > [email-masked]
> > Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> > --------------------------------------------------------------------
>
>--
>Thanks and Regards,
>
>Bhaskar S.
>Ph: +91-80-26012284
>**************************************************
>  [ ]    General Business Information
>  [x]    Motorola Internal Use only
>  [ ]    Motorola Confidential Proprietary
>     POPI -  A Responsibility we all share
>**************************************************

_________________________________________________________________
Choose what you want to read. Protect your mail from spam. 
http://server1.msn.co.in/sp04/hotmailspamcontrol/  Win the war in 9 steps!

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Markku Savela <[email-masked]>
Date: Thu, 25 Nov 2004 17:08:06 +0200

> From: "Rajan Srivastava" <[email-masked]>

> Or is there any alternative?

Uhh? IPv6 stack is perfectly capable of receiving RA with prefix
information over the PPP link. That has been the normal IPv6 way of
doing it from day one, and the way all my PPP links have worked.
There is no need for DHCPv6.

---

From: Greg Daley <[email-masked]>
Date: Fri, 26 Nov 2004 11:14:32 +1100

Hi Rajan,

> Or is there any alternative?

ND runs over the PPP link.  The PPP link acts as a single IP link,
no matter whether it is PPPoE, PPPoA, PPP over modem, PPP over 3GPP2.

Greg