Subject: RE: IESG Comments about ICMPv6 draft: Obsoleting 2780

From: [email-masked]
Date: Sun, 27 Feb 2005 19:42:19 -0600

Allison,

It all makes sense now :)  Thanks for being patient :)

What about we replace "This document obsoletes RFC 2463 
[RFC-2463]." text with "This document obsoletes RFC 2463 
[RFC-2463] and RFC 2780 [RFC-2780]" ?

and Margaret adds a note to the RFC editor in her
writeup.

Both these action should take care of your second
comment.  Right ?

I am still trying to address your first comment
about ESP/AH RFCs.

Regards
Mukesh

> -----Original Message-----
> From: ext Allison Mankin [mailto:[email-masked]]
> Sent: Sunday, February 27, 2005 4:40 PM
> To: Gupta Mukesh.K (Nokia-NET/MtView)
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: IESG Comments about ICMPv6 draft: Obsoleting 2780 
> 
> 
> 
> Mukesh,
> 
> Well, let me try again, we often have documents that update only part
> of the earlier document.
> 
> In this case, we need people to know when the see RFC 2780
> in the index that there is another RFC that modifies some of its
> content.  If this isn't done, they'll pick up RFC 2780 and be
> misled into asking for the RFC 2780 rules for ICMPv6.  This causes
> delay and problems until they get straightened out to get to the
> right rules for ICMPv6.  If you look at the RFC Editor definition
> for Updates, it does not say how much of the RFC has to be updated
> (see below).
> 
> 
> > RFC 2780 provides guidelines for more than ICMP (IPv4, IPv6,
> > TCP, UDP) and this ICMPv6 draft updates only section 6 and 7=20
> > (ICMP).  So will it not be wrong to say that this spec updates
> > 2780.  What if someone was looking to do a registry action
> > about TCP and they looked at the index and looked at the
> > note that 2780 has been updated by this spec and couldn't
> > find guidelines for TCP in this spec ?
> > 
> > Am I making my concern clear ?
> > 
> 
>   The RFC Editor has the following formal rule (in their 
> almost approved
>   draft-rfc-editor-rfc2223bis-08.txt)
> 
>  Updates
> 
>  Specifies an earlier document whose contents are modified or
>  augmented by the new document.  The new document cannot be
>  used alone, it can only be used in conjunction with the
>  earlier document.
> 
> This says nothing about how much or how little of the earlier 
> document the new document updates.
> 
> Does this give you enough help on the update point?  Margaret,
> this ok? 
> 
> Allison
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Allison Mankin <[email-masked]>
Date: Sun, 27 Feb 2005 19:45:19 -0800

> What about we replace "This document obsoletes RFC 2463=20
> [RFC-2463]." text with "This document obsoletes RFC 2463=20

Oops - 

This document obsoletes RFC 2463 [RFC2463] and *updates*
RFC 2780 [RFC-2780].

With that proviso, yes!

> Both these action should take care of your second

Yes!

> I am still trying to address your first comment

Okay, I'll await that.