Subject: IESG Comments about ICMPv6 draft: Obsoleting 2780

From: [email-masked]
Date: Sun, 27 Feb 2005 03:39:00 -0600

Allison,

I am trying to address the following comment of yours for
the ICMPv6 draft (draft-ietf-ipngwg-icmp-v3-06.txt).

Please see my comments inline..

> The document includes a ref to RFC 2780 but never mentions it.
> In the IANA considerations, it needs to state that it obsoletes 
> 2780's IANA instructions on ICMPv6.

Good catch.  What about adding the following text in the IANA
Consideration section in the next rev ?

====
This specification obsoletes 2780's IANA instructions for ICMPv6.
The IANA is requested to use the guidelines provided in this
specfication for assigning ICMPv6 type and code values as soon
as this specification is published as a RFC.
====

> The RFC Editor needs to be told that this RFC updates 2780,

Why do we need to tell this to RFC Editor ?  and this draft
does not update the 2780 as a whole.  It just updates the part
that talks about ICMP.

> as well as obsoleting the previous ICMPv6 spec. 

We already have "This document obsoletes RFC 2463 [RFC-2463]."
line in the introduction of the current draft.  Is it not
enough ?

> new IANA Considerations are great. We should make sure the 
> loose ends are tied. 

We have tried to tie them all :)  If you see any loose ends,
please let us know.

Regards
Mukesh

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Allison Mankin <[email-masked]>
Date: Sun, 27 Feb 2005 08:08:26 -0800

Hi, Mukesh,

I've answered you inline, in turn.  

> > In the IANA considerations, it needs to state that it obsoletes=20

> as this specification is published as a RFC.

This text is very good.

> does not update the 2780 as a whole.  It just updates the part

Updating an RFC often means just updating a part. Iit's important for
for someone who want to do a registry action about ICMPv6 and may
look at RFC 2780.  Because you tell RFC Editor that this spec
updates RFC 2780, there will be a pointer in the index from
RFC 2780 to this spec, guiding the person here.  It's a help
if someone is doing an RFC-index based search for how to register.

> line in the introduction of the current draft.  Is it not
My comment didn't mean you needed to add more statements
about obsoleting RFC 2463 to the draft, just add the one
fact to the other.  And it would be good to ask your AD put
the RFC obsoleted and RFC updated info in the writeup, so the
RFC Editor doesn't have to dig it out of the spec.

---

From: [email-masked]
Date: Mon, 28 Feb 2005 13:31:24 -0600

> Oops - 
> 
> This document obsoletes RFC 2463 [RFC2463] and *updates*
> RFC 2780 [RFC-2780].
> 
> With that proviso, yes!

Oops !  Sorry about that :)

> Okay, I'll await that.

There is another thread already going on about the second
comment.  I would appreciate your comments to that thread
too.

Regards
Mukesh