Subject: RE: IPv6 Address Architecture update question

From: "sasson, shuki" <[email-masked]>
Date: Tue, 1 Feb 2005 10:13:44 -0500

Listening for both IPv4 and IPv6 connection is very useful for servers. 
Examples ftp server, SNMP agent.
Servers usually don't care about the source address since they are
responding to source no matter if this is an IPv4 address or IPv6 address.
The existing interface allows them to do it with the same loop as for IPv4.
Thus porting of servers becomes much easier.
Connecting clients do need to know about the destination addresses. Still
keeping the current interface for servers is a must!

Shuki 

> > From: Jeroen Massar <[email-masked]>
> 
> > Thus that applications should be using multiple sockets, one
> > for IPv4 and one for IPv6 and one for whatever follows.
> 
> I strongly object to this. There are other socket api's which don't
> have the Unix inherited drawbacks. For such, the recommendation is
> exactly the opposite: the same socket works just fine for IPv4 and
> IPv6, and in unifying the application code to work for both, IPv4
> mapped address format is very useful tool.

Any documentation on this ? I do know RFC3493, not any others.

> There is no reason for application to care at all whether actual
> connection is over IPv4 or IPv6.

There is, these are different protocols, how else are you going to
address which host you are going to connect to?

For instance www.kame.net port 80 results in different answers over IPv6
than the one on IPv4...

If you are talking about wrappers, then these are most likely wrapping
around the above already anyway, thus it matter than?

Greets,
 Jeroen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jeroen Massar
Sent: Tuesday, February 01, 2005 9:46 AM
To: Markku Savela
Cc: [email-masked]; Bob Hinden
Subject: Re: IPv6 Address Architecture update question

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 1 Feb 2005 16:43:05 +0100

> Thus porting of servers becomes much easier.

The point is that server portability becomes much harder. That might
not be an issue for you, but for many it is.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: "Alan Chang" <[email-masked]>
Date: Wed, 2 Feb 2005 10:26:58 +0800

Hi,

I agree the removal.

We are working for importing IPv6 to our embedded OS.
At initial phase, we used v4-mapped address to upgrade server and everything
worked fine.
But when we needed more detail control, we failed to set IP layer socket
option with AF_INET6 socket.
So the modification of the listen(::) + listen(0.0.0.0) was needed finally.

-Alan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
sasson, shuki
Sent: Tuesday, February 01, 2005 11:14 PM
To: Jeroen Massar; Markku Savela
Cc: Bob Hinden; [email-masked]
Subject: RE: IPv6 Address Architecture update question

Shuki 

> > Thus that applications should be using multiple sockets, one for 
> > IPv4 and one for IPv6 and one for whatever follows.
> 

> connection is over IPv4 or IPv6.

There is, these are different protocols, how else are you going to address
which host you are going to connect to?

Greets,
 Jeroen