Subject: RE: 2461bis update

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 26 May 2005 15:31:54 -0400

> 
 > My primary suggestion is thus to remove "problem 1)" of Appendix A.
 > Or, if we still want to emphasize the "complexity" of the multi-homed
 > case, I'd rewrite it to:
 > 
 >      1) If no Router Advertisement is received on any interfaces, a
 >         multihomed host will have no way of knowing which 
 > interface to
 >         send packets out on, even for on-link destinations.  One
 >         possible approach for a multihomed node would be to 
 > attempt to
 >         perform address resolution on all interfaces.  The same
 >         argument applies to a singlehomed node that does not receive
 >         any Router Advertisement, but the step in the multihomed case
 >         involves significant complexity.

=> So to be very clear, you're suggesting that if we don't remove probem 1) then we should use 
the above text instead of the following:

If no Router Advertisement is received on any interfaces, a multihomed host will have no way 
of knowing which interface to send packets out on, even for on-link destinations. One possible approach 
for a multihomed node would be to attempt to perform address resolution on all interfaces, a step involving 
significant complexity.

Essentially, the delta is: "The same argument applies to a singlehomed node that does not receive
any Router Advertisement"

Hesham

 > 
 > 					JINMEI, Tatuya
 > 					Communication Platform Lab.
 > 					Corporate R&D Center, 
 > Toshiba Corp.
 > 					[email-masked]
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Fri, 27 May 2005 05:08:46 +0900

>>>>> On Thu, 26 May 2005 15:31:54 -0400, 
>>>>> "Soliman, Hesham" <[email-masked]> said:

> => So to be very clear, you're suggesting that if we don't remove
> probem 1) then we should use the above text instead of the
> following:

> If no Router Advertisement is received on any interfaces, a
> multihomed host will have no way of knowing which interface to send
> packets out on, even for on-link destinations. One possible approach
> for a multihomed node would be to attempt to perform address
> resolution on all interfaces, a step involving significant
> complexity.

Yes.  (While my primary impression is that we don't have to mention
this case any more with the removal of the "on-link assumption", which
makes the problem not specific to multihomed nodes)

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]