Subject: RFC2460: question about next header field

From: Yukiyo Akisada <[email-masked]>
Date: Thu, 25 Aug 2005 13:11:29 +0900

Hi, all.

I have a question about next header handling.

RFC2460 says, the node send Parameter Problem Code 1
when the node doesn't support the next header type.

    4.  IPv6 Extension Headers
    ------------------------------------------------------------------------
    351    If, as a result of processing a header, a node is required to proceed
    352    to the next header but the Next Header value in the current header is
    353    unrecognized by the node, it should discard the packet and send an
    354    ICMP Parameter Problem message to the source of the packet, with an
    355    ICMP Code value of 1 ("unrecognized Next Header type encountered")
    356    and the ICMP Pointer field containing the offset of the unrecognized
    357    value within the original packet.  The same action should be taken if
    358    a node encounters a Next Header value of zero in any header other
    359    than an IPv6 header.
    ------------------------------------------------------------------------

If the subsequent payload is empty, what should the node do?

    IPv6 Header
        Next Header = Destination Options Header
    Destination Options Header
        Next Header = unrecognized Next Header type
    No Next Header
        Payload     = 0 octets

Should the node send Parameter Problem? or just discard it?

The text says "a node is required to proceed to the next header",
and 0 octets payload doesn't need to be proceeded by the node.
It can be read that the node can just ignore the packet.
But I still think a node need to send Parameter Problem,
because the packet is broken.

How should the node do?

Thanks,

------------------------------------------------------------------------
Yukiyo Akisada <[email-masked]>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Vishwas Manral" <[email-masked]>
Date: Wed, 24 Aug 2005 21:50:19 -0700

Hi,

I think the ICMP Parameter Problem with code value of 1, could to be
sent in such a case.

Thanks,
Vishwas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Yukiyo Akisada
Sent: Thursday, August 25, 2005 9:41 AM
To: [email-masked]
Subject: RFC2460: question about next header field

Hi, all.

 
------------------------------------------------------------------------
    351    If, as a result of processing a header, a node is required to
proceed
    352    to the next header but the Next Header value in the current
header is
    353    unrecognized by the node, it should discard the packet and
send an
    354    ICMP Parameter Problem message to the source of the packet,
with an
    355    ICMP Code value of 1 ("unrecognized Next Header type
encountered")
    356    and the ICMP Pointer field containing the offset of the
unrecognized
    357    value within the original packet.  The same action should be
taken if
    358    a node encounters a Next Header value of zero in any header
other
    359    than an IPv6 header.

    IPv6 Header

How should the node do?

Thanks,