Subject: IPv6 Final Destination Option

From: Srinivas Goud <[email-masked]>
Date: Wed, 3 Aug 2005 13:10:38 +0530

Hello All, 
Is Final Destination Option (just before upper layer protocol), mutable or 
immutable?
Can I assume that Destination Options inside AH (before AH) are mutable and 
Destination Option outside AH (after AH) as Immutable?

Thanks in advance,
Srinivas.
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Thu, 04 Aug 2005 06:57:50 +0900

>>>>> On Wed, 3 Aug 2005 13:10:38 +0530, 
>>>>> Srinivas Goud <[email-masked]> said:

> Is Final Destination Option (just before upper layer protocol), mutable or 

Whether an destination (or hop-by-hop) option is mutable is defined
per-option basis.  It is irrelevant from the position of the options
header containing each particular option (e.g. just before upper layer
protocol).  See RFC2460 for more details.

So,

> Destination Option outside AH (after AH) as Immutable?

No, you can't.  You need to examine the third-highest-order bit of
each option, regardless of the header position.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

---

From: Srinivas Goud <[email-masked]>
Date: Thu, 4 Aug 2005 10:39:00 +0530

I do agree with your points, but if you loot at rfc3775, it says that

" The use of IPsec Authentication Header (AH) for the Home Address option is 
not required, except that if the IPv6 header of a packet is covered by AH, 
then the authentication MUST also cover the Home Address option; this 
coverage is achieved automatically by the definition of the Option Type code 
for the Home Address option, since it indicates that the data within the 
option cannot change en route to the packet's final destination, and thus 
the option is included in the AH computation."

from the above, it is satisfactory that final destination option cannot be 
mutable.
any opinions?

Thanks,
Srinivas.

---

From: YOSHIFUJI Hideaki / 吉藤英明<[email-masked]>
Date: Thu, 04 Aug 2005 08:37:50 +0200 (CEST)

> from the above, it is satisfactory that final destination option cannot be 

No. It is only a instance of destination options.
Because it is possible to have other destination option(s),
you cannot assume that "final" destination option is not mutable
just by its position.

--yoshfuji

---

From: Francis Dupont <[email-masked]>
Date: Thu, 04 Aug 2005 10:58:10 +0200

In your previous mail you wrote:

   I do agree with your points, but if you loot at rfc3775, ...
   
=> the question is a bit different: is it silly to define a mutable
option which can only be in the final destination option header so
cannot be mute en route? This is true but you can't infer that options
at this place must be not mutable.

Regards

[email-masked]