Subject: RE: IPv6 and Tiny Fragments

From: "Vishwas Manral" <[email-masked]>
Date: Fri, 25 Nov 2005 01:57:52 -0800

Hi Pekka,

That sounds good. We seem to be coming from different direction but to
the same thing. 

I however would prefer to be closer to 800, to allow more levels of
encapsulation, especially the first header. 

I do not agree with Mohacsi because the 1280 limit will not allow
further encapsulations, without fragmentation. 

Pekka, besides the RFC does not state how we treat M flag as 0 and
fragment Offset as 0?

Thanks,
Vishwas
-----Original Message-----
From: Pekka Savola [mailto:[email-masked]] 
Sent: Friday, November 25, 2005 3:12 PM
To: Vishwas Manral
Cc: Mohacsi Janos; [email-masked]
Subject: RE: IPv6 and Tiny Fragments

Hi,

On Fri, 25 Nov 2005, Vishwas Manral wrote:
> I think that is the minimum Link MTU and not the smallest size
non-last
> fragment.
>
> Can you point me to the RFC/ draft which says what you stated?

This is a good point.  Let me copy a part of Elwyn Davies's message on 
the list on September:

Date: Wed, 21 Sep 2005 23:14:26 +0100
From: Elwyn Davies <[email-masked]>
To: Bob Hinden <[email-masked]>, Brian Haberman
<[email-masked]>
Cc: [email-masked]
Subject: Taking RFC2460 (base IPv6) spec to full standard - issues
outstanding
....
[outstanding issues in core IPv6 spec before moving to full standard]
?       Fragment reassembly algorithm - should explicitly forbid
overlapped
         fragments and possibly require that non-final fragments are
(say) at
         least 1024 bytes.

The minimum IPv6 fragment size is not specified AFAICT.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Mohacsi Janos <[email-masked]>
Date: Fri, 25 Nov 2005 11:40:37 +0100 (CET)

> further encapsulations, without fragmentation.

What further encapsulation are you referering to? If I would be a 
implementer and I would have to pass packets bigger than MTU.
I would take as much content as I can into the first fragmented packet and 
so on until there is content left. I would use fragment at least minimum 
MTU (size >1280).

> Pekka, besides the RFC does not state how we treat M flag as 0 and

Janos Mohacsi
Network Engineer, Research Associate
NIIF/HUNGARNET, HUNGARY
Key 00F9AF98: 8645 1312 D249 471B DBAE  21A2 9F52 0D1F 00F9 AF98