Subject: RE: [Int-area] Re: KHIs and SHA-256

From: "Christian Huitema" <[email-masked]>
Date: Mon, 14 Nov 2005 16:02:13 -0800

IMHO, every identifier ends up being routed, at least in some context.
For example, there is a good case that on a disconnected ad hoc network,
it makes more sense to use the identifiers you have than to create some
new addresses. Indeed, if one is willing to have individual host entries
in a routing table, then one can use any identifier.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Geoff Huston
Sent: Monday, November 14, 2005 3:40 PM
To: Manfredi, Albert E
Cc: [email-masked]; Internet Area
Subject: RE: [Int-area] Re: KHIs and SHA-256 

I heard "non-routeable" with respect to these identifiers.

Is this _really_ the case?

   Geoff

At 10:03 AM 15/11/2005, Manfredi, Albert E wrote:
>I didn't assume that the identifier space with no locator overtones
must
>be non-intersecting with a routable network space.
>
>Are you saying that use of these identifiers must only apply to
isolated
>nets?
>
>Bert
>
>
> > -----Original Message-----
> > From: Geoff Huston [mailto:[email-masked]]
> > Sent: Monday, November 14, 2005 5:54 PM
> > To: Manfredi, Albert E
> > Cc: Internet Area; [email-masked]
> > Subject: RE: [Int-area] Re: KHIs and SHA-256
> >
> > Don't present such packets to the router.
> >
> > i.e. if you are working in an identifier space that has no locator
> > overtones (I have already seen the assertion that these
> > identifiers are
> > "non-routeable"), then how exactly will these identity values
> > show up in a
> > packet on the wire and be presented to routers are a
> > destination or source
> > locator?
> >
> >    Geoff
> >
> >
> >
> >
> >
> >
> > At 08:03 AM 15/11/2005, Manfredi, Albert E wrote:
> > >Geoff,
> > >
> > >How would a router know not to forward such packets, in the event
the
> > >top 64 bits clash with a real IPv6 address?
> > >
> > >Bert
> > >
> > >
> > > > -----Original Message-----
> > > > From: Geoff Huston [mailto:[email-masked]]
> > > > Sent: Monday, November 14, 2005 3:11 PM
> > > > To: Pekka Nikander
> > > > Cc: [email-masked]; Brian Haberman; Internet Area
> > > > Subject: Re: [Int-area] Re: KHIs and SHA-256
> > > >
> > > > But nothing in what you have said is inconsistent with the
> > > > proposition that
> > > > there is _no_ requirement to allocate IPv6 unicast address
> > > > space for this
> > > > form of use of 128 numbers.
> > > >
> > > > As you yourself point out "they are non-routeable" and theya
> > > > re understood
> > > > to be "semantically different".
> > > >
> > > > i.e. what you are going with the number in this context is
really
> > > > interesting, and a Good Thing in terms of furthering our
> > > > understanding of
> > > > the implications of the identifier / locator split. But I
> > > > have yet to see a
> > > > justification as to why these numbers should also entail a
> > > > reservation in
> > > > the IPv6 unicast number space. Indeed, I can think of
> > some tolerable
> > > > arguments as to why they should deliberately clash with
> > > > unicast address values.
> > > >
> > > > regards,
> > > >
> > > >       Geoff
> > >
> > >
> >
>--------------------------------------------------------------------
> > >IETF IPv6 working group mailing list
> > >[email-masked]
> > >Administrative Requests:
https://www1.ietf.org/mailman/listinfo/ipv6
> >
>--------------------------------------------------------------------
> >
> >
> >
> >

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Geoff Huston <[email-masked]>
Date: Tue, 15 Nov 2005 11:14:40 +1100

>IMHO, every identifier ends up being routed, at least in some context.

Does your statement here specifically encompass the DNS? If not, then what 
is the difference between such DNS identifiers and the ones under 
consideration in this context?

regards,

   Geoff

---

From: David Conrad <[email-masked]>
Date: Mon, 14 Nov 2005 17:01:38 -0800

Christian,

> IMHO, every identifier ends up being routed, at least in some context.

If they are routed, they are not identifiers.  They are locators.

An identifier simply names the object.  It might enable connectivity  
on a non-routed infrastructure, e.g., a local LAN, and if you want to  
call this 'being routed', then your comment could be considered  
accurate, but in a rather pointless sense.

> in a routing table, then one can use any identifier.

Then the locator and the identifier have the same value, but they are  
semantically different.

I don't quite understand why this is so difficult for folks to  
understand.  IMHO, the failure to differentiate the two is probably  
the biggest failing in the IP protocol.

Rgds,
-drc
Speaking only for myself

---

From: Pekka Nikander <[email-masked]>
Date: Tue, 15 Nov 2005 09:51:26 +0100

Christian,

> IMHO, every identifier ends up being routed, at least in some context.

I think I fully agree with you, but IMHO we need to be very careful  
about the terminology here.  For example, I can easily imagine an  
overlay network, running on the top of the current IP network, using  
DHTs to "route" flat identifiers.  If we want to call that kind of  
"application-layer" forwarding routing, then I fully agree.

> in a routing table, then one can use any identifier.

I concur.  But as you well know, that does not scale.  Once your ad  
hoc network grows to a size where clustering becomes a necessity, you  
can no longer use fixed flat identifiers for routing purposes.  [Note  
that I am not saying that you need hierarchically organised  
addresses; more desirable would probably be dynamically assigned  
locators that encode clustering information in some better-than- 
hierarchically-assigned way.]

--Pekka

---

From: Pekka Nikander <[email-masked]>
Date: Tue, 15 Nov 2005 09:58:28 +0100

David,

> An identifier simply names the object.  It might enable  
> connectivity on a non-routed infrastructure, e.g., a local LAN, and  
> if you want to call this 'being routed', then your comment could be  
> considered accurate, but in a rather pointless sense.

I think Christian's point here is that one man's identifiers are  
other man's locators.  All depends on your point of view, or layer  
what you are looking at.  However, as I noted in my previous message,  
while having some value, such usage of terms it is likely to cause  
confusion, requiring care with terminology.

Ad hoc (and other sufficiently small) networks are a kind of a  
special case since you can mix identifiers and locators there,  
simplifying the architecture.  I also happen to believe that this  
confounding of roles in current IP addresses is one of the reasons  
why the Internet has been so successful as it is.  However, to me it  
is also clear that it is high time to move on, and to split these two  
roles.

--Pekka

---

From: Geoff Huston <[email-masked]>
Date: Wed, 16 Nov 2005 05:37:09 +1100

At 07:58 PM 15/11/2005, Pekka Nikander wrote:
>what you are looking at.

My apologies, but this is getting a little spaced out in terms of being 
able to understand where you are heading here.

My point of view is, i thought, pretty simple. I am looking at routers that 
forward packets according to a precisely defined matching algorithm between 
the contents of the packet's destination address field and the forwarding 
table in the router. What we used to call "addresses".

Where exactly are you looking?

regards,

  Geoff

---

From: Pekka Nikander <[email-masked]>
Date: Tue, 15 Nov 2005 21:46:51 +0100

Dear Geoff,

> My apologies, but this is getting a little spaced out in terms of  
> being able to understand where you are heading here.
>
> [...]
>

Sorry for trying to interpret Christian's intentions, thereby  
confusing the things.  I merely tried to understand what Christian  
meant, nothing more.

What I really have wanted to say so far was the transition plan message,
http://www1.ietf.org/mail-archive/web/ipv6/current/msg05900.html

--Pekka