Subject: Fwd: Request To Advance: <draft-ietf-ipv6-2461bis-05.txt>

From: Brian Haberman <[email-masked]>
Date: Tue, 1 Nov 2005 13:04:37 -0500

Begin forwarded message:

> From: Brian Haberman <[email-masked]>
> Date: November 1, 2005 13:04:17 EST
> To: The IESG <[email-masked]>, Margaret Wasserman 
> <[email-masked]>
> Cc: Mark Townsley <[email-masked]>, Bob Hinden 
> <[email-masked]>
> Subject: Request To Advance: <draft-ietf-ipv6-2461bis-05.txt>
>
> Margaret & Mark,
>      On behalf of the IPv6 WG, the chairs request the advancement of:
>
> 	Title		: Neighbor Discovery for IP version 6 (IPv6)
> 	Author(s)	: T. Narten, et al.
> 	Filename	: draft-ietf-ipv6-2461bis-05.txt
> 	Pages	: 88
> 	Date		: 2005-10-21
>
> to Draft Standard.  This version addresses all comments received 
> during the
> working group last calls.
>
> Regards,
> Brian & Bob
> IPv6 WG co-chairs
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Mon, 07 Nov 2005 17:31:44 +0900

Excuse me for not doing this earlier, but I finally check the 05
version to see my previous comments were addressed, and found some
points I'm not sure about.

>>>>> On Tue, 1 Nov 2005 13:04:37 -0500, 
>>>>> Brian Haberman <[email-masked]> said:

>> Filename	: draft-ietf-ipv6-2461bis-05.txt

I'm not sure if this one is correctly addressed:
  http://www1.ietf.org/mail-archive/web/ipv6/current/msg05107.html
(BTW: msg05107 is a comment on version 03, and I could not get a 04
 version.  Has that version been issued, or is the version number
 bumped?)

I've compared the difference of the state machine in Appendix C
between the 03 and 05 versions (attached below).  At least it doesn't
seem to cover the case where the neighbor cache entry does not exist.
It also does not cover the case where a Redirect message (w/o target
link-layer address option) caused the situation in question.  In
addition, I don't understand the following entry (added in 05):

+   INCOMPLETE      NA, Solicited=any,     Send ICMP error      unchanged
+                   Override=any, No       (if router) or
+                   Link-layer address     log error (if host)
+

Which ICMP error is expected to be sent in this case?  Why do we
separate the case for router and host?

These points are probably pretty minor, and we can probably deal with
those in concurrent with the AD/IESG evaluation, though.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

--- 03.txt	Mon Nov  7 17:21:58 2005
+++ 05.txt	Mon Nov  7 17:22:36 2005
@@ -20,11 +20,19 @@
                    Override=any           address. Send queued
                                           packets.
 
+   INCOMPLETE      NA, Solicited=any,     Send ICMP error      unchanged
+                   Override=any, No       (if router) or
+                   Link-layer address     log error (if host)
+
    !INCOMPLETE     NA, Solicited=1,        -                   REACHABLE
                    Override=0
                    Same link-layer
                    address as cached.
 
+   !INCOMPLETE     NA, Solicited=any,     Update content of    unchanged
+                   Override=any, No       IsRouter flag.
+                   link-layer address
+
    REACHABLE       NA, Solicited=1,        -                     STALE
                    Override=0
                    Different link-layer
@@ -89,6 +97,9 @@
    !INCOMPLETE     NS, RS, RA, Redirect    Update link-layer     STALE
                    Different link-layer    address
                    address than cached.
+
+   INCOMPLETE      NS, RS No link-layer    -                   unchanged
+                   address
 
    !INCOMPLETE     NS, RS, RA, Redirect    -                   unchanged
                    Same link-layer