Subject: How to use IPv6 feature in WINDOWS XP on laptop

From: Li Defeng <[email-masked]>
Date: Mon, 21 Nov 2005 00:54:37 +0800

Hello, All,

I use wireless card to access internet for my laptop,and the operating system is WINDOWS XP, I have already installed IPv6 protocol for my wireless network connection, which is done by select"control panel--> network and internet connection--> network connection--> wireless network connection", then click the right button on the mouse, select "property",then click "install", and select "protocol", select TCP/IP v6. After then I run ipconfig, find that I have already have thress IPv6 addresses, one for the wireless link, one for Tunnel adapter Teredo Tunneling Pseudo-Interface,Tunnel adapter Automatic Tunneling Pseudo-Interface, the result of IPconfig is attached in this e-mail, could you please explain what the addresses of fe80::211:95ff:fe92:e110%6,fe80::5445:5245:444f%4,fe80::5efe:192.168.2.105%2 stand for?

Another problem is with these IPv6 address, how to access IPv6 applications in the web?

Best Regards

Defeng
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: David Malone <dwmalone=[email-masked]>
Date: Sun, 20 Nov 2005 19:57:18 +0000

On Mon, Nov 21, 2005 at 12:54:37AM +0800, Li Defeng wrote:
> After then I run ipconfig, find that I have already have thress
> IPv6 addresses, one for the wireless link, one for Tunnel adapter
> Teredo Tunneling Pseudo-Interface,Tunnel adapter Automatic Tunneling
> Pseudo-Interface, the result of IPconfig is attached in this e-mail,
> could you please explain what the addresses of
> fe80::211:95ff:fe92:e110%6,fe80::5445:5245:444f%4,fe80::5efe:192.168.2.105%2
> stand for?

These addresses are link local addresses that are automatically
generated by IPv6 for the interfaces. Roughly speaking, can tell
they are link local because they start "fe80". Link local addresses
are only good for talking to hosts on the same link, and so are
of limited use to you.

> Another problem is with these IPv6 address, how to access IPv6

Internet Explorer will automatically use IPv6 on windows when
accessing IPv6 web sites on machines with IPv6 connectivity. Before
you can do this, you will need to get connectivity to the IPv6
Internet. You should probably grab a book on setting up IPv6 to
find out how to do this.

	David.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 20 Nov 2005 22:35:37 +0100

I guess this is more a topic for [email-masked] ML, but in short, if your XP
didn't got a 2002 address means 6to4 is not working (probably you don't have
a public IPv4 address), and if you didn't got a Teredo address is because
you're behind a NAT box which didn't like it. So the alternative is to use a
Tunnel Broker. You have quick instructions available when you select your
own OS at our own TB:

http://www.ipv6tf.org/using/connectivity/test.php

Regards,
Jordi

> De: David Malone <dwmalone=[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Sun, 20 Nov 2005 19:57:18 +0000
> Para: Li Defeng <[email-masked]>
> CC: "[email-masked]" <[email-masked]>
> Asunto: Re: How to use IPv6 feature in WINDOWS XP on laptop
> 

************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Information available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.