Subject: Re: N reasons for not deploying ipv6

From: "Eric Klein" <[email-masked]>
Date: Mon, 17 Apr 2006 18:41:11 +0200

(Cross posting this to IPv6-OPS and IPV6 lists - started on the OPS list)

Does anyone else have additonal  items that should be on this list? It will 
help with my thesis and we might best address these perceptions in a new 
draft as some are addressed in draft-ietf-v6ops-nap-02.txt.

I would be interested in (co-)writing  such a draft.

Nick Hilliard wrote:
Subject: N reasons for not deploying ipv6

>> What might the other ones be, I still haven't seen a list.
>
> There are lots of reasons, including but not limited to:
>
> o  cost of deployment for network services providers
> o  lack of demand for content providers caused by lack of perceived 
> benefit
> o  continuing problems with supporting ipv6 in core networks (mostly due 
> to legacy equipment and lack of interest in upgrading)
> o  poor quality ipv6 global routing infrastructure
> o  not enabled by default on Microsoft operating systems
> o  poor AAA support on dialup / dsl aggregation / NAS devices
> o  lack of multihoming for end-users who need this
> o  almost non-existent support for CPE routers outside some mainstream 
> vendors
> o  continued problems with AAAA lookups from some braindead resolvers
>
> And of course, the primary reason: if the internet ain't broke, why do we 
> need to fix it?

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Lixia Zhang <[email-masked]>
Date: Mon, 17 Apr 2006 09:51:32 -0700

On Apr 17, 2006, at 9:41 AM, Eric Klein wrote:

> Does anyone else have additonal  items that should be on this list?  
> It will help with my thesis and we might best address these  
> perceptions in a new draft as some are addressed in draft-ietf- 
> v6ops-nap-02.txt.

in case you have not crossed this: back in Feb NANOG held a panel on

   "IPv6 Panel: Time for the Transition or Just More GOSIP?"
   http://nanog.org/mtg-0602/golding.html

the webpage contains a pointer to realmedia recording.

It seemed an interesting panel, arguments from both sides were  
presented.

FYI.

>> o  lack of demand for content providers caused by lack of  
>> perceived benefit
>> o  continuing problems with supporting ipv6 in core networks  
>> (mostly due to legacy equipment and lack of interest in upgrading)
>> o  almost non-existent support for CPE routers outside some  
>> mainstream vendors
>> And of course, the primary reason: if the internet ain't broke,  
>> why do we need to fix it?
>
>