Subject: RE: questions about draft-wen-ipv6-rsra-opt-multihoming-00

From: "CTO WEN Haibo" <[email-masked]>
Date: Mon, 12 Jun 2006 09:40:43 +0800

Hi Arifumi,

Thank you for your comments.

1. "routing header" issue
In the RFC4292, it says "The Internet Protocol Version 6 is specified in
[RFC-2460].  This specification MUST be supported." So IPv6 router MUST
support Extension Headers including routing header. Due to the 
simplified header and good orgnized structure of extension header, IPv6 
router can process IPv6 header with extension headers much faster than 
IPv4 router process IPv4 header with many options.

2. "how do the CPEs know ISP edge routers' IPv6 global-scope address"
In scenario2, the L3 CPE (or the router in the subscriber network) will
obtain a prefix from an ISP. The method of obtaining prefix will be done
by DHCPv6 Prefix Delegation (PD). ISP edge router's IPv6 global-scope 
address may be obtained by CPE along with the DHCP-PD procedure or other
method (after all, L3 CPE is connected to the ISP edge router).

3. "address selection at hosts"
The objective of this document is to propose a new option for RS/RA 
message. Multi-homing informaiton option is just to add some extra 
information to prefix information option in RA. These extra information 
will help host to do correct prefix selection, source address selection 
and exit router selection. For example, STB may only select the prefix
from the "IPTV" service provider to form its global IPv6 address. PC may
select multiple prefixes to form its address, at the same time it will
cache the information with the related prefix (/address), these 
information will help it select correct source address and so on.

Best regards,

Haibo

> -----Original Message-----
> From: Arifumi Matsumoto [mailto:[email-masked]]
> Sent: 2006年6月9日 19:12
> To: [email-masked]
> Subject: Re: questions about draft-wen-ipv6-rsra-opt-multihoming-00
> 
> 
> Hi Wen,
> 
> Maybe, we are working on similar problems.
> Let me comment on a few things about your proposal.
> 
> - I think Routing Header is an interesting method
>   to implement policy routing at gateway. The problem
>   is which router has to support Routing Header.
>   Is it correct that L3 CPE and also ISP's edge router
>   has to support Routing Header in scenario2 ?
>   When you see the deployment status of IPv4 source
>   routing, it is clear that ISP routers won't possibly
>   support Routing Header for security reason or other,
>   it may be possible to make CPE vendors to implement
>   Routing Header support though.
> 
> - Even if ISP edge routers implement Routing Header support,
>   how do the CPEs know ISP edge routers' IPv6 global-scope
>   address ?
>   If I remember correctly, in the Routing Header if you
>   put a link-local-address, the packet's final destination
>   must be a host on the same link.
>   So, end hosts have to know a global address of L3 CPE
>   and ISP edge routers.
>   As RA and DHCPv6 are delivered by link-local addresses,
>   there is no means to inform a global address of a ISP edge
>   router or a L3 CPE.
> 
> - At the last e-mail sent to IPv6 ML, you mentioned that
>   Host chooses an address given by an ISP that the host want
>   to connect. IMO, however, your proposal doesn't have any
>   effects on address selection at hosts, but have effects
>   on routing after address selection. After address selection
>   is completed, your mechcanism selects an appropriate next
>   or next-next hop depending on the selected source address.
> 
>   We are now working on the address selection aspects of
>   the similar environment considered here.
>   http://www.nttv6.net/dass/draft-arifumi-ipv6-policy-dist-00.txt
>   http://www.nttv6.net/dass/
> 
>   Now I'm revising this draft and also writing a problem statement
>   document of default address selection in multi-prefix environment.
> 
> Best regards.
> 
> 
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
> 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Arifumi Matsumoto <[email-masked]>
Date: Mon, 12 Jun 2006 17:18:17 +0900

Hi.

> IPv4 router process IPv4 header with many options.

Do you mean RFC4294 "IPv6 Node Requirements", right ?
As in section 4.1 of RFC4294, it is still disputable
that Routing Header support should be "MUST". I am
dubious about RH support in networks like ISP considering
Source Routing support status in IPv4.

> method (after all, L3 CPE is connected to the ISP edge router).

I just wanted to know if there is a standardized way for this or
there is a way for CPEs to get edge routers' addresses without
any additional irregular changes to edge routers.

> information will help it select correct source address and so on.

About this point, I was talkinFrom [email-masked] Mon Jun 12 04:19:26 2006
Date: Mon, 12 Jun 2006 17:18:17 +0900
From: Arifumi Matsumoto <[email-masked]>
To: [email-masked]
Subject: Re: questions about draft-wen-ipv6-rsra-opt-multihoming-00

Hi.

> IPv4 router process IPv4 header with many options.

Do you mean RFC4294 "IPv6 Node Requirements", right ?
As in section 4.1 of RFC4294, it is still disputable
that Routing Header support should be "MUST". I am
dubious about RH support in networks like ISP considering
Source Routing support status in IPv4.

> method (after all, L3 CPE is connected to the ISP edge router).

I just wanted to know if there is a standardized way for this or
there is a way for CPEs to get edge routers' addresses without
any additional irregular changes to edge routers.

> information will help it select correct source address and so on.

About this point, I was talking about the implementation aspect.
Making STBs to support this option seems fine, perhaps you don't
need standardization though.
For PCs, address selection rule is defined in RFC3484. If you
change the existing address selection rules, I wondered what
kind of the changes will be made.

Kindest regards,

Arifumi Matusmoto

>> ------------------------------------------------------------------------
>>