Subject: RE: Proposal to change aspects of Neighbor Discovery

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 8 Aug 2006 16:37:38 -0700

> Most wireless link protocols that provide robust dormant 
 > mode support have a 
 > separate dormant mode (aka paging) signaling channel that is 
 > extremely 
 > narrowband and requires very low receiver power to monitor. 
 > This channel is 
 > independent of the traffic channel over which IP traffic 
 > goes. Requiring the 
 > terminal to wake up periodically, bring up the traffic 
 > channel for an RA, 
 > then go to sleep again would result in considerably less 
 > power saving than 
 > if the separate dormant mode channel is used. 

=> Of course, but it all depends on how often you do this. If we do it
every 30 minutes, it's not much of a drain, if we do it every hour it's
negligible and so on. 

Hesham

This is why 
 > your laptop can't 
 > really do power efficient dormant mode on its 802.11 
 > interfaces (802.11 has 
 > no separate dormant mode signaling channel), while your cell 
 > phone regularly 
 > gets something like 30 hours of dormant mode before the 
 > battery runs out 
 > (cellular protocols do have such channels).
 > 
 >                 jak
 > 
 > ----- Original Message ----- 
 > From: "Pars Mutaf" <[email-masked]>
 > To: "Francis Dupont" <[email-masked]>
 > Cc: <[email-masked]>
 > Sent: Tuesday, August 08, 2006 5:18 AM
 > Subject: Re: Proposal to change aspects of Neighbor Discovery
 > 
 > 
 > > Hello,
 > >
 > > On Tue, 2006-08-08 at 12:37 +0200, Francis Dupont wrote:
 > >>  In your previous mail you wrote:
 > >>
 > >>    The I-D:
 > >>    draft-madanapalli-ipv6-periodic-rtr-advts-00.txt
 > >>    proposes several changes to ND procedures and parameters.
 > >>
 > >> => I strongly object not about the document itself but about its
 > >> principle because IMHO the link-layer should adapt, not 
 > the network 
 > >> layer.
 > >
 > >
 > > I agree with you of course. But I was thinking of this issue,
 > > i.e. "how the link layer could adapt?"... It's not that easy.
 > >
 > > Ideally, the dormant host's receiver circuit would be 
 > synchronized with
 > > the router's periodic RAs. The receiver circuit would be 
 > switched ON
 > > exactly when the RA arrives. But unfortunately, between 
 > the AR and the
 > > host, there is an access point. The RA messages may be queued and
 > > delayed at the access point (mixed up with other link 
 > layer frames).
 > > This queuing delay may foil our dormant mode 
 > synchronization, and the
 > > host may miss the RA messages :-(
 > >
 > > This means that, perfect dormant mode synchronization can 
 > be more easily
 > > achieved between the host and the access point (i.e. at 
 > the link layer).
 > > In this case, however, the router's RAs will awaken the 
 > dormant host.
 > > (unless the L2 access point recognizes the RA packets and 
 > forwards them
 > > at the right time, i.e. when the host's receiver is ON).
 > >
 > > Difficult issue.
 > >
 > > Regards!
 > > pars
 > >
 > >
 > >
 > >> Regards
 > >>
 > >> [email-masked]
 > >>
 > >> 
 > --------------------------------------------------------------------
 > >> IETF IPv6 working group mailing list
 > >> [email-masked]
 > >> Administrative Requests: 
 > https://www1.ietf.org/mailman/listinfo/ipv6
 > >> 
 > --------------------------------------------------------------------
 > >
 > >
 > > 
 > --------------------------------------------------------------------
 > > IETF IPv6 working group mailing list
 > > [email-masked]
 > > Administrative Requests: 
 > https://www1.ietf.org/mailman/listinfo/ipv6
 > > 
 > --------------------------------------------------------------------
 > > 
 > 
 > 
 > 
 > --------------------------------------------------------------------
 > IETF IPv6 working group mailing list
 > [email-masked]
 > Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
 > --------------------------------------------------------------------
 > 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Wed, 9 Aug 2006 09:56:37 -0700

jak>> Dunno. Most of the terminal engineers I've talked to don't want to 
bring up the traffic channel at all if the terminal is in dormant mode. 
They're comparing that kind of a design to what they currently have where 
dormant mode is entirely controlled by the circuit switched network. There's 
no need to bring up the circuit switched traffic channel, everything is 
handled through the narrowband paging channel. It's kind of like owning a 
Toyota Prius (60 mpg) and somebody telling you that the next generation is 
going to get the same gas milage as a Corolla (40 mpg). It's still better 
than a Chevy Tahoe (maybe 12 mpg) but it's not a particularly compelling 
tradeoff.

                       jak

---

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 9 Aug 2006 17:31:56 -0700

> than a Chevy Tahoe (maybe 12 mpg) but it's not a 

=> That's not a good analogy IMO because your tradeoff is focused on one
set of features. If they didn't see the benefits of moving from circuit
switched networks to IP, none of these systems would have mandated IP in
their next generation. The argument above seems to come from the point
of view of wanting everything for free. That's never the case. 

Hesham