Subject: Re: [Fwd: I-D Action:draft-eubanks-chimento-6man-00.txt]

From: Pekka Savola <[email-masked]>
Date: Thu, 4 Jun 2009 09:50:43 +0300 (EEST)

Hello,

On Tue, 24 Feb 2009, Brian Haberman wrote:
>     The below referenced draft was composed in response to a problem 
> encountered in the mboned working group.  There is a proposal there that 
> allows for the encapsulation of multicast traffic within a unicast tunnel in 
> order to traverse unicast-only networks.  This draft proposes to ease the 
> rule on checksums in IPv6 UDP packets.  I have asked that discussion of this 
> draft occur on the 6MAN mailing list.
>
>     In case anyone is interested in more of the background material, the 
> draft requiring this change is draft-ietf-mboned-auto-multicast-09.txt.

Since March, there has been no public discussion of this.  (I'll note 
that in April Gorry Fairhurst submitted an alternative, 
draft-fairhurst-6man-tsvwg-udptt-00, but AFAIK this has not been 
discussed anywhere).

I wonder if there been progress off-list, or if progress is expected?

> -------- Original Message --------
> Subject: I-D Action:draft-eubanks-chimento-6man-00.txt
> Date: Mon, 23 Feb 2009 10:45:01 -0800 (PST)
> From: [email-masked]
> Reply-To: [email-masked]
> To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
>
> 	 Title           : UDP Checksums for Tunneled Packets
> 	 Author(s)       : M. Eubanks
> 	 Filename        : draft-eubanks-chimento-6man-00.txt
> 	 Pages           : 7
> 	 Date            : 2009-02-23
>
> We address the problem of computing the UDP checksum on tunneling
> IPv6 packets when using lightweight tunneling protocols.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-eubanks-chimento-6man-00.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 04 Jun 2009 14:03:11 +0100

The "other" draft on this topic is at:
https://datatracker.ietf.org/idtracker/draft-fairhurst-6man-tsvwg-udptt/

I'd love to receive feedback on this initial draft (if you have sent 
previous comments please resend - because I saw none). It would be nice 
to get a new revision out before the next IETF meeting (or even converge 
on a combined draft). All comments welcome, - on or off list.

Best wishes,
Gorry

> Begin forwarded message:
> 
>> From: Pekka Savola <[email-masked]>
>> Date: June 4, 2009 8:50:43 GMT+02:00
>> To: Brian Haberman <[email-masked]>
>> Cc: "[email-masked]" 
>> <[email-masked]>,         IPv6 WG  Mailing List 
>> <[email-masked]>
>> Subject: Re: [Fwd: I-D Action:draft-eubanks-chimento-6man-00.txt]
>>
>> Hello,
>>

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 4 Jun 2009 11:22:29 -0400

> https://datatracker.ietf.org/idtracker/draft-fairhurst-6man-tsvwg-udptt/

It actually doesn't seem to be there now - but it is here

<http://www.ietf.org/internet-drafts/draft-fairhurst-6man-tsvwg-udptt-00.txt 

I too would welcome further comments on either this draft or our draft.

Marshall

> previous comments please resend - because I saw none). It would be  
> nice to get a new revision out before the next IETF meeting (or even  
> converge on a combined draft). All comments welcome, - on or off list.
>
> Best wishes,
> Gorry
>
>
>> Begin forwarded message:
>>> Cc: "[email-masked]" <mboned- 
>>> [email-masked]>,         IPv6 WG  Mailing List  
>>> <[email-masked]>

---

From: "C. M. Heard" <[email-masked]>
Date: Thu, 4 Jun 2009 18:24:00 -0700 (PDT)

On Thu, 4 Jun 2009, Marshall Eubanks wrote:
> I too would welcome further comments on either [ ... ] draft.

In both documents: I find the arguments against UDP-Lite with a 
checksum coverage of 8 to be unconvincing.

Mike Heard