Subject: RFC4 4861 and unicast router solicitations

From: Dmitry Anipko <[email-masked]>
Date: Mon, 22 Jun 2009 18:51:49 -0700

Hello,

I have a question on whether router solicitations with unicast destination addresses are valid under RFC 4861, and if they are, whether they shall be handled by routers equally to the solicitations with multicast destination address.

The RFC says:

>>6.3.7.  Sending Router Solicitations
>>A host sends Router Solicitations to the all-routers multicast   address.

and

>>4.1.  Router Solicitation Message Format
>>      Destination Address - Typically the all-routers multicast address.

These two statements seem only to define solicitations with multicast destination addresses (although it is not clear to me what "typically" in the latter may imply).

However at the same time the RFC doesn't seem to define router's reaction to solicitations sent to an address different from all-routers address:

>>6.2.2.  Becoming an Advertising Interface
>>Routers respond to Router Solicitations sent to the all-routers address

Also, according to the validity checks in 6.1.1., a solicitation with a unicast destination address shall be considered valid.

Are there other stronger statements in this or other RFCs or perhaps either of the two options was implied but was not explicitly worded?

Thanks,
Dmitry

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 23 Jun 2009 11:35:46 -0400

Dmitry,

An RS with a unicast destination is legal as per RFC 4861.  For example,
first time when a host was initialized, the host sent an RS with mcast
destination.  Then the host received an RA and the host acquired IPv6
address(es) and is up and running.  After a while the host detaches from
the link and reattaches, or the host network interface is disabled by
admin and enabled again.  In such cases, the host does know the unicast
destination of the default router.  So the next time the host is enabled
or reattached, the host can unicast the RS directly to the router.  

Hemant

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 23 Jun 2009 14:22:20 -0400

Hi Dmitry,

> These two statements seem only to define solicitations with multicast destination addresses (although it is not clear to me what "typically" in the latter may imply).

An unicast destination address is valid but not very useful. That is why 
the multicast address is "typically" used. I am curious though, and I 
would appreciate it if you can give a little bit of background on why 
you would like to send an RS with a unicast destination address. If you 
are doing it for checking reachability, an NS would be a better bet.

Cheers
Suresh

---

From: Dmitry Anipko <[email-masked]>
Date: Tue, 23 Jun 2009 14:35:46 -0700

Thanks Hesham, Hemant and Suresh for your responses.

It seems from them that the implied intent was that unicast-destined RSes should be allowed to be both sent and received and should be handled equally with multicast-destined ones. If that is the case, shall the RFC text be amended to reflect that more clearly?

While as it was pointed out in your responses, unicast RSes may be useful/reasonable for any type of link, I faced this in the case of ISATAP links.

ISATAP clients are provisioned with potential routers by out of band mechanism.  In general the clients could send multicast RSes to the provisioned routers, however ISATAP doesn't natively support multicast, and hence it seemed that it would also be reasonable for the clients to send unicast RSes to the provisioned routers directly. However it was not clear whether such behavior would be compliant with RFC 4861.

Please let me know if you think there are additional considerations for this behavior in case of the non-multicast capable links.

Thanks,
Dmitry

---

From: Aleksi Suhonen <[email-masked]>
Date: Mon, 29 Jun 2009 10:32:13 +0300

> or reattached, the host can unicast the RS directly to the router.  

How can the host know that it hasn't been reattached to a different 
network during this outage? (Well ... the unicast RS should reveal that 
of course, but a multicast RS would do the same job too.)

If the subnet has several routers present and the host only cares about 
one of them (for whatever reasons, security, configuration, ...) I think 
that might be a good reason to use unicast RS. Or if a mobile host tries 
to identify the network by its occupants.

-- 
	Aleksi Suhonen