Subject: RE: flow label usage?

From: Sheng Jiang <[email-masked]>
Date: Thu, 05 Aug 2010 17:37:04 +0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Brian E Carpenter
> Sent: Thursday, July 29, 2010 9:50 AM
> To: Bob Hinden
> Cc: [email-masked]
> Subject: Re: flow label usage?
> 
> On 2010-07-29 00:32, Bob Hinden wrote:
> > Lucy,
> > 
> > On Jul 28, 2010, at 1:58 PM, Yong Lucy wrote:
> > 
> >>  
> >> What is flow label usage?
> >>  
> >> IMO: it enforces that a set of packets with the same flow 
> label has to be carried through the networks in the same path 
> or belong to the same application at host. Is that correct? 
> Is there other usage of flow label?
> > 
> > RFC 3697 defines it as:
> > 
> >    A flow is a sequence of packets sent from a particular 
> source to a
> >    particular unicast, anycast, or multicast destination 
> that the source
> >    desires to label as a flow.  A flow could consist of all 
> packets in a
> >    specific transport connection or a media stream.  
> However, a flow is
> >    not necessarily 1:1 mapped to a transport connection.
> > 
> > It is intended to label a flow.  It does not specify a path.
> 
> And that was *not* an oversight by the authors or the WG. On 
> the contrary, RFC 3697 intentionally did not define any usage 
> model for the flow label, or even a purpose. It was limited 
> to defining the behaviour of source hosts.

en... I can understand "intentionally did not define any usage model" during RFC 3697 writing.
However, now, the question is what stop or block us to define any usage model. The fact is, after 6
years from RFC 3697, we don't have only usage defined. Why?

Sheng
 
>    Brian
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 06 Aug 2010 09:46:07 +1200

> years from RFC 3697, we don't have only usage defined. Why?

Excellent question! Actually that is why Qinwen Hu and I wrote
draft-hu-flow-label-cases, but it didn't give us the answer.

   Brian