Subject: [Fwd: I-D Action:draft-ietf-6man-flow-ecmp-01.txt]

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Feb 2011 09:42:43 +1300

Hi,

This version is intended to respond to the comments made during WG Last Call.

   Brian + Shane

-------- Original Message --------
Subject: I-D Action:draft-ietf-6man-flow-ecmp-01.txt
Date: Wed, 09 Feb 2011 12:30:01 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]
CC: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance Working Group of the IETF.

	Title           : Using the IPv6 flow label for equal cost multipath routing and link aggregation in tunnels
	Author(s)       : B. Carpenter, S. Amante
	Filename        : draft-ietf-6man-flow-ecmp-01.txt
	Pages           : 10
	Date            : 2011-02-09

The IPv6 flow label has certain restrictions on its use.  This
document describes how those restrictions apply when using the flow
label for load balancing by equal cost multipath routing, and for
link aggregation, particularly for IP-in-IPv6 tunneled traffic.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-6man-flow-ecmp-01.txt

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Feb 2011 13:21:19 +1300

On 2011-02-10 12:16, Lucy yong wrote:
> Hi Brian,
> 
>    There is some conflict between these goals: for example, strictly
>    avoiding idle time could cause a small packet sent on an idle path to
>    overtake a bigger packet from the same flow, causing out-of-order
>    delivery.
> 
> I don't understand this. Do you mean the small packet and a bigger packet takes different paths? 

Exactly, if the goal is to keep both paths busy, this could happen,

> If they take the same path, it should not cause out-of-order delivery.

Thus, the method must ensure that all packets from the same user flow
do take the same path.

   brian

> Thanks,
> Lucy
> 
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> Brian E Carpenter
>> Sent: Wednesday, February 09, 2011 2:43 PM
>> To: 6man
>> Subject: [Fwd: I-D Action:draft-ietf-6man-flow-ecmp-01.txt]
>>
>> Hi,
>>
>> --------------------------------------------------------------------
>> IETF IPv6 working group mailing list
>> [email-masked]
>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>> --------------------------------------------------------------------
>