Subject: RFC3484, Section 6, Rule 7 and ISATAP

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 16 May 2011 08:50:18 -0700

Recently, there was discussion regarding how to discern
an ISATAP IPv6 address from a native IPv6 address, and an
implication that this may have some bearing on RFC3484
address selection. The correct answer is that an IPv6
address is an ISATAP address IFF it is assigned to an
ISATAP interface, i.e., a node can tell that its IPv6
source address is ISATAP by examining the interface to
which the address is assigned. Therefore, there is a way
for a node to prefer native IPv4 over ISATAP even though
an IPv6 address cannot be identified as ISATAP solely by
examining the prefix.

This policy is manifested in RFC3484, Section 6, Rule 7:

   "Rule 7:  Prefer native transport.
   If DA is reached via an encapsulating transition mechanism (e.g.,
   IPv6 in IPv4) and DB is not, then prefer DB.  Similarly, if DB
   is reached via encapsulation and DA is not, then prefer DA.

      Discussion:  6-over-4 [15], ISATAP [16], and configured tunnels
      [17] are examples of encapsulating transition mechanisms for which
      the destination address does not have a specific prefix and hence
      can not be assigned a lower precedence in the policy table.  An
      implementation MAY generalize this rule by using a concept of
      interface preference, and giving virtual interfaces (like the
      IPv6-in-IPv4 encapsulating interfaces) a lower preference than
      native interfaces (like ethernet interfaces)."

Although the Discussion shows a "MAY", the rule itself
asserts that the native transport is to be preferred over
an encapsulating transport. Hence, there is no particular
reason for an ISATAP host to avoid placing AAAA records in
the DNS for any of its SLAAC-derived ISATAP addresses.

Fred
[email-masked]

---

From: Dmitry Anipko <[email-masked]>
Date: Mon, 16 May 2011 12:47:51 -0700

Hello Fred,

Rule 7 does help to distinguish native IPv6 versus ISATAP. 

However, rule 7 doesn't help to distinguish ISATAP from native IPv4: the rule 7 is only considered after rule 6, and per rule 6 ISATAP is already prioritized higher than IPv4 due to the default prefix policy table precedence values. As a result, rule 7 won't apply in that case, and ISATAP is preferred over IPv4.

I'm not weighing in on whether that is a problem or not, but trying to clarify what I believe the raised concern was.

Thank you,
Dmitry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Monday, May 16, 2011 8:50 AM
To: [email-masked]; [email-masked]
Subject: RFC3484, Section 6, Rule 7 and ISATAP

Fred
[email-masked]
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------