Subject: Re: Short 6MAN WG Last Call: <draft-ietf-6man-node-req-bis-09.txt>

From: RJ Atkinson <[email-masked]>
Date: Thu, 12 May 2011 10:55:44 -0400

On Friday 6th May 2011, Ole Troan wrote in part:
> basically I want the document to say that IETF has standardised
> two mechanisms to configure hosts. one using ND and one using DHCP.
> As they apply to different management models, nodes SHOULD implement both. 

On 12th May 2011, Thomas Narten responded in part:
> I personally would support having DHCP be a SHOULD rather than a
> MAY. The justification in my mind is that if you want the network
> operator to have the choice of whether they want to use  Stateless
> addrconf OR DHCP, they only have that choice of devices widely
> implement both.

I share the views above.  One wonders whether others also do.

In some environments, IPv6 actually is NOT deployable unless/until 
DHCP for IPv6 is widely supported in IPv6 nodes.  

I agree with others here that cable modem deployments (e.g. DOCSIS)
are one example where all node provisioning is handled via DHCP.  
A certain FTTH service that I myself use is a second example 
where DHCP is the node provisioning method.  Numerous corporate,
enterprise, educational, or government environments provide a 
3rd example where DHCP for IPv6 is a pre-requisite for IPv6 deployment.

Yours,

Ran

---

From: Bob Hinden <[email-masked]>
Date: Thu, 12 May 2011 13:39:52 -0700

Ran,

> 3rd example where DHCP for IPv6 is a pre-requisite for IPv6 deployment.

While my personal view is that DHCPv6 won't be used for host configuration in cable/DSL deployments (except for provisioning the prefix to the home router), it appears that DHCPv6 is being widely implemented in host OS's because it is needed some environments.  There are enough variations in deployment models that a host developer will need to support both.  

Based on this, I think a SHOULD is OK. 

I do note that I had a conversation with a content provider who worked closely with a mobile provider, and was surprised to learn that they planned to use SLAACC for their servers because it made their job easier.  So I don't think we know what all people deploying IPv6 are going to do in this area.  

Bob