Subject: Re: DNS configuration for Wireless networks using Router Advertisement

From: Bruno Silvestre <[email-masked]>
Date: Wed, 18 May 2011 19:17:17 +0100

Dear All !

We found the solution of the problem.

There was a problem in the clients side and not in the 'radvd' service.

In fact, 'Windows 7 and Vista' clients do not consider the RDNSS option
advertised by radvd.

In linux clients like Ubuntu 10.04, we installed a daemon to solve this.
In Ubuntu 11.04, there is no need to install any daemon.

For windows 7 and Vista, we had to install a program called 'rdnssd_win32',
which is an implementation of the RFC 6106 for Microsoft Windows. It parses
the RDNSS options present in Router Advertisement (RA), get the DNS
nameservers and write them in the registry.

Many thanks for your support,

Bruno.

2011/5/17 Bruno Silvestre <[email-masked]>

> Dear Mr. Jeong,
>
> I am currently developping an IPv6 project for University purposes for
> wireless networks and mobile devices.
>
> We configured radvd (router advertisement) to advertise a prefix in order
> to enable the AutoConfiguration of the hosts.
>
> This process works fine.
>
> However, we encounter problems to advertise DNS configuration.
>
> In fact, it seems that Android devices ( SDK 2.2 and 2.3 mobile phones) do
> not support DHCPv6, and so we should advertise the DNS configuration (DNS
> servers) by using Router Advertisement ??
>
> According the RFC6106, this should be possible...
>
> But it seems that 'radvd' ignores the RDNSS and DNSSL options...
>
> We are running 'radvd' under Ubuntu Server.
>
> Is there any way to advertise the DNS configuration via Router
> Advertisement with radvd ?
> Do you know about some 'radvd' version, which can run these configurations
> for Ubuntu Server ?
> We are currently running radvd 1.6.
>
> Thank you very much in advance,
>
> Bruno
>
> P.S: Here comes our radvd.conf file:
>
> #radvd.conf
> *interface eth1
> {
>     AdvSendAdvert on;
>     AdvManagedFlag off;
>     AdvOtherConfigFlag off;
>     prefix 2001:690:2060::/64
>   {
>        AdvOnLink on;
>        AdvAutonomous on;
>   };*
>
> *
> *
>
> *# Advertise DNS server ??*
>
> *RDNSS 2001:690:2060::2
> {
>         AdvRDNSSPreference 8;
>         AdvRDNSSOpen off;
>         AdvRDNSSLifetime 3600;
> };
> };*
>
>
>
>
>

---

From: Bruno Silvestre <[email-masked]>
Date: Tue, 17 May 2011 20:00:28 +0100

Good Afternoon,

We configured radvd (router advertisement) to advertise a prefix in order to
enable the AutoConfiguration of the hosts.

This process works fine.

Is there any way to advertise the DNS configuration via Router Advertisement
with radvd ?
Do you know about some 'radvd' version, which can run these configurations
for Ubuntu Server ?
We are currently running radvd 1.6.

Bruno

#radvd.conf
*interface eth1
{
    AdvSendAdvert on;
    AdvManagedFlag off;
    AdvOtherConfigFlag off;

*
*

*RDNSS 2001:690:2060::2
{
        AdvRDNSSPreference 8;
        AdvRDNSSOpen off;
        AdvRDNSSLifetime 3600;
};
};*

---

From: Jaehoon Jeong <[email-masked]>
Date: Wed, 18 May 2011 12:21:30 -0600

Bruno,
Thanks for this information.

Best Regards,
Paul

From: Bruno Silvestre [mailto:[email-masked]]
Sent: Wednesday, May 18, 2011 1:17 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Jaehoon Jeong; Carlos; Nuno Veiga; [email-masked]
Subject: Re: DNS configuration for Wireless networks using Router Advertisement

Dear All !

In fact, 'Windows 7 and Vista' clients do not consider the RDNSS option advertised by radvd.

For windows 7 and Vista, we had to install a program called 'rdnssd_win32', which is an implementation of the RFC 6106 for Microsoft Windows. It parses the RDNSS options present in Router Advertisement (RA), get the DNS nameservers and write them in the registry.

Bruno.
2011/5/17 Bruno Silvestre <[email-masked]<mailto:[email-masked]>>
Dear Mr. Jeong,

I am currently developping an IPv6 project for University purposes for wireless networks and mobile devices.

We configured radvd (router advertisement) to advertise a prefix in order to enable the AutoConfiguration of the hosts.

This process works fine.

In fact, it seems that Android devices ( SDK 2.2 and 2.3 mobile phones) do not support DHCPv6, and so we should advertise the DNS configuration (DNS servers) by using Router Advertisement ??

Is there any way to advertise the DNS configuration via Router Advertisement with radvd ?
Do you know about some 'radvd' version, which can run these configurations for Ubuntu Server ?
We are currently running radvd 1.6.

Bruno

#radvd.conf

interface eth1

{

    AdvSendAdvert on;

    AdvManagedFlag off;

    AdvOtherConfigFlag off;

  {

       AdvOnLink on;

       AdvAutonomous on;

  };

# Advertise DNS server ??

RDNSS 2001:690:2060::2

{

        AdvRDNSSPreference 8;

        AdvRDNSSOpen off;

        AdvRDNSSLifetime 3600;

};

};