Subject: Re: AD review of draft-ietf-6man-flow-3697bis

From: RJ Atkinson <[email-masked]>
Date: Tue, 21 Jun 2011 11:07:48 -0400

CLARIFICATION:

I agree with Brian and George that for the case where a router
is inserting a Flow Label value into a fragmented packet, 
it is desirable (and normally practical) to include the 
Fragment ID field as an input.  

So that would give 3 input values (Source IP, Dest IP, 
Fragment ID) for calculating a Flow ID value in fragmented 
packets.

Cheers,

Ran

---

From: Christian Huitema <[email-masked]>
Date: Tue, 21 Jun 2011 16:47:27 +0000

> I agree with Brian and George that for the case where a router is inserting a Flow Label value into a fragmented packet, it is > desirable (and normally practical) to include the Fragment ID field as an input.  
>
> So that would give 3 input values (Source IP, Dest IP, Fragment ID) for calculating a Flow ID value in fragmented packets.

Really? The fragment ID can change with each packet, correct? Imagine a UDP stream that for some reason uses large packets. Or maybe some large packets and some small packets. Isn't the proposal going to result in different packets of the same "application stream" getting different flow ids? Isn't that going to be somewhat problematic for load balancers?

-- Christian Huitema

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 21 Jun 2011 13:03:47 -0400

> Really? The fragment ID can change with each packet, correct? Imagine a UDP stream that for some reason uses large packets. Or maybe some large packets and some small packets. Isn't the proposal go…

I think the starting point probably should be the prior notes 
on this from Brian & George.  As my note made clear, I merely 
echoed their words.

<http://www.ietf.org/mail-archive/web/ipv6/current/msg14263.html>
	In which, Brian wrote in part:
	> As far as routers go, I think we have to say that an implementor 
	> has to choose between a reassembly-based solution using the 5-tuple 
	> and simply using the 2-tuple (maybe also the fragmentation ID 
	> - there is some scope for ingenuity here).

<http://www.ietf.org/mail-archive/web/ipv6/current/msg14270.html>
	In which, George wrote in part:
	> However, to Brian's comment about fragmentation ID, 
	> is there any reason why the draft can't recommend 
	> (or even require) this as a possible improvement over 
	> straight 2-tuple in the revert case?

Cheers,

Ran