Subject: I-D Action: draft-ietf-6man-rfc3484-revise-03.txt

From: [email-masked]
Date: Fri, 10 Jun 2011 03:16:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the IPv6 Maintenance Working Group of the IETF.

	Title           : Update to RFC 3484 Default Address Selection for IPv6
	Author(s)       : Arifumi Matsumoto
                          Jun-ya Kato
                          Tomohiro Fujisaki
	Filename        : draft-ietf-6man-rfc3484-revise-03.txt
	Pages           : 11
	Date            : 2011-06-10

   RFC 3484 describes algorithms for source address selection and for
   destination address selection.  The algorithms specify default
   behavior for all Internet Protocol version 6 (IPv6) implementations.
   This document specifies a set of updates that modify the algorithms
   and fix the known defects.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-6man-rfc3484-revise-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-6man-rfc3484-revise-03.txt

---

From: Rui Paulo <[email-masked]>
Date: Fri, 17 Jun 2011 08:12:45 -0700

Hi,

>   and fix the known defects.

I can't seem to find the discussion that led to this new draft. Could you please clarify why 3ffe::/16 was removed from the new policy table?

Thanks,
--
Rui Paulo

---

From: Brian Haberman <[email-masked]>
Date: Fri, 17 Jun 2011 11:25:07 -0400

On 6/17/11 11:12 AM, Rui Paulo wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories. This draft is a work item of the IPv6 Maintenance
>> Working Group of the IETF.
>> 
>> Title           : Update to RFC 3484 Default Address Selection for
>> IPv6 Author(s)       : Arifumi Matsumoto Jun-ya Kato Tomohiro
>> Fujisaki Filename        : draft-ietf-6man-rfc3484-revise-03.txt 
>> Pages           : 11 Date            : 2011-06-10
>> 
>> behavior for all Internet Protocol version 6 (IPv6)
>> implementations. This document specifies a set of updates that
>> modify the algorithms and fix the known defects.
> 
> 
> I can't seem to find the discussion that led to this new draft. Could
> you please clarify why 3ffe::/16 was removed from the new policy
> table?

The use of 3FFE has been deprecated.

Regards,
Brian

---

From: Tim Chown <[email-masked]>
Date: Fri, 17 Jun 2011 16:56:45 +0100

> The use of 3FFE has been deprecated.

Should we also remove site-locals then, or IPv4-compatibles?

Tim

---

From: Rui Paulo <[email-masked]>
Date: Sat, 18 Jun 2011 08:47:45 -0700

> The use of 3FFE has been deprecated.

Right, I understand that, but like Tim pointed out, site-locals were also deprecated and are still in the table. I suspect the 3ffe::/16 traffic is low enough these days not to warrant any entry in the table, but I wanted confirmation on that.

Regards,
--
Rui Paulo

---

From: Brian Haberman <[email-masked]>
Date: Sun, 19 Jun 2011 09:49:50 -0400

On 6/18/11 11:47 AM, Rui Paulo wrote:
>>>> A New Internet-Draft is available from the on-line
>>>> Internet-Drafts directories. This draft is a work item of the
>>>> IPv6 Maintenance Working Group of the IETF.
>>>>
>>>> Title           : Update to RFC 3484 Default Address Selection
>>>> for IPv6 Author(s)       : Arifumi Matsumoto Jun-ya Kato
>>>> Tomohiro Fujisaki Filename        :
>>>> draft-ietf-6man-rfc3484-revise-03.txt Pages           : 11 Date
>>>> : 2011-06-10
>>>>
>>>> RFC 3484 describes algorithms for source address selection and
>>>> for destination address selection.  The algorithms specify
>>>> default behavior for all Internet Protocol version 6 (IPv6)
>>> I can't seem to find the discussion that led to this new draft.
>>> Could you please clarify why 3ffe::/16 was removed from the new
>>> policy table?
>>
> Right, I understand that, but like Tim pointed out, site-locals were
> also deprecated and are still in the table. I suspect the 3ffe::/16
> traffic is low enough these days not to warrant any entry in the
> table, but I wanted confirmation on that.
>
> Regards, -- Rui Paulo

In my opinion, site-locals should be removed as well.

Regards,
Brian

---

From: Arifumi Matsumoto <[email-masked]>
Date: Mon, 20 Jun 2011 11:15:08 +0900

Hi,

thank you for your comment.
I cannot find it soon, but we had discussion about the
deprecated prefixes before.

There, it was pointed out that 3ffe::/16 was deprecated
and now it is just treated as normal global unicast address.
So, preserving 3ffe::/16 in the table will bring troubles
in future.

Regarding site-local prefix, it is still reserved by IETF.
So, it was not removed from the table.

Please correct me if I'm wrong.

Kindest regards,

On 2011/06/18, at 0:56, Tim Chown wrote:

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

--
Arifumi Matsumoto
 NGN System Architecture Project
 NTT Service Integration Laboratories
 E-mail: [email-masked]
 TEL +81-422-59-3334 FAX +81-422-59-6364