Subject: Doubt in Router Advertisement Message

From: Thiruma valavan <[email-masked]>
Date: Sat, 9 Jul 2011 10:53:21 +0530

Hi IETF Group,
While testing IPV6 Router Advertisement part, I noticed some behaviour that if I changed router interface MTU value, it won't send Router Advertisement message immediately instead of waiting to next interval time.

Is that normal behaviour, 
Thanks & Regards,

Thirumavalavan PCalsoflabs India Pvt Ltd,BangaloreATLEN Group of CompanyMob: +91 9790758035

---

From: "Vishwas Manral" <[email-masked]>
Date: Sat, 9 Jul 2011 15:05:47 -0700

Hi Thiruma,

>From the specs it is clear that the MTU is optional. However if MTU sending is enabled it should be sent on change too.

Sounds like a bug in the implementation to me.

Thanks,
Vishwas

Sent from my Palm Pre on AT&amp;T
On Jul 9, 2011 2:51 AM, Thiruma valavan &lt;[email-masked]&gt; wrote: 

Hi IETF Group,

Is that normal behaviour,&nbsp;
Thanks &amp; Regards,

---

From: Thiruma valavan <[email-masked]>
Date: Sun, 10 Jul 2011 14:47:52 +0530

Thanks vishwas.

Once again I will analyze those things(Router Advertisement - MTU option) and let you know. 

Thanks in Advance,

Thirumavalavan PCalsoftlabs India Pvt Ltd, Bangalore.
ALTEN Group of Company.Mob: +91 9790758035 

Date: Sat, 9 Jul 2011 15:05:47 -0700
From: [email-masked]
To: [email-masked]; [email-masked]
Subject: Re: Doubt in Router Advertisement Message

Hi Thiruma,

Thanks,
Vishwas

Sent from my Palm Pre on AT&T
On Jul 9, 2011 2:51 AM, Thiruma valavan <[email-masked]> wrote: 

Hi IETF Group,

---

From: Thiruma valavan <[email-masked]>
Date: Wed, 13 Jul 2011 18:13:22 +0530

Vishwas,
I am having one more doubt in IPv6 Fragmentation 

Router Interface MTU 1500, Host A wants to send a packet with 3,000 data bytes but MTU is 1500, so it needs to fragment the packet.
As per RFC 2460, First Packet 40 bytes (IPv6 Header) + 8 bytes Fragment Header + 1452 Data = 1500  

	            Second Packet 40 bytes (IPv6 Header) + 8 bytes Fragment Header + 1452 Data = 1500  
                   Third Packet     40 bytes (IPv6 Header) + 8 bytes Fragment Header +    96 Data =  1500 

Thanks,
Thiru 

Hi Thiruma,

Thanks,
Vishwas

Hi IETF Group,

---

From: Thiruma valavan <[email-masked]>
Date: Wed, 13 Jul 2011 18:16:47 +0530

This is the correct packet capture for IPv6 fragmentation

Thanks,
Thiru 

From: [email-masked]
To: [email-masked]
CC: [email-masked]
Subject: RE: Doubt in Router Advertisement Message
Date: Wed, 13 Jul 2011 18:13:22 +0530

Vishwas,

Thanks,
Thiru 

Hi Thiruma,

Thanks,
Vishwas

Hi IETF Group,

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 13 Jul 2011 17:56:12 -0700

Hi Thiruma,

The packet capture looks good. I did not get the question however.

If there is a question on technology you can mail me, however if the
question is on an implementation we can take it offline.

Thanks,
Vishwas
On Wed, Jul 13, 2011 at 5:43 AM, Thiruma valavan <[email-masked]>wrote:

> Router Interface MTU 1500, Host A wants to send a packet with 3,000 data
> bytes but MTU is 1500, so it needs to fragment the packet.
>
>  ------------------------------
> From the specs it is clear that the MTU is optional. However if MTU sending
> is enabled it should be sent on change too.
>
> ------------------------------
> While testing IPV6 Router Advertisement part, I noticed some behaviour that
> if I changed router interface MTU value, it won't send Router Advertisement
> message immediately instead of waiting to next interval time.
>
> Thirumavalavan P
> Calsoflabs India Pvt Ltd,Bangalore
> ATLEN Group of Company
> Mob: +91 9790758035
>

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 13 Jul 2011 17:58:31 -0700

Hi Anupam,

You are right the RFC allows the optional MTU update. However I would think
that if an MTU is sent earlier, it should be resent on MTU change/ update.

Thanks,
Vishwas
On Tue, Jul 12, 2011 at 1:53 AM, Anupam Kapoor <[email-masked]> wrote:

> "Vishwas Manral" <[email-masked]> writes:
>
> ,----
> | > From the specs it is clear that the MTU is optional. However if MTU
> | > sending is enabled it should be sent on change too.
> | >
> | > Sounds like a bug in the implementation to me.
> `----
> from thiruma's mail it seems that RA's are not sent *immediately* after
> changing mtu values. from rfc, as vishwas has pointed out, sending mtu
> is optional.
>
> following snippet from rfc-4861, sec: 6.2.4
>
>   The information contained in Router Advertisements may change through
>   actions of system management.  For instance, the lifetime of
>   advertised prefixes may change, new prefixes could be added, a router
>   could cease to be a router (i.e., switch from being a router to being
>   a host), etc.  In such cases, the router MAY transmit up to
>   MAX_INITIAL_RTR_ADVERTISEMENTS unsolicited advertisements, using the
>   same rules as when an interface becomes an advertising interface.
>
>
> from above, to me at least, it seems that, the behavior that you see
> doesn't point to a flawed implementation.
>
> kind regards
> anupam
>

---

From: Anupam Kapoor <[email-masked]>
Date: Thu, 14 Jul 2011 09:16:12 +0530

Vishwas Manral <[email-masked]> writes:

,----
| > You are right the RFC allows the optional MTU update. However I would
| > think that if an MTU is sent earlier, it should be resent on MTU
| > change/ update.
`----
thanks for confirming. fundamental question imho is *when* should the
update be sent, and *not* if...

kind regards
anupam