Subject: 2^64 is 10s of trillions (not just trillions)

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 26 Jul 2011 23:10:20 +0200

2^64 is 10s of trillions (not just trillions) and only for anglo-saxons.

2^64 is exabytes of memory (not giga, nor tera, nor peta).

I am not sure you look at adapting nd for these figures.

Alex

---

From: Joel Jaeggli <[email-masked]>
Date: Tue, 26 Jul 2011 18:05:26 -0400

If you're commenting on v6nd draft I don't think we have any intention of connecting ~1.8 * 10^19 hosts to a subnet...

On Jul 26, 2011, at 5:10 PM, Alexandru Petrescu wrote:

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 27 Jul 2011 00:09:20 +0200

> If you're commenting on v6nd draft I don't think we have any intention of connecting ~1.8 * 10^19 hosts to a subnet...

Yes, commenting on the v6nd draft.

Listening to the disxcussion it so sounde to me that these were ND 
optimizations such as to support 2^64 nodes in a subnet.

Alex

---

From: Joel Jaeggli <[email-masked]>
Date: Tue, 26 Jul 2011 18:20:18 -0400

On Jul 26, 2011, at 6:09 PM, Alexandru Petrescu wrote:

> Listening to the disxcussion it so sounde to me that these were ND optimizations such as to support 2^64 nodes in a subnet.

goal is:

	to retain entries for things that we know under duress
	
	to be able to learn new addresses when that router is resource constrained by prioritizing activities.

the implicit assumption is that memory is a limited commodity and there are higher priority things for the control plane processor to be doing instead of discovering hosts that don't exist due to incoming unicast packets...