Subject: comments on ipv6-over-mstp

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 27 Jul 2011 00:03:59 +0200

Comments on draft  draft-lynn-6man-6lobac-00:

- needs a section on multicast address mapping; it may not be 
straightforward: it may need to _not_ send all ip-multicasted messages 
to 255 link-layer address: the solicited-node multicast address includes 
the octet address (as opposed to eg ethernet 6octets) hence it could 
send it to that octet address (not 255).

- 1 Poll for Master - sounds as RS, why not mapping one into another?
   2 Reply to Poll for Master sounds as RA, same.

- MLD mapping could be as well useful.

Alex

---

From: Kerry Lynn <[email-masked]>
Date: Tue, 26 Jul 2011 18:30:44 -0400

On Tue, Jul 26, 2011 at 6:03 PM, Alexandru Petrescu <
[email-masked]> wrote:

> straightforward: it may need to _not_ send all ip-multicasted messages to
> 255 link-layer address: the solicited-node multicast address includes the
> octet address (as opposed to eg ethernet 6octets) hence it could send it to
> that octet address (not 255).
>
> The current version is -01; see section 9

It is a non-goal (perhaps this should be stated explicitly in the I-D)
to modify the current MS/TP state machines (other than the
extension for larger data frames already proposed in BACnet).

The only currently available option is 255 (all-nodes).  We *could*
look at MS/TP as a multicast challenged data link and support
functions like NS via RFC 4861 extensions as discussed in
IPv6 ND Optimization for Energy-aware
Devices<http://tools.ietf.org/agenda/81/slides/6man-8.pdf>

Plan B would be to look at using the 128-254 address range for
multicast mapping, but then we diverge from co-existence and
possibly need to modify state machines.

> These are MAC control frames that are part of token generation
(or recovery from a lost token).  Again, modification of the MS/TP
MAC is a non-goal.  See section 2 for MS/TP MAC requirements.

> Can you say more about this?

Thanks, -K-

> Alex
> ------------------------------**------------------------------**--------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/**listinfo/ipv6<https://www.ietf.org/mailman/listinfo/ipv6>
> ------------------------------**------------------------------**--------
>