Subject: Optimization of RFC 4861 for Energy-aware networks

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 19 Jul 2011 15:38:09 -0400

Hello all:

In 6lowpan workgroup, we developed  draft-ietf-6lowpan-nd which provides optimization of IPv6 ND for IEEE802.15.4 devices by avoiding all-node and solicited-node multicast messages for the most part and providing a method for device registration with a IPv6 Border router in a route-over topology  and as well as single-hop topology.

In the last IOT workshop at IETF, it has been brought up that the 6lowpan-nd like document may be useful in many other cases where devices are not IEEE 802.15.4 devices but the nodes are basically energy-aware and like to save energy as much as possible.  'Hello' or periodic advertisement/solicitation messages generally work well for line-powered devices, yet reducing the periodic messages may be useful for less power consumption for each connected device and therefore reducing overall energy consumption of the network. Needless to say that the reduced number of messages and avoidance of periodic all-node or solicited-node multicast messages are critical for some low-powered device operations. With EUI-64 IID, a DAD is not necessary if the deployment may choose to do so.

Here is an attempt to put together the first draft for generic optimization for energy-aware IPv6 networks:

http://tools.ietf.org/html/draft-chakrabarti-nordmark-energy-aware-nd-00

Comments are welcome. Would like the help from the community to shape this document up for generic energy optimization for IPv6 ND  in applicable cases. This document also discusses a way of prefix dissemination for address auto-configuration which may be useful in future home network in a single prefix scenario. With the proliferation of internet-of-things, it might be helpful to do address auto-configuration in some isolated situations.
More work is needed in this document - it is the initial effort to begin with.

Regards,
-Samita

---

From: Rute Sofia <[email-masked]>
Date: Thu, 21 Jul 2011 00:46:46 +0100

Hello Samita,

I will contribute, but do you have a specific deadline for us to send 
you comments?

BR,
Rute Sofia

On 07/19/2011 08:38 PM, Samita Chakrabarti wrote:
> Hello all:
> In 6lowpan workgroup, we developed  draft-ietf-6lowpan-nd which 
> provides optimization of IPv6 ND for IEEE802.15.4 devices by avoiding 
> all-node and solicited-node multicast messages for the most part and 
> providing a method for device registration with a IPv6 Border router 
> in a route-over topology  and as well as single-hop topology.
> In the last IOT workshop at IETF, it has been brought up that the 
> 6lowpan-nd like document may be useful in many other cases where 
> devices are not IEEE 802.15.4 devices but the nodes are basically 
> energy-aware and like to save energy as much as possible.  'Hello' or 
> periodic advertisement/solicitation messages generally work well for 
> line-powered devices, yet reducing the periodic messages may be useful 
> for less power consumption for each connected device and therefore 
> reducing overall energy consumption of the network. Needless to say 
> that the reduced number of messages and avoidance of periodic all-node 
> or solicited-node multicast messages are critical for some low-powered 
> device operations. With EUI-64 IID, a DAD is not necessary if the 
> deployment may choose to do so.
> Here is an attempt to put together the first draft for generic 
> optimization for energy-aware IPv6 networks:
> Comments are welcome. Would like the help from the community to shape 
> this document up for generic energy optimization for IPv6 ND  in 
> applicable cases. This document also discusses a way of prefix 
> dissemination for address auto-configuration which may be useful in 
> future home network in a single prefix scenario. With the 
> proliferation of internet-of-things, it might be helpful to do address 
> auto-configuration in some isolated situations.
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

-- 
Rute Sofia, PhD ([email-masked])
Scientific Director for Technology
Research Unit in Informatics Systems and Technologies (SITI)
Coordinator of the Internet Architecture and Networking Lab (IAN Lab)
University Lusofona, Portugal
[email-masked]

http://siti.ulusofona.pt
Tel.: 217 515 500 Fax: 21 757 7006
.......................................................

---

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 20 Jul 2011 20:17:58 -0400

Hi Rute,

I will contribute, but do you have a specific deadline for us to send you comments?

BR,
Rute Sofia
[[SC ] ]  Thanks.    If you provide comments in next few weeks, that will be good, I believe.

-Samita

Regards,
-Samita

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--
Rute Sofia, PhD ([email-masked]<mailto:[email-masked]>)
Scientific Director for Technology
Research Unit in Informatics Systems and Technologies (SITI)
Coordinator of the Internet Architecture and Networking Lab (IAN Lab)
University Lusofona, Portugal
[email-masked]<mailto:[email-masked]>

http://siti.ulusofona.pt