Subject: Is it legal to set IID to 0?

From: Washam Fan <[email-masked]>
Date: Fri, 15 Jul 2011 11:01:30 +0800

Hi,

I don't know if it is legal when I manually set a unicast address with
IID=0. Linux allows that and RFC4291 doesn't explicitly prohibit that.
I assume it is legal, Right?

THanks in advance.
washam

---

From: Mark Smith <[email-masked]>
Date: Fri, 15 Jul 2011 12:49:00 +0930

Hi,

On Fri, 15 Jul 2011 11:01:30 +0800

> I assume it is legal, Right?

That's the subnet router anycast address, so you probably shouldn't use
it without the anycast flag being set when you assign it. Using it as a
conventional unicast address might make it interact
unexpectedly/badly with things like duplicate address detection. 

See RFC5453, "Reserved IPv6 Interface Identifiers".

Regards,
mark.

---

From: Washam Fan <[email-masked]>
Date: Fri, 15 Jul 2011 13:38:27 +0800

Thanks Mark,
I was not aware of that before.
Thanks again,
washam