Subject: RFC 3306 question

From: Kerry Lynn <[email-masked]>
Date: Tue, 9 Aug 2011 17:51:03 -0400

RFC 3306 states:

"The scope of the unicast-prefix based multicast address MUST NOT
exceed the scope of the unicast prefix embedded in the multicast
address."

I'd just like to verify my interpretation that site-local multicast addresses

MAY be formed from ULA prefixes?  If so, should a particular value

(e.g. 0x0000) be used as the subnet ID portion of the prefix?

Thanks, -K-

---

From: Sander Steffann <[email-masked]>
Date: Wed, 10 Aug 2011 10:13:09 +0200

Hi,

> MAY be formed from ULA prefixes?

ULA has global scope, so that should be ok.

Met vriendelijke groet,
Sander Steffann

---

From: Brian Haberman <[email-masked]>
Date: Wed, 10 Aug 2011 09:54:11 -0400

> MAY be formed from ULA prefixes?  If so, should a particular value

Yes, there is no issue with using a ULA prefix to form a unicast-prefix
based multicast address with site-local scope.

> (e.g. 0x0000) be used as the subnet ID portion of the prefix?

What you use in the subnet portion of the ULA is really up to your use case.

Regards,
Brian

---

From: Tim Chown <[email-masked]>
Date: Tue, 16 Aug 2011 12:11:55 +0100

> based multicast address with site-local scope.

Or presumably across whatever scope over which the ULA applies.  In our university we use site scope multicast (5) for departments and organisation scope multicast (8) for services constrained to the university.   If we used ULAs, then there would be a single /48 ULA for the university.

Technically RFC3306 would permit a global scope (e) multicast address using a ULA prefix, at least by the text cited above from the end of section 4.  That is a nit caused by the change in scope between deprecated site-locals and newer ULAs.

In practice we use Embedded-RP for all our IPv6 multicast. The embedded RP address could presumably be ULA so long as the multicast was only carried within the organisation border where the ULA routing existed.   It's not something we've tried to do, but it would theoreticially give some improved independence from network renumbering events.

This topic may become more relevant if ULAs are discussed more widely for routed networks in homenet, and 'home scope' service discovery (for example) used multicast.

Tim