Subject: Moving to WGLC 3484-bis?

From: Tim Chown <[email-masked]>
Date: Fri, 12 Aug 2011 15:21:30 +0100

Hi guys,

I think we're almost ready to WGLC the 3484-bis draft, as per draft-ietf-6man-rfc3484-revise-04.

We had 3 issues in Quebec:

1) Inclusion of deprecated prefixes.  It seemed the agreement in the room was to include compatibles, site-locals and 6bone prefixes in the policy table.  If that's what we do, then we need to add 3ffe::/16 back in.

2) Privacy bit indicator.  We had removed the privacy bit indicator after the heavy negative feedback in Prague to a privacy bit option for RAs, but Eric Vyncke suggested it should be added back so that an enterprise administrator could use the DHCPv6 policy distribution method to have hosts in their domain not use privacy addresses for talking to other hosts in their domain (same prefix, or ULAs).  At the moment, there is no privacy bit support.

3) Prefer greatest lifetime.  We agreed to make no change here.

If we agree to add back 3ffe::/16, we could quickly produce a revise-05 and WGLC based on that, and ask in the WGLC whether there's strong support for the privacy option.  If there is, then the option bit itself would be defined in the DHCPv6 policy distribution text, and 3484-bis would need to describe the use of the bit in the updated policy table. 

Sound reasonable, or would a different approach be better?

Tim

---

From: Brian Haberman <[email-masked]>
Date: Fri, 12 Aug 2011 16:15:57 -0400

Hi Tim,

On 8/12/11 10:21 AM, Tim Chown wrote:
> 1) Inclusion of deprecated prefixes.  It seemed the agreement in the
> room was to include compatibles, site-locals and 6bone prefixes in
> the policy table.  If that's what we do, then we need to add
> 3ffe::/16 back in.
> 
> 2) Privacy bit indicator.  We had removed the privacy bit indicator
> after the heavy negative feedback in Prague to a privacy bit option
> for RAs, but Eric Vyncke suggested it should be added back so that an
> enterprise administrator could use the DHCPv6 policy distribution
> method to have hosts in their domain not use privacy addresses for
> talking to other hosts in their domain (same prefix, or ULAs).  At
> the moment, there is no privacy bit support.
> 
> If we agree to add back 3ffe::/16, we could quickly produce a
> revise-05 and WGLC based on that, and ask in the WGLC whether there's
> strong support for the privacy option.  If there is, then the option
> bit itself would be defined in the DHCPv6 policy distribution text,
> and 3484-bis would need to describe the use of the bit in the updated
> policy table.

I agree with your assessment and this approach as a reasonable way
forward.  Go ahead and generate -05 with 3ffe::/16 back in the table.
When that draft is out, I will start a WG Last Call and specifically
request feedback on the privacy bit issue.

Regards,
Brian

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 16 Aug 2011 14:13:00 +0200

BTW, ok for me of course to go WGLC even without the privacy bit indicator

-éric

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Tim
> Chown
> Sent: vendredi 12 août 2011 16:22
> To: Arifumi Matsumoto; 6man Mailing List; Brian Haberman
> Subject: Moving to WGLC 3484-bis?
> 
> Hi guys,
> 
> 1) Inclusion of deprecated prefixes.  It seemed the agreement in the room was
> to include compatibles, site-locals and 6bone prefixes in the policy table.
> If that's what we do, then we need to add 3ffe::/16 back in.
> 
> 2) Privacy bit indicator.  We had removed the privacy bit indicator after the
> heavy negative feedback in Prague to a privacy bit option for RAs, but Eric
> Vyncke suggested it should be added back so that an enterprise administrator
> could use the DHCPv6 policy distribution method to have hosts in their domain
> not use privacy addresses for talking to other hosts in their domain (same
> prefix, or ULAs).  At the moment, there is no privacy bit support.
> 
> If we agree to add back 3ffe::/16, we could quickly produce a revise-05 and
> WGLC based on that, and ask in the WGLC whether there's strong support for
> the privacy option.  If there is, then the option bit itself would be defined
> in the DHCPv6 policy distribution text, and 3484-bis would need to describe
> the use of the bit in the updated policy table.
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------