Subject: Question about Subnet-Router anycast address

From: François-Xavier Le Bail <[email-masked]>
Date: Mon, 26 Sep 2011 06:20:17 -0700 (PDT)

Hi All,

I try to ping some routers on one of their Subnet-Router anycast addresses (SRAA).
(http://tools.ietf.org/html/rfc4291#section-2.6.1)

Some (Cisco) reply with an unicast source address (same subnet prefix).
Another one (Alcatel) reply with the SRAA as source address.
A Linux kernel in IPv6 forwarding mode behave like the Cisco router.

The RFC 4291 removed the restrictions on using IPv6 anycast addresses, so a SRAA may be used as a source address.

Is there an RFC which describe the reply source address that must be used ?

Thanks,
Francois-Xavier Le Bail

---

From: Ole Troan <[email-masked]>
Date: Wed, 28 Sep 2011 19:58:13 +0200

Francois,

> Is there an RFC which describe the reply source address that must be used ?

not as far as I know. the closest we have is probably http://tools.ietf.org/html/draft-itojun-ipv6-anycast-analysis-02

6rd is one of the few applications using the Subnet router anycast. we thought it useful for troubleshooting and then particularly as a way to identify BR if the reply was the BR's unicast address instead of the anycast. your mileage may vary.

cheers,
Ole