Subject: Re: Last Call: <draft-gundavelli-v6ops-pmipv6-address-reservations-00.txt> (Reserved IPv6 Interface Identifier for Proxy Mobile IPv6) to Informational RFC

From: Jari Arkko <[email-masked]>
Date: Tue, 18 Oct 2011 21:29:38 +0300

The last call ended yesterday. We are fine with going ahead as proposed standard, but there were two other issues raised during discussion.

1. Possible draft to update RFC 5453 / 5342 to say that allocations in either one should not conflict with each other. I tend to agree with Thomas that we are unlikely to see much use of these registries and we should not worry too much about it. That being said, if Suresh finds enough time to write a draft on this I wouldn't mind shepherding it forward. In any case, it is a separate matter from Sri's draft.

2. Whether to allocate an EUI-64 from the IANA block and base the IID on that, or to allocate just a reserved value per RFC 5453. Collisions are extremely unlikely in either case. Personally, I'd prefer an EUI-64 based approach though, because collisions based on random addresses are then ruled out completely, and only manual or multiple MAG type collisions may occur. That is a personal preference though. But we need to choose. Are we going with the draft as is, or changing it to use EUI-64 allocation? I saw Suresh support this approach, Sri had questions (were those answered and what was your conclusion?), what about the rest of you?

In any case, I'm sending the draft to the IESG review.

Jari

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 18 Oct 2011 14:45:37 -0400

> 2. Whether to allocate an EUI-64 from the IANA block and base the IID on that, or to allocate just a reserved value per RFC 5453. Collisions are extremely unlikely in either case. Personally, I'd p…

I would prefer that we use an EUI-64-based approach, but my opinion is not strong enough to block the document for that reason, if others feel strongly that we should use a reserved value from some other space.

Margaret

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 18 Oct 2011 23:49:18 -0400

Hi Jari,

> 1. Possible draft to update RFC 5453 / 5342 to say that allocations in either one should not conflict with each other. I tend to agree with Thomas that we are unlikely to see much use of these regi…

I think this would be relatively simple to fix. We just need to add a
new range entry into the IID registry to mark all of IIDs based on the
IANA block as reserved and point to RFC5342. I can do this pretty
quickly once the draft submission reopens.

> 2. Whether to allocate an EUI-64 from the IANA block and base the IID on that, or to allocate just a reserved value per RFC 5453. Collisions are extremely unlikely in either case. Personally, I'd p…

I am personally fine with either approach.

Thanks
Suresh

---

From: Jari Arkko <[email-masked]>
Date: Sat, 29 Oct 2011 20:48:04 +0300

We did not get an exactly overwhelming number of responses, but it seems that those that cared (me and Margaret) seemed to prefer an EUI-64 approach. Sri, can you make that happen? Feel free to ask me or Suresh to help, if needed. Make a clear enough explanation in the document so that we can get IANA to understand also what they need to do in detail. I'm currently holding a Discuss on their behalf, because the current instructions were unclear. Can you make this happen by drafts deadline?

Jari

On 18.10.2011 21:29, Jari Arkko wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>