Subject: Re: Question about Subnet-Router anycast address

From: François-Xavier Le Bail <[email-masked]>
Date: Mon, 3 Oct 2011 01:52:36 -0700 (PDT)

Ole,

> > I try to ping some routers on one of their
> Subnet-Router anycast addresses (SRAA).
> > (http://tools.ietf.org/html/rfc4291#section-2.6.1)
> > 
> > Some (Cisco) reply with an unicast source address
> (same subnet prefix).
> > Another one (Alcatel) reply with the SRAA as source
> address.
> > A Linux kernel in IPv6 forwarding mode behave like the
> Cisco router.
> > 
> > The RFC 4291 removed the restrictions on using IPv6
> anycast addresses, so a SRAA may be used as a source
> address.
> > 
> > Is there an RFC which describe the reply source
> address that must be used ?
> 
> not as far as I know. the closest we have is probably http://tools.ietf.org/html/draft-itojun-ipv6-anycast-analysis-02

Thanks for the link.
This draft refers RFC 2373 that prohibited the use of anycast as source address. It's no more the case in RFC 4291.

> 6rd is one of the few applications using the Subnet router
> anycast. we thought it useful for troubleshooting and then
> particularly as a way to identify BR if the reply was the
> BR's unicast address instead of the anycast. your mileage
> may vary.

If the source address of reply differs from destination address of the request, some applications are broken.

Thanks,
François-Xavier

---

From: Thomas Narten <[email-masked]>
Date: Mon, 03 Oct 2011 09:18:46 -0400

=?iso-8859-1?Q?Fran=E7ois-Xavier_Le_Bail?= <[email-masked]> writes:

> If the source address of reply differs from destination address of
> the request, some applications are broken.

If you are saying that applications should ignore the src address (in
case it is anycast) when accpting replies, I very strongly disagree.

The norm is (and has been forever) to require that the source address
in a response (whether TCP or UDP) match the destination address in
the original query. And for good reason.

Thomas