Subject: multiple policy tables handling in draft-ietf-6man-addr-select-opt-01

From: Dmitry Anipko <[email-masked]>
Date: Mon, 14 Nov 2011 05:21:11 +0000

Hello,

I have a question about this text the -01 revision:

>>A node MAY use OPTION_DASP in any of the following two cases:
                 1: The address selection option is delivered across a secure, trusted
                    channel.

The OPTION_DASP is configured by a network administrator, presumably based on some knowledge they have about what makes more or less sense in the particular network. How whether or not a secure channel has been used on one of the networks relates to whether or not the admin of that network has knowledge of a completely different network the host may simultaneously be connected to?

Thanks,
Dmitry

---

From: Arifumi Matsumoto <[email-masked]>
Date: Fri, 18 Nov 2011 14:13:52 +0900

Hi,

thank you for your comment.

> The OPTION_DASP is configured by a network administrator, presumably based on some knowledge they have about what makes more or less sense in the particular network. How whether or not a secure cha…

In any case, the policy delivered on the secured channel should be used.

That is what the draft suggests.

Make sense ?

---

From: Dmitry Anipko <[email-masked]>
Date: Fri, 18 Nov 2011 05:27:12 +0000

Hello,

>>That is what the draft suggests.

If the different policy tables were received from different administrative domains, I don't see yet why it would make sense to prefer one of them to another based on whether one of the channel was secured. In case an interface which delivered secured policy table is not preferred by routing metric, the copy of the table received over such interface may be irrelevant or harmful.

Thanks,
Dmitry

From: Arifumi Matsumoto [mailto:[email-masked]]
Sent: Thursday, November 17, 2011 9:14 PM
To: Dmitry Anipko
Cc: [email-masked]
Subject: Re: multiple policy tables handling in draft-ietf-6man-addr-select-opt-01

Hi,

Hello,

Make sense ?

---

From: Arifumi Matsumoto <[email-masked]>
Date: Sun, 20 Nov 2011 03:31:27 +0900

Hi,

On 2011/11/18, at 14:27, Dmitry Anipko wrote:

> If the different policy tables were received from different administrative domains, I don’t see yet why it would make sense to prefer one of them to another based on whether one of the channel was secured. In case an interface which delivered secured policy table is not preferred by routing metric, the copy of the table received over such interface may be irrelevant or harmful.

The policy table is a host-wide policy, and not interface specific.
It can have effects even on the routing policy of the host in that it has
effects on destination address selection.

The existence of a secure, trusted channel means that the host
belongs to the administrative domain. In that case, the policy of 
the un-trusted channel should not override the host-wide policy,
even if the default route is directed to the untrusted interface.

If the admin of the administrative domain allows the simultaneous
use of the untrusted domain and to direct the default route to that
untrusted interface, the admin has to design his distributing policy
so that the policy will not bring bad effects from that. If the admin
does not allow the simultaneous connection, the bad effects need
not be taken care.

Of course, this draft does not preclude configuration option to use
the received policy on the untrusted interface, though.

Best regards,