Subject: Re: Character set for Line ID

From: RJ Atkinson <[email-masked]>
Date: Tue, 6 Dec 2011 14:42:58 -0500

Earlier, Suresh wrote:
> In the deployments that I know of, the line-id is
> not configured on the router at all. The router
> just passes through the line-id it received
> from the Access Node onto the AAA server.

Some are configured in the router.  Some are not.
In some cases, the router might even be the 
same system as the Access Node.  Regardless,
the quote above misses the original point
about operations.

The LineID value is configured by humans 
(e.g. directly via a CLI or indirectly via a 
provisioning system that was itself configured 
by humans or via some other schema that also
originates with humans) into (various) operational 
systems (e.g. routers, access nodes, AAA server, 
DHCP servers, other boxes) and does not contain
opaque bytes.  It contains printable characters
only.

In the different systems I'm aware of, which are
genetically different from each other, none permit
non-printable characters.  All appear to be limited
to US-ASCII, ISO-646, or ISO-8859.

The word "opaque" in the DHCP Line-ID option
merely meant that one ought not try to be too
smart in packet processing.  The goal of the 
words in that DHCP RFC are ONLY to ensure that 
"Foo" matches "Foo" and does not match (for example) 
"FOO" or "fOO" or "F00".

Yours,

Ran

---

From: RJ Atkinson <[email-masked]>
Date: Thu, 8 Dec 2011 07:26:13 -0500

Glen Turner and I expect to post some draft 
candidate text about the character set issue 
to the IPv6 WG list in the next several days.

Ran