Subject: Re: Working Group last call for adding RFC6437 Flow Label support to Node Requirements bis document

From: Bob Hinden <[email-masked]>
Date: Thu, 1 Dec 2011 06:41:27 -0800

This last call was completed on 17 November 2011.  There was no objection raised during the last call.  The topic was also discussed at the Taipei 6man session.  The minutes show:

 Node Requirements update based on new Flow Label RFC, Chairs, 10 min.
 =====================================================================

 Should this document be updated to reflect the recently published Flow
 Label RFCs?  So a new WG last call has been issued to confirm comfort
 with the changes.  Jari Arkko said not to delay publishing if we cannot
 easily resolve this issue.  Several people spoke in support of getting
 this text into the document now.  Brian Haberman (remote, co-chair)
 strongly urged support for making this change.  Bob Hinden polled the
 room, and there was strong support for the change, and no one indicated
 opposition.

Consequently, the authors should proceed with the change to the document.

Bob Hinden / Brian Haberman
6man Chairs

On Nov 10, 2011, at 9:00 AM, Bob Hinden wrote:

> This email starts a one week 6MAN Working Group last call for adding text and a reference to RFC6437 "IPv6 Flow Label Specification" to the Node Requirements bis document current in AUTH48 state.  The document is currently on hold in the RFC Editor waiting for resolution of this issue.  
> 
> The proposed text, first sent to the [email-masked] mailing list on November 2, 2011 (included below), is:
> 
>> All nodes SHOULD support RFC 6437, IPv6 Flow Label Specification, 
>> defines the IPv6 Flow Label.  Specifically:
>> 
>>   "Forwarding nodes such as routers and load distributors MUST NOT
>>    depend only on Flow Label values being uniformly distributed. "
>> 
>>   "It is therefore RECOMMENDED  that source hosts support the flow 
>>    label by setting the flow label field for all packets of a given flow to the 
>>    same value chosen from an approximation to a discrete uniform distribution. "
> 
> The chairs have discussed this with the Internet Area Directors and they recommended this course of action.  This topic is also on the agenda for the 6man session at the Taipei IETF.
> 
> Substantive comments and statements of support for taking this action should be sent to the mailing list.  This last call will end on November 17, 2011.
> 
> Regards,
> Bob Hinden & Brian Haberman
> 
> 
> Begin forwarded message:
> 
>> From: <[email-masked]>
>> Date: November 2, 2011 7:50:35 PM PDT
>> To: <[email-masked]>
>> Subject: Flow Label support in the Node Requirements bis document
>> 
>> Hi all,
>> 
>> There has been some discussions whether or not we should add support for the Flow Label in
>> Soon to be RFC 6434 <draft-ietf-6man-node-req-bis-11.txt> As a straw man proposal, if we add
>> Support, I would suggest the following text:
>> 
>> All nodes SHOULD support RFC 6437, IPv6 Flow Label Specification, 
>> defines the IPv6 Flow Label.  Specifically:
>> 
>>   "Forwarding nodes such as routers and load distributors MUST NOT
>>     depend only on Flow Label values being uniformly distributed. "
>> 
>>   "It is therefore RECOMMENDED  that source hosts support the flow 
>>     label by setting the flow label field for all packets of a given flow to the 
>>     same value chosen from  an approximation to a discrete uniform distribution. "
>> 
>> I'd like to ask the wg the following:
>> 
>> 1) Is the above text acceptable?
>> 2) Do you support adding the text? If no, please suggest text, unless you do not support adding
>>    Flow label support at all (please say so).
>> 
>> John
>> --------------------------------------------------------------------
>> IETF IPv6 working group mailing list
>> [email-masked]
>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>> --------------------------------------------------------------------
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 01 Dec 2011 17:46:08 +0200

Good. Please make sure the RFC Editor gets the final AUTH48 change in e-mail so that I can say "approve"...

Jari