Subject: [Fwd: I-D Action: draft-carpenter-6man-uri-zoneid-00.txt]

From: Brian E Carpenter <[email-masked]>
Date: Thu, 08 Dec 2011 08:20:58 +1300

Comments welcome...

-------- Original Message --------
Subject: I-D Action: draft-carpenter-6man-uri-zoneid-00.txt
Date: Tue, 06 Dec 2011 17:27:00 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Representing IPv6 Zone Identifiers in Uniform Resource Identifiers
	Author(s)       : Brian Carpenter
                          Robert M. Hinden
	Filename        : draft-carpenter-6man-uri-zoneid-00.txt
	Pages           : 6
	Date            : 2011-12-06

   This document describes how the Zone Identifier of an IPv6 scoped
   address can be represented in a Uniform Resource Identifier that
   includes a literal IPv6 address.  It updates RFC 3986 and RFC 4007.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-carpenter-6man-uri-zoneid-00.txt

---

From: Brian Haberman <[email-masked]>
Date: Thu, 08 Dec 2011 09:46:29 -0500

Brian & Bob,

>    includes a literal IPv6 address.  It updates RFC 3986 and RFC 4007.

If option 2 is preferred as this work moves forward, does there need to
be text on how to handle the addition of a ZoneID to an address that
does not need one (i.e., non-link-local)?

It would probably be useful for the draft to reference RFC 4007 as
guidance on how the ZoneID affects interface/address selection.

Regards,
Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 Dec 2011 11:15:40 +1300

> Brian & Bob,

...
> does not need one (i.e., non-link-local)?

Either that, or at least a statement that it's currently undefined.

I imagine that MIF might have an interest in this question.

> guidance on how the ZoneID affects interface/address selection.

Yes, good idea.

Thanks

    Brian C

> 
> Regards,
> Brian
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>