Subject: Reviews requested: draft-carpenter-6man-uri-zoneid-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 04 Jan 2012 15:23:20 +1300

Representing IPv6 Zone Identifiers in Uniform Resource Identifiers

We'd like feedback on this. In particular, which of the two options
proposed do people prefer?

   OPTION 1:

   The existing syntax of IPv6address is extended by adding a specific
   option for the case of link-local addresses.

   OPTION 2:

   The existing syntax of IPv6address is retained, and a zone identifier
   may be added optionally to any literal address.  This allows
   flexibility for unknown future uses.

 - Brian & Bob

-------- Original Message --------
Subject: I-D Action: draft-carpenter-6man-uri-zoneid-00.txt
Date: Tue, 06 Dec 2011 17:27:00 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Representing IPv6 Zone Identifiers in Uniform Resource Identifiers
	Author(s)       : Brian Carpenter
                          Robert M. Hinden
	Filename        : draft-carpenter-6man-uri-zoneid-00.txt
	Pages           : 6
	Date            : 2011-12-06

   This document describes how the Zone Identifier of an IPv6 scoped
   address can be represented in a Uniform Resource Identifier that
   includes a literal IPv6 address.  It updates RFC 3986 and RFC 4007.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-carpenter-6man-uri-zoneid-00.txt

---

From: Karl Auer <[email-masked]>
Date: Wed, 04 Jan 2012 14:33:54 +1100

For what my opinion is worth, the second option seems better to me:

>    OPTION 2:
> 
>    The existing syntax of IPv6address is retained, and a zone
>    identifier may be added optionally to any literal address.
>    This allows flexibility for unknown future uses.

Regards, K.

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Karl Auer ([email-masked])
http://www.biplane.com.au/kauer

GPG fingerprint: AE1D 4868 6420 AD9A A698 5251 1699 7B78 4EEE 6017
Old fingerprint: DA41 51B1 1481 16E1 F7E2 B2E9 3007 14ED 5736 F687

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 Jan 2012 11:37:23 +1300

Hi,

I've only seen one comment on this question. Any more, or should
the authors just decide?

Regards
   Brian Carpenter