Subject: FW: New Version Notification for draft-tsou-6man-hbh-header-update-00.txt

From: Tina TSOU <[email-masked]>
Date: Mon, 05 Mar 2012 04:48:31 +0000

For your comment.
http://datatracker.ietf.org/doc/draft-tsou-6man-hbh-header-update/

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, March 04, 2012 8:45 PM
> To: Tina TSOU
> Cc: Sreenatha setty b
> Subject: New Version Notification for draft-tsou-6man-hbh-header-update-
> 00.txt
> 
> A new version of I-D, draft-tsou-6man-hbh-header-update-00.txt has been
> successfully submitted by Tina Tsou and posted to the IETF repository.
> 
> Filename:	 draft-tsou-6man-hbh-header-update
> Revision:	 00
> Title:		 Update to the processing of the Hop-by-Hop Options extension
> header
> Creation date:	 2012-03-04
> WG ID:		 Individual Submission
> Number of pages: 5
> 
> Abstract:
>    The Hop-by-Hop Options header is used to convey optional information
>    that must be examined by every node along a packet's delivery path.
>    This document updates RFC2460, removing the requirement that source
>    nodes must process the Hop-by-Hop extension header, on the basis that
>    it imposes a performance impact with no advantages.
> 
> 
> 
> 
> The IETF Secretariat

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 05 Mar 2012 08:04:17 -0500

It seems likely to me that an efficient host implementation can meet the 
existing requirement relative to sourcing a packet with such options 
without noticeable load.  So there does not seem any point in relaxing 
the requirement.
And technically, if the host puts ina strict source route, and the first 
hop is not directly reachable, it really does need to drop it.  So 
keeping the existing text has a minor benefit.

Yours,
Joel

On 3/4/2012 11:48 PM, Tina TSOU wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>