Subject: Why one Internet?

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 16:24:34 +0300

Hi,

In my opinion, we can add one more Internet when necessary, then another
one etc.

We can have as many Internets as we need, all different.

We just need a *network of Internets*.

The first (current) Internet is an IPv4 Internet.
The second Internet can be an IPv4 Internet too. In this case we would have
2 IPv4 Internets.
Obviously, in this case, we would have the same addresses used by two
different nodes in
the two Internets. I think it is possible to locate the node we need. I am
not here to discuss
these details.

The second Internet can be an IPv6 Internet.

The second Internet can be a IPv7 Internet.

The second Internet can be IPv6 but we may have a third one which is IPv7
etc.

We just need a network of Internets, all possibly different.

Pars
http://content-based-science.org/

---

From: Randy Bush <[email-masked]>
Date: Tue, 10 Apr 2012 22:50:08 +0900

> ...

in the words of vince perriello, send code

randy

---

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 16:51:23 +0300

Why me?

---

From: Randy Bush <[email-masked]>
Date: Tue, 10 Apr 2012 22:53:27 +0900

> Why me?

because you are the nut case who proposed it

---

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 16:58:50 +0300

No sir "not questioning" is being the nut case. Sorry.

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 10 Apr 2012 10:04:12 -0400

plonk

On Tue, Apr 10, 2012 at 9:58 AM, Pars Mutaf <[email-masked]> wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Lixia Zhang <[email-masked]>
Date: Tue, 10 Apr 2012 07:09:19 -0700

the Internet is a means to communicate.
and the market drives for most effective/efficient/economical communication systems (there are tradeoffs between the adjectives)
wonder if you could help explain how your picture of "network of Internets" would be more effective and economical (than what we have now)

Lixia

On Apr 10, 2012, at 6:24 AM, Pars Mutaf wrote:

> Hi,
> 
> In my opinion, we can add one more Internet when necessary, then another one etc. 
> 
> The second Internet can be an IPv4 Internet too. In this case we would have 2 IPv4 Internets. 
> Obviously, in this case, we would have the same addresses used by two different nodes in 
> the two Internets. I think it is possible to locate the node we need. I am not here to discuss 
> these details. 
> 
> The second Internet can be IPv6 but we may have a third one which is IPv7 etc. 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 10 Apr 2012 15:31:04 +0100

Lixia,

The original note says "I think it is possible to locate the node we need."

So, the idea is apparently not to divide the Internet - it is simply to deal
with the fact that addresses would be ambiguous. Since we have 15 years
experience of the pain caused by ambiguous addresses, and a perfectly good
128 bit address space that avoids any need for ambiguous addresses, I don't
see the point. It isn't even worth sending the code.

Pars,

Your original note also says "I am not here to discuss these details." Sorry,
but in the IETF it's *exactly* the details that we must discuss; that's our
job. We've been doing so since 1992 to my personal knowledge.

Regards
   Brian

On 2012-04-10 15:09, Lixia Zhang wrote:
> ------------------------------------------------------------------------
>

---

From: Hagen Paul Pfeifer <[email-masked]>
Date: Tue, 10 Apr 2012 16:45:17 +0200

> job. We've been doing so since 1992 to my personal knowledge.

Brian: Pars is a troll, don't feed him. See MANET WG postings ...

Hagen

---

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 17:57:23 +0300

I am here to question:

My question is why IPv6 is the end of the road.

We shouldn't give all the responsibility to a few persons.
We should not be dependent on their decisions.

If the transition to a complete IPv6 network is not possible, then we can
add a new Internet. It can be IPv4, IPv6, or even IPv7.

Pars

On Tue, Apr 10, 2012 at 5:09 PM, Lixia Zhang <[email-masked]> wrote:

> and the market drives for most effective/efficient/economical
> communication systems (there are tradeoffs between the adjectives)
> wonder if you could help explain how your picture of "network of
> Internets" would be more effective and economical (than what we have now)
>
> Lixia
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 10 Apr 2012 08:01:18 -0700

Pars,

This discussion is out of scope for the [email-masked] mailing list.  Please take it elsewhere.

Bob & Ole
6man w.g. Chairs

On Apr 10, 2012, at 7:57 AM, Pars Mutaf wrote:

> If the transition to a complete IPv6 network is not possible, then we can add a new Internet. It can be IPv4, IPv6, or even IPv7. 
> 
> Pars
>

---

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 18:03:03 +0300

> job. We've been doing so since 1992 to my personal knowledge.
I propose have a network of Internets:

Internet1
Internet2
Internet3
...
Interntet_n

In Internet 1 and 2 we may have two nodes with the same address.
The goal is to route the packet to the right Internet. I don't think it is
impossible.

Pars

---

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 18:04:10 +0300

I am not a troll I worked on IPv6 and MANET for longtime.

Now I choose to wake up and question.

Pars

---

From: Lixia Zhang <[email-masked]>
Date: Tue, 10 Apr 2012 08:12:43 -0700

Hi Brian, 

I was not questioning about connectivity (or divide Internet).
I was just looking for an explanation of how the proposal could be MORE effective *and* more economical.

Lixia

---

From: Cameron Byrne <[email-masked]>
Date: Tue, 10 Apr 2012 08:25:19 -0700

On Tue, Apr 10, 2012 at 8:03 AM, Pars Mutaf <[email-masked]> wrote:
>
>
> On Tue, Apr 10, 2012 at 5:31 PM, Brian E Carpenter
> <[email-masked]> wrote:
>>
>> Lixia,
>>

Quite possible. Most people call it CGN.  In fact, the IETF granted a
/10 of IPv4 for this purpose.

CB

---

From: Pars Mutaf <[email-masked]>
Date: Tue, 10 Apr 2012 18:45:51 +0300

> /10 of IPv4 for this purpose.
You mean this one?
http://tools.ietf.org/html/rfc6264

Figure 1 looks like what I am proposing. Right?

If so, we can also have a IPv7 with is, in addition to IPv6 (or directly
IPv7). I have no idea what IPv7
would be and why it would be needed, but it looks like we should be
flexible (to me at least).

Pars

CB
> >> >> The second Internet can be an IPv4 Internet too. In this case we
> would
> >> >> have 2 IPv4 Internets.
> >> >> the two Internets. I think it is possible to locate the node we
> need. I
> >> >> am not here to discuss
> >> >> these details.
> >> >>

---

From: Turchanyi Geza <[email-masked]>
Date: Tue, 10 Apr 2012 18:01:15 +0200

Hello,

yes, address translator and higher level gateways are tools to cope with
the difficulties caused by the address shortage, but

it is difficult to scale these tools

and we can rid of them with the large scale deployment of IPv6 based
Internet.

Less energy consumption, clearer architecture...

I thought this is clear for all of us...

Géza

---

From: Sander Steffann <[email-masked]>
Date: Tue, 10 Apr 2012 20:49:12 +0200

Hi Pars,

> The goal is to route the packet to the right Internet. I don't think it is impossible.

You should talk to Jos Vrancken. He has been talking about such ideas for years.
See http://www.nextgenerationinfrastructures.eu/index.php?pageID=17&itemID=449455

I think you'll get along with him. He also says things like "I am not here to discuss these details." and "I don't think it is impossible." when people ask him about how his ideas could possibly work... It can be fun for theoretical research, but not for running a real world wide network with millions of users...

- Sander

---

From: Carlos Martinez-Cagnazzo <[email-masked]>
Date: Tue, 10 Apr 2012 15:53:37 -0300

Wasn't this what the Internet was supposed to be? I'm tempted to ask how
old you are, but I don't want to be rude.

As the Monty Python would put it: 'You see, the key is in the name -
Inter - net(work)'

:-)

cheers

Carlos

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 10 Apr 2012 14:12:55 -0500

Yes, that was also my reaction. Why one Internet? Because Internet means tying together multiple separate networks. Of course you can have the same addresses on the different networks. Nothing new there either. That's why we have NATs, NAPTs, and IPv6 NPTs.

No one is forcing an ISP or an enterprise network to use a combination of protocols. They can already opt to be IPv4 only, or IPv6 only, or dual stack, or eventually IPv7. Matter of fact, years ago, our enterprise had an assortment of different networks, tied together by Softswitch gateways. IPv4, SNA, DECnet.

Bert

From: [email-masked] [mailto:[email-masked]] On Behalf Of Carlos Martinez-Cagnazzo
Sent: Tuesday, April 10, 2012 2:54 PM
To: Pars Mutaf
Cc: [email-masked]
Subject: Re: Why one Internet?

Wasn't this what the Internet was supposed to be? I'm tempted to ask how old you are, but I don't want to be rude.

As the Monty Python would put it: 'You see, the key is in the name - Inter - net(work)'

:-)

cheers

Carlos

---

From: Pars Mutaf <[email-masked]>
Date: Wed, 11 Apr 2012 10:29:02 +0300

On Tue, Apr 10, 2012 at 10:12 PM, Manfredi, Albert E <
[email-masked]> wrote:

> Yes, that was also my reaction. Why one Internet? Because Internet means
> tying together multiple separate networks. Of course you can have the same
> addresses on the different networks. Nothing new there either. That’s why
> we have NATs, NAPTs, and IPv6 NPTs.****
>
> ** **
>
> No one is forcing an ISP or an enterprise network to use a combination of
> protocols. They can already opt to be IPv4 only, or IPv6 only, or dual
> stack, or eventually IPv7. Matter of fact, years ago, our enterprise had an
> assortment of different networks, tied together by Softswitch gateways.
> IPv4, SNA, DECnet.****
>
> **
>

I have no problem with anyone. I am facing my own illusions.

Here is my conclusion after years of work on IPv6.

IPv6 guy is just a salesman.

But the salesman thought the entire world should buy his product.

The product cannot change.

There is no other product.

Not even sure the product was really needed.

Complete delusion.

Pars

> **
>
> Bert****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Carlos Martinez-Cagnazzo
> *Sent:* Tuesday, April 10, 2012 2:54 PM
> *To:* Pars Mutaf
> *Cc:* [email-masked]
> *Subject:* Re: Why one Internet?****
>
> ** **
>
> ****

---

From: Mohacsi Janos <[email-masked]>
Date: Wed, 11 Apr 2012 09:53:32 +0200 (CEST)

On Wed, 11 Apr 2012, Pars Mutaf wrote:

> 
> 
> On Tue, Apr 10, 2012 at 10:12 PM, Manfredi, Albert E <[email-masked]> wrote:
>
>       Yes, that was also my reaction. Why one Internet? Because Internet means tying together multiple separate networks. Of course you can have the same
>       addresses on the different networks. Nothing new there either. That?s why we have NATs, NAPTs, and IPv6 NPTs.
>
>        
>
>       No one is forcing an ISP or an enterprise network to use a combination of protocols. They can already opt to be IPv4 only, or IPv6 only, or dual
>       stack, or eventually IPv7. Matter of fact, years ago, our enterprise had an assortment of different networks, tied together by Softswitch gateways.
>       IPv4, SNA, DECnet.
>
>        
> 
> 

Not, but a reasonable technology for go forward with.

> The product cannot change.

Wrong, See evolution of IPv6 in the past 10 years - lot has been changed - 
due to better understanding of requirements and drawback of certain 
solutions.

> There is no other product. 

Yes there are, but ipv6 seems to be most reasonable at the moment.

> Not even sure the product was really needed. 

See ipng work in the late 90's - it was requirement driven.

> Complete delusion. 

Please describe your conception in details - we can compare solutions 
based on technical merits.
 	Best Regards,
 			Janos Mohacsi

---

From: Pars Mutaf <[email-masked]>
Date: Wed, 11 Apr 2012 11:05:40 +0300

On Wed, Apr 11, 2012 at 10:53 AM, Mohacsi Janos <[email-masked]> wrote:

>>      Yes, that was also my reaction. Why one Internet? Because Internet
>> means tying together multiple separate networks. Of course you can have the
>> same
>>      addresses on the different networks. Nothing new there either.
>> That?s why we have NATs, NAPTs, and IPv6 NPTs.
>>
>>
>>
>>
>>      No one is forcing an ISP or an enterprise network to use a
>> combination of protocols. They can already opt to be IPv4 only, or IPv6
>> only, or dual
>>      stack, or eventually IPv7. Matter of fact, years ago, our enterprise
>> had an assortment of different networks, tied together by Softswitch
>> gateways.
>>      IPv4, SNA, DECnet.
>>
>>
>>
>>

Sorry I don't see the problem yet. I wouldn't design a solution nor discuss
its details.

Designing the future makes me suffer.

Pars

---

From: Mohacsi Janos <[email-masked]>
Date: Wed, 11 Apr 2012 10:11:46 +0200 (CEST)

On Wed, 11 Apr 2012, Pars Mutaf wrote:

> 
> Sorry I don't see the problem yet. I wouldn't design a solution nor discuss its details. 
> 

Then, you are probably on a wrong mailing list.

Regards,
 		Janos Mohacsi

---

From: "Greg Kavalec" <[email-masked]>
Date: Wed, 11 Apr 2012 09:51:34 -0500

Avoiding the situation you describe is exactly why "The Internet" was
commercially adopted.

Without One Internet, we will have commercial walled gardens; open
exchange of information will suffer.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Pars Mutaf
Sent: Tuesday, April 10, 2012 8:25 AM
To: [email-masked]
Subject: Why one Internet?

Hi,

The second Internet can be an IPv4 Internet too. In this case we would
have 2 IPv4 Internets. 

the two Internets. I think it is possible to locate the node we need. I
am not here to discuss 

these details. 

The second Internet can be IPv6 but we may have a third one which is
IPv7 etc. 

Pars

http://content-based-science.org/ <http://content-based-science.org/>

---

From: Bob Hinden <[email-masked]>
Date: Wed, 11 Apr 2012 09:09:35 -0700

Pars,

OK, last warning (w/ Area director copied).  If we see any further posts on this (or similar out of scope topics on this list) from you, we will remove your ability to send email to this mailing list.

We also request others to stop responding to this thread.

Bob

On Apr 11, 2012, at 1:05 AM, Pars Mutaf wrote:

> Wrong, See evolution of IPv6 in the past 10 years - lot has been changed - due to better understanding of requirements and drawback of certain solutions.
> 
> 
> 
> Please describe your conception in details - we can compare solutions based on technical merits.
>